"Copy All" button provides no visual feedback

  • 9
  • Problem
  • Updated 3 months ago
In the Editor, click on the "Copy All" link on the right side of the top toolbar. Although it functions properly, there's no visual feedback of the click. That is, nothing about that link changes color. Compare that behavior to the "Share" button next to it. When you click "Share", the button background changes color slightly, thus giving you feedback that the click occurred. But "Copy All" provides no such feedback, causing me to click it multiple times to make sure the click was actually received. Please add some visual feedback to clicking "Copy All".
Photo of rseligman

rseligman

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 9
Photo of Rick Grunwald

Rick Grunwald

  • 1252 Posts
  • 860 Reply Likes
Yes they should fix that
Photo of Rick Grunwald

Rick Grunwald

  • 1252 Posts
  • 860 Reply Likes
If you want a great work around, try the free Arsclip. It is a PORTABLE clipboard manager on steroids
http://www.joejoesoft.com/cms/showpage.php
It will give you any sound file you want when you copy plus you can copy several things at once  ... then go there places and paste them individually. Permanent clips and folders. Shared database (I clip - you paste), replaceable parameters and a lot more that you may never bother with
And it has a very small footprint
Photo of jacklap

jacklap

  • 1 Post
  • 2 Reply Likes
I use "Copy All" frequently at home and work.  If I'm distracted for a moment or two, it's handy to visually confirm I did that operation and now am ready for the next step.  Snag-It 12 worked fine and I see this change in 13 as step back.
Photo of Boswell

Boswell

  • 4 Posts
  • 2 Reply Likes
Either an audible click, or visual indication would be really useful. I would have thought it was a really easy item to fix?

In fact, not having any indication that the image has been copied, it could be really likely one could paste the wrong capture in, say, an email.
(Edited)
Photo of r_samberg

r_samberg

  • 2 Posts
  • 0 Reply Likes
yep same here. Would very much like to MOVE the Copy All button to the top LEFT as well.
Photo of Puteunderarmen

Puteunderarmen

  • 1 Post
  • 1 Reply Like
I just love Snagit, but this is actually one of the things that annoys me as well. I keep clicking on the "Copy All" button 2-3 times just to be sure that I've really done it, I guess every time expecting some sort of standard visual button click respond.

As @Boswell points out, you want to be certain that your pasting the correct clipboard item in e.g. a Skype for Business conversation, where the file is sent immediately after pasting.
Photo of jesseb

jesseb

  • 8 Posts
  • 3 Reply Likes
What is up the Copy All button has still not been fixed! I just downloaded the latest update. Come on how hard is it to make the button change color or something. The "Share" at least opens to a menu. You could add a menu to the Copy All button that would pop out and have on it, "Done" and then go away at least that would be something!
Photo of Boswell

Boswell

  • 4 Posts
  • 2 Reply Likes
I totally agree with the above. Sometimes the Copy All works, sometimes it doesn't. When working quickly it's extremely easy to send the wrong image when emailing.

I don't know too much about coding, but from what I do, the solution is simple, and an elementary extra to add.
Photo of Rick Grunwald

Rick Grunwald

  • 1252 Posts
  • 860 Reply Likes
Control A + Control C works.
I use the Arsclip clipboard manager that gives a sound when something is copied even when the copy all button is pressed
They should add a flash to the button a sound and or a confirmation message that it actually copied 
Photo of H

H

  • 4 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Good Product, however, need to change the Copy All button to provide feedback to ....


Need to change the Copy All button to provide feedback to user that it has been clicked.
Photo of kristin.l.allbright

kristin.l.allbright

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Request: visual feedback for button clicks (like Copy All).

I would like the Copy All button in the editor to change when I click on it.  (I am using V13) I'm not sure if it did in the old version and doesn't in the new one.  I use the dark theme but tried the light and also don't see any click indication.  I tried other programs (MS Office) and clicking on things gives a visual indicator. I find when in SnagIt Editor when I click to copy, I click a few times because I'm not sure if I clicked or not.  Thank you!!
Photo of farukgunes

farukgunes

  • 2 Posts
  • 0 Reply Likes
in version 2018 still Copy All button don't provide any feedback to user that it has been clicked.
Plase improve this.
Photo of Keith.uk

Keith.uk

  • 21 Posts
  • 5 Reply Likes
I came here to create a thread regarding this same problem. For some reason some apparently easy-to-fix problems are just ignored for years. Sometimes the argument is that not many user are affected by the problem. This cannot be the case here. That button must surely be used by a very significant percentage of users.

The real problem here is the often sluggish and unresponsive UI. I often click a button to change tools, attempt to use the new tool, and discover that the button press has not registered and I still have the previous tool selected.
Photo of Boswell

Boswell

  • 4 Posts
  • 2 Reply Likes
Lack of response on the Copy All button was a serious nuisance, but I changed to Mac a few months ago (having used PC from the beginning).  

On a Mac, a flag shoots out from screen top right: "Capture Copied - your copy is ready to be pasted" when using Copy All.

It can't be that difficult to program something like this for PC?

If it is, TechSmith guys, why not explain to us?

(Edited)