"Snagit could not finalize your video capture"

  • 5
  • Question
  • Updated 5 months ago
"The videoURL for the MOV file is inavlid. Please retry your video capture." (actual spelling, btw).

I was finishing a video capture on my screen to create a short video using SnagIt (Mac) 2.3.0, when I got the above error message. How do I fix this? This was my first attempt using the video capture feature.

Photo of Amy

Amy

  • 8 Posts
  • 3 Reply Likes

Posted 5 years ago

  • 5
Photo of Amy

Amy

  • 8 Posts
  • 3 Reply Likes
Hello, hello? 
Photo of Jo Po

Jo Po

  • 3 Posts
  • 1 Reply Like
I have this too.  I'm using Snagit for Mac v3.3.3 and I get the same error message - still with same spelling error.

Photo of Amy

Amy

  • 8 Posts
  • 3 Reply Likes
I took this issue directly to Support and it is now resolved. The problem was permissions. The folder that SnagIt was attempting to save the video to didn't have the right Read and Write permissions. I'd check that first. 
Photo of Jo Po

Jo Po

  • 3 Posts
  • 1 Reply Like
Thanks Amy - do you have any pointers on which directory it's attempting to save the video to?  I haven't been prompted to save it anywhere by the time it crashes.
Photo of Amy

Amy

  • 8 Posts
  • 3 Reply Likes
Hi Jo Po,

Under /Users/yourusername/Documents/Snagit/, get info about the SnagIt folder, and check under Sharing & Permissions for your username with Read & Write privileges. If it doesn't, add it. If this doesn't resolve the issue, I'd take it directly to Support. Hope this helps!

Amy
Photo of Jo Po

Jo Po

  • 3 Posts
  • 1 Reply Like
Thanks Amy - my issue must be similar but different.  my copy of /Users/yourusername/Documents/Snagit/ - is correctly permissioned. I'll wait for support to respond to my ticket.
Photo of Eliana

Eliana

  • 4 Posts
  • 0 Reply Likes
There has been no official response to this?
Photo of Joseph Sip

Joseph Sip

  • 2 Posts
  • 0 Reply Likes
Ummmm.... it appears this issue is happening again. I am litterally getting the exact error message in the screenshot at the top of this conversation thread...
Photo of qasair

qasair

  • 2 Posts
  • 0 Reply Likes
It was folder permissions error for me. Try giving permissions or changing the location in Preferences -> Advanced -> Autosave location . select some other/newly created folder, it will start working.