Add activation snap to selection of objects in timeline

  • 1
  • Idea
  • Updated 3 years ago
Often (more than 60 % of all times) it happens to me that when I'm selecting an object in the timeline, I'm also moving it a tiny bit.

This is rather annoying because this behaviour destroys object arrangements I've made.

Hence, I'd very much like to suggest to add a movement threshold to selecting objects: When activating an object by clicking and holding down the mouse button, don't start a movement until a certain amount of movement has been reached. From that moment on (or as soon as the mouse button gets released) this particular "activation snap" for that object should be deactivated for as long as that object is being active.
Photo of Axel

Axel

  • 123 Posts
  • 20 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of kayakman

kayakman, Champion

  • 6861 Posts
  • 2187 Reply Likes
best practice to avoid these unintended displacements is to work at high zoom in on timeline

this issue too gives me fits, but it is mostly a user/mouse interaction issue for me

I use an optical, wireless mouse; the act of clicking left mouse button also imparts a small backwards kick to the mouse [geometry re finger tip, button, and mouse case, plus mouse slides easily], which CS registers as a move [mouse button down = selected]

I always have to be extra careful when making selection/clicks in CS as it is very sensitive

if I hold down mouse with left hand while clicking with right hand = never an issue
Photo of Axel

Axel

  • 123 Posts
  • 20 Reply Likes
Hi Kajakman,

sure, but this isn't kind of a user's problem to deal with.

If the design and reality differ, I suggest reality to win. The software should take care that physical nexus is not a problem.

Other graphical tools, like the CorelDRAW Graphics Suite, for example, do provide such initial threshold. So it is not uncommon to have this.

One more suggestion here: Holding down the CTRL key should disable the suggested initial snap, like it does with all the other snaps in Camtasia Studio, too.

Cheers,
Axel
Photo of Axel

Axel

  • 123 Posts
  • 20 Reply Likes
*ping*

After three years of Techsmith Camtasia downtime I'd like to bring this issue up again for Techsmith to improve.

I'm working with a high resolution mouse here (1,600 dpi). The current behaviour of Camtasia Studio is making me nuts. (Amongst other issues that haven't been worked on by Techsmith for the last number of years.)
Photo of forevermaat

forevermaat

  • 13 Posts
  • 0 Reply Likes
with camtasia 9, I was having this problem.  The workaround is to hold CTRL and then click on object.  It will not "move a little" as others have noticed.  This is especially important for text objects, that are now only editable directly on the canvas.  The object would quickly move (even just a pixel or two) to snap to some other object border.  Pissing me off.

Then I noticed that when you hold ctrl, it disables the snap objects.

I do wish TS added in an option with xxx ms delay in which auto snapping would be activated place.  So those who are double-clicking to select textbox and such do not move their objects unintentionally.