All menus and tool bars disappeared in 2017 SnagIt Editor. Re-installations don't help.

  • 1
  • Question
  • Updated 4 months ago
I tried everything TechSmith recommended here: https://support.techsmith.com/hc/en-us/articles/115006194148?input_string=snagit+editor+menu+bar+is+all+greyed+out
I uninstalled, rebooted, and reinstalled SnagIt 2017 numerous times tonight. I checked Dell for new drivers. I removed one external monitor at a time. Nothing worked!  I even tried googling the issue. Why isn't the problem fixed yet?  Are there any workarounds out there that have helped you other than uninstalling and reinstalling which isn't doing the trick with my new laptop  (although that did fix the problem 2 days ago, but apparently only temporarily).




Photo of casa.de.seto

casa.de.seto

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
Let Techsmith figure it out. You have done all you can do.
You can Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Chat Support Hours.

You can reach the “CHAT” Support Team for assistance from

 6:00 AM to 9:00 PM ET, Monday-Friday

 Saturday from 12:00 PM to 4:00 PM ET.
Photo of casa.de.seto

casa.de.seto

  • 2 Posts
  • 0 Reply Likes
I tried again, and this finally seemed to fix (hopefully permanently this time instead of for just a couple days) the problem:

Reset configuration files

This process will reset some of the configuration files in Snagit, which can help in some cases if they have become corrupt.

Warning! This process will reset your Custom Tool Bar, QuickStyles, QuickEffects, Capture Presets, Share History, and Program Outputs.


  1. Close out of Snagit and make sure it is not running at all. Make sure it is not running in your system tray either.
  2. Hold down the Windows key on your keyboard and then hit the R key to open the run window:
  3. Type the following and then hit enter: %localappdata%\techsmith\snagit\<br><br><img src="https://support.techsmith.com/hc/article_attachments/115010601248/2017-04-20_14-43-40.png" alt="2017-04-20_14-43-40png"><br><br>
  4. Cut and paste all of the XML files here to your Desktop (or some other safe location).

    2017-04-20_14-45-55gif

  5. Reopen Snagit and see if it works.
Photo of Joe Morgan

Joe Morgan

  • 5637 Posts
  • 2924 Reply Likes

It looks like the zoom level of your monitor may be a factor.

That Welcome screen in your screen capture doesn't normally fill the entire work area. That, makes me think your monitors zoom level is well above 100%. That shouldn't prevent the menu from displaying like in the image below.

This is my monitor set to 175% zoom on a 1920 x 1080 monitor.



Maybe.If that's the case.If you set the zoom level to 100% and the menu comes back. Then, you can set the zoom back to whatever level your more comfortable with, and the menu won't disappear.Or chose a slightly lower setting for now, and report the issue to tech support.

Regards,Joe
(Edited)
Photo of mchamberlain

mchamberlain

  • 1 Post
  • 0 Reply Likes
That brought mine back up. It has worked fine for months. Must be something buggy. I have 2018 version...