Ascii characters become chinese

  • 2
  • Problem
  • Updated 4 weeks ago
Hi. When I type a character such as "→" using ascii code 282, it comes out as a chinese character.  The font automatically changes to SimSun and can't be changed to anything else.  Anybody know how to fix this behavior?
Photo of Quark Flux

Quark Flux

  • 5 Posts
  • 0 Reply Likes
  • confused

Posted 2 years ago

  • 2
Photo of Rick Grunwald

Rick Grunwald

  • 1275 Posts
  • 878 Reply Likes
Confirmed here  and that sounds like a bug that needs to be reported. 
When you put it in the bug section, report back here and I will support it

I just tried some Cyrillic and that is the same. If you use character map to select the letter then copy the LETTER it works ok but inputting by ASCII codes fails totally
(Edited)
Photo of Rick Grunwald

Rick Grunwald

  • 1275 Posts
  • 878 Reply Likes
Ok there is no bug category as such so hopefully a company rep will find it here
Photo of Robert R.

Robert R., Online Community Admin

  • 1467 Posts
  • 418 Reply Likes
Hi there!

This certainly does not sound like the intended behavior and per the frontpage here at the forums, you'll want to open a Support Ticket so our agents can test the issue, then escalate it to development for logging as an issue.

-Robert
Photo of Cindy Kendall

Cindy Kendall

  • 2 Posts
  • 3 Reply Likes
This is a major problem for me too - I work in the Spanish language and use the ASCII keys extensively. Going to open a support ticket.
Photo of Rick Grunwald

Rick Grunwald

  • 1270 Posts
  • 875 Reply Likes
It is definitely a bag
Photo of Cindy Kendall

Cindy Kendall

  • 2 Posts
  • 3 Reply Likes
Confirmed. Sadly, no estimation on a fix. Here is the response to my support ticket:

Hello,

Thank you for contacting us. This appears to be a bug in Snagit and our developers are working on this but unfortunately I do not have a time frame as to when this will be fixed.

Please let me know if you have any questions.

Kind Regards,
Jason
Technical Support Specialist
Photo of Quark Flux

Quark Flux

  • 5 Posts
  • 0 Reply Likes
I was really hoping this would be fixed in Snagit 2019, but alas we still can't use ascii codes.  Snagit doesn't show Chinese characters when typing ascii codes, but it just gives you either an empty rectangle character or a rectangle with a question mark inside.  Interestingly, the Chinese characters show up on the banner of the "now printing" message box.