Audio and video not syncing in the timeline..Sampling Rate issue?

  • 1
  • Question
  • Updated 2 months ago
The audio is lagging on imported videos.  The audio sampling rate on my camera is set at 48kHz, if it was set at 44kHz, would this correct the problem?  For reference, I am using Movie Pro software on my iPhone 11.  Uploading to Google Drive, and importing from there.  I end up having to separate audio and video, to manually sync them every time.  The video clips range from under a minute to 5-8 minutes generally.
Photo of jsaunders

jsaunders

  • 3 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 9088 Posts
  • 4787 Reply Likes
I hate to state the obvious.
Why don't do a test recording at 44.1 kHz and see if it works.

I say this because Camtasia loves 44,100 Hz.
It prefers .wav

I have no Idea if it will help or not?

If you could share the results of a test.That would be great {:>)

Regards,Joe
Photo of rg

rg

  • 323 Posts
  • 251 Reply Likes
I doubt that changing the sampling rate would help.  Sampling rate is kind of like the audio equivalent of color depth -- higher sampling provides more audio slices per second.  However, it would not change the timing unless there is something about the recording method which is affected by audio sampling rates (which I've never heard mentioned).
However:  There is a thing called latency.  When you record to a computer while it's playing video and/or audio, the computer is trying to switch (incredibly rapidly) between two different tasks, playback and recording.  The difference (the lag) between the two, measured in microseconds, is latency.
For example:  Suppose I have a music track recorded on the PC.  I want to sing along as I play it back.  When I'm done, there is a 200msec delay that sounds like I'm lagging behind the music bed.  So I have to drag that track up to get it back in sync.
This is also not unheard of in imported video clips.  I am working on a project with two cameras recorded at the same time in the same location.  If I play camera 1, everything is in sync; if I play camera 2, whatever internal video or audio encoding was done (or possibly a feed from a mixer) the audio is around 1-2 frames off (ahead, I think).  It's due to how that camera recorded the video.  So I end up dragging one camera up by 1-2 frames (or 3? I don't recall off-hand).  The audio between the two cameras no longer looks in sync but the video is perfect between them.
I know of nothing that guarantees this won't happen again, and no software that automatically corrects a camera's wandering encoding.
Photo of jsaunders

jsaunders

  • 3 Posts
  • 0 Reply Likes
Thanks for the feedback guys.  I did try recording at 44, no change.  I have been using AirPods, through the Bluetooth connection.  I used the phone mic today, and no delay.  So the issue seems to be in the Bluetooth connection, or the AirPods possibly?  I still would like to use the Bluetooth, or some external mic, as the sound quality sucks at and distance other than right in front of the camera/phone/mic.
Photo of Joe Morgan

Joe Morgan

  • 9088 Posts
  • 4787 Reply Likes
Wireless mics are not support by Camtasia......
Heres a support article..........https://support.techsmith.com/hc/en-us/articles/203729948-Microphone-To-Use-With-Camtasia

The reason I suggested trying it? SnagIt's screen recorder used to keep audio synced better if I used 44.1
When you pause and re-start a recording several time. Switching the mic setting helped.

Camtasia has never kept sync if you pause a recording several times.
It was a shot in the dark suggestion.
Glad you got it resolved.

Photo of jsaunders

jsaunders

  • 3 Posts
  • 0 Reply Likes
I used my Bluetooth mic with the Movie Pro recording Software on my iPhone, then uploaded the recording to Google Drive.  Imported the entire recording into Camtasia.  The uncut video was out of sync to start, but only upon the import into Camtasia.  I can play it back in Movie Pro, and it is in sync, or in my camera roll, where it saves as it records, and it’s still in sync.  I don’t have the problem when not using the Bluetooth mic, but again, it’s only when importing to Camtasia, and either way, the audio is already there, so I’m not trying to use the Bluetooth within Camtasia.  Problems still not solved, but I’m still working on it.  I’ll let you all know if I figure it out.