Black Screen on Capture using Snagit 10

  • 5
  • Problem
  • Updated 7 months ago
  • Solved
Sometimes when I try to capture a region of the screen, the screen goes completely black once I click the capture button. Nothing gets captured. Any ideas? I'm using Windows XP and Google Chrome.
Photo of Rob Phillips

Rob Phillips

  • 2 Posts
  • 0 Reply Likes

Posted 8 years ago

  • 5
Photo of Mike Curtis

Mike Curtis, Employee

  • 2205 Posts
  • 214 Reply Likes
Hi Rob,

Let's try disabling your hardware acceleration. You can see how to do that here: http://techsmith.custhelp.com/app/ans...

Our Tech Support team may have some additional advice in case that's not the root cause. You can reach them at: http://techsmith.custhelp.com/app/uti...

Mike Curtis
Photo of GregoryMcDanielJr.

GregoryMcDanielJr.

  • 8 Posts
  • 12 Reply Likes
I have a GREAT solution! I literally spent HOURS using Google and restating my search. I tried to update the driver for my video card and then, I tried to figure out why it wouldn't update properly. I spend countless hours messing with settings, reading, throwing stuff, and just plain loosing my marbles! Well, FINALLY, I found something about Zone Alarm (A security suite) and I transposed the idea and went into my Webroot settings and chose the correct option to allow access to Snagit. EUREKA! There was also an option for the other capture programs I tried. It works just fine! Ok, first I will explain. Webroot, Zone Alarm, and I'm sure Kaspersky, Norton, and other anti-virus programs block the use of Snagit and other capture program that try to take screenshot of website with vital info on them. For instance, anything you typed like email, bank account, google searches, or any site in general where you entered anything, will be unable to be captured. The reason for this, is to stop hackers from remotely taking a screen shot of lets say your Chase account information. If the hacker can take screenshots without your knowledge, they can get important info to do bad things with your account. So you have to find the setting to allow Snagit.exe or which ever program you use to allow the captures. Once done, you will be able to take screenshots again. YAY! I will explain how to do this in Webroot Secure Anywhere Complete. Keep in mind no matter which antivirus you use, there should be a way to do this. If you can't google search how, contact your manufacturer. Ok, here goes:
Steps:
1. Open Webroot Secure Anywhere Complete. (Use the desktop shortcut if that's easy or use Start>All Programs>Webroot SecureAnywhere folder>Webroot SecureAnywhere icon.)
2. Click the Identity and Privacy tab on left.
3. Click on the "View/Edit Applications" link.
4. Scroll until you see the name of your screen capture program. In my case its under "snagit32.exe in C:\program files (86)\techsmith\snagit 10".
5. In the three columns there are buttons you can choose. They are: "Protect" "Allow" or "Deny". In my case all my programs were selected as "Deny". Click on the bubble in the "Protect" column. Not sure what the difference between this column and "Allow" are, but I chose "Protect.
6. Click close when done.
7. Close Webroot, since you are done.
8. Check to see if it worked by trying the same page that went black before.
This should work. It sure did for me! I decided to share this post so I can save you all the hours of net digging I had to endure. Good Luck!
Photo of Rob Phillips

Rob Phillips

  • 2 Posts
  • 0 Reply Likes
My problem was also Trusteer, recommended for security purposes by my bank.  I went to the site recommended by tomxpg http://goo.gl/tZ1TYt .  In addition to that recommendation, I also had to change the "Block Screen Capturing" switch to "Never".  Problem solved.  Thanks to all.
Photo of ellen

ellen

  • 1 Post
  • 0 Reply Likes

Fixed Black Screen problem on 6-1-15 by following these steps for my current version of Webroot:

Click Green Webroot icon on desktop or open in Programs

Go to:  Identity Protection – Settings – Application Protection

Scroll down to SnagIt.  Click on box that says “Protect” instead of “Deny” 

Problem was solved for me.

I am SO glad I stumbled across Greg's suggestion to look at Webroot as the source of the problem!!
Photo of lrex@genfinplan.com

lrex@genfinplan.com

  • 1 Post
  • 1 Reply Like
I switched from Webroot to Kaspersky last week because of many issues I was having with Webroot.  I didn't have the black screen problem before but had it today.  I had another window open with Kaspersky's Safe Money option.  Once I closed that window the screen blacking problem went away.
Photo of Gundega Korsts

Gundega Korsts

  • 1 Post
  • 0 Reply Likes
Thanks to lrex! -- Closing the Kaspersky Safe Money window worked for me, too. I'd been wondering why setting Techsmith as an allowed program or process in both Kaspersky and Malware Bytes wasn't fixing the problem. Blocking screen capture in Safe Money makes sense, but now I know to close the window as soon as I'm done. It's only a minor inconvenience not to do my own screen recording of financial transactions; now I print to pdf instead.
Photo of istjgeek

istjgeek

  • 1 Post
  • 0 Reply Likes
Thank you! Running SnagIt 13.1.1 on Windows 10 and Webroot SecureAnywhere v9  was the issue for me. Allowed the app and screenshot previews work again!
(Edited)
Photo of Francis Rosete

Francis Rosete

  • 1 Post
  • 0 Reply Likes
Hi, I had the same problem and work on the resolutions and scaling but it didn't help. There's a trick that I accidentally  discovered not sure if it also works for you. If you right click your mouse go to Graphic options > output to >Extended desktop > Digital Display + Built-In display. ( It will swap your monitor from your main screen. Do the same thing but this time choose Built In Display + Digital Display. It solves my blurry apps and the black SnagIt capture.