Borders saved as Quick Effects are not retained

  • 3
  • Problem
  • Updated 7 months ago
  • (Edited)
I have a specific border that I apply to most of my captures and I save it as a Quick Effect. However, it's only saved until I exit SnagIt; upon re-starting it, the border Quick Effect is gone. The Quick Effects for other effects are saved permanently, so why doesn't this work for borders?

I realize that I could set a default border in Effects, but I typically crop and/or resize captures prior to using them, so a default border wouldn't help me.

I'm running SnagIt 13.1.0 (32bit) on Windows 7 Pro w/SP1
Photo of brian.nystrom.nh

brian.nystrom.nh

  • 6 Posts
  • 1 Reply Like

Posted 2 years ago

  • 3
Photo of Mary Wilken-Myers

Mary Wilken-Myers

  • 30 Posts
  • 6 Reply Likes
I'll be following this thread too as I've experienced the same issue and thought I was doing something wrong lol glad you posted this Brian! :) thank you!
Photo of brian.nystrom.nh

brian.nystrom.nh

  • 6 Posts
  • 1 Reply Like
Misery loves, company, right? 
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes
I've got a similar problem.  I can't add Edge effect items to Quick Effects. 

Hey, SnagIt! Can we get this fixed? 
Photo of brian.nystrom.nh

brian.nystrom.nh

  • 6 Posts
  • 1 Reply Like
Really, some kind of response would be greatly appreciated. Silence is not a virtue in Customer Service. 
(Edited)
Photo of Robert R.

Robert R., Online Community Admin

  • 1465 Posts
  • 414 Reply Likes
Hi all;

I would like you to completely exit Snagit (via File - Exit Snagit) and the Snagit 13 Editor (via File - Exit Snagit Editor), then go to C:\Program Files (x86)\TechSmith\Snagit 13\ and first right-click on Snagit32.exe and choose "Run as Administrator" then right-click on SnagitEditor.exe and choose "Run as Administrator"

Once both the core app and the Editor have launched with elevated privileges, I would like you to add an edge effect quick style (note, you may need to alter the quickstyle window size, see: https://www.screencast.com/t/3qsRXtqgfl6X ). Once it has been added, please go to File - Exit Snagit Editor then File - Exit Snagit in the core Snagit app.

Once both have been exited in this fashion, please restart Snagit normally.

Is the quickstyle that you added included in the edge styles area?

-Robert
Photo of brian.nystrom.nh

brian.nystrom.nh

  • 6 Posts
  • 1 Reply Like
Yes, that worked! I restarted SnagIt multiple time and also started the Editor alone, and it still worked. I'll reboot the system when it's convenient and test it again. 

Thanks!

UPDATE: It survived a reboot, so apparently the border is saved unless I remove it.
(Edited)
Photo of Benjamin Day

Benjamin Day

  • 33 Posts
  • 12 Reply Likes
It looks like it worked for me, too!  Thanks!

I'm curious -- why did it work when elevated? 
Photo of ducatistii

ducatistii

  • 1 Post
  • 0 Reply Likes
Me three! Thanks
Photo of Leslie Griffith

Leslie Griffith

  • 1 Post
  • 0 Reply Likes
This worked for me as well!  Thanks.
Photo of jared.hess

jared.hess

  • 12 Posts
  • 4 Reply Likes
Does this mean we should launch snagit all the time with elevated privs any time we want to add something to Quick Effects? Anyway, I went to my shortcuts have have modified them so that they'll always run as administrator just in case.
(Edited)
Photo of Stu Andrews

Stu Andrews

  • 1 Post
  • 0 Reply Likes
Hi TechSmith folks, can we please get a response to this, whether we need to run elevated if we want to custom-add to quick effects?