callout not wrapping text and dynamically changes the size of the callout

  • 2
  • Question
  • Updated 1 month ago
I just got a new Macbook Pro and callouts are behaving differently. My old Mac is on version 2019.1.4 and I am on 2019.1.5. On the newer version when I create a callout and start typing it used to wrap the text. Now its no longer wrapping and instead dynamically changing the size of the callout to the point its very wide. Then I have to do a bunch of scrolling to resize the callout. How do I configure the callout to wrap text?


Photo of smoisan

smoisan

  • 2 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 2
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1239 Posts
  • 312 Reply Likes
Hi,

So sorry about this, this is a bug that was introduced in 2019.1.5. We are working on a fix for 2019.1.6, but if it's causing you too much trouble you can download 2019.1.4 and then wait to update once 2019.1.6 is live.
Photo of Kevin McGuire

Kevin McGuire

  • 11 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Create or Edit Text Automatically Expands Container Beyond Canvas.

After the most recent update to Snagit 2019.1.5 (94043) on Mac, every time I create or edit a text field, it expands beyond the edge of the canvas and remains expanded not to be undone. It makes composing or editing very difficult and requires manually repositioning and resizing the text field on every edit. It often results in the canvas expanding which means more rework. Yesterday notating a single screenshot took several times as long as it would have previously because of this behaviour.

The expected behaviour is that once a text field is sized, text should automatically flow to the next line if it exceeds the width and overflow beyond the bottom would be hidden. New text fields that have not been sized should not exceed the canvas width. This has been the behaviour prior to this update.

Is this a known issue or am I missing a setting or control? I've searched in vain for a setting that might resolve the issue. Thank you.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1229 Posts
  • 307 Reply Likes
Hi Kevin,

Sorry about this issue! I merged this conversation with another user who had reported it, I will report back when the issue is fixed.
Photo of Rick Stone

Rick Stone

  • 5775 Posts
  • 2756 Reply Likes
I'm a PC user so I'm unsure if this setting is available on a MAC.

On a PC, from the editor window you can click Edit > Editor Preferences... > Editor tab and we see an option there that governs whether the canvas automatically expands to accommodate objects. 

If you have that on the MAC, it may help address the canvas issue.
Photo of smoisan

smoisan

  • 2 Posts
  • 0 Reply Likes
Thanks Rick. TechSmith support contacted me and said it's a bug that will get fixed in the next release. Fingers crossed
Photo of Bob T.

Bob T.

  • 1 Post
  • 0 Reply Likes
I'm having the same text wrapping issue described above. Started with the last Mac release. Please push out this patch as soon as possible. Thanks! :)
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1239 Posts
  • 312 Reply Likes
Hi folks, 

This issue should be much less prevalent in our 2019.1.6 update, let us know if you run into any problems.