Camtasia 2018 Faster Project Rendering, as compared to WHAT?

  • 2
  • Problem
  • Updated 4 months ago
I'm dealing with five 1 minute video clips. I move a clip to a track, it stops at the top track, I have to wait 30 - 60 seconds, then I can move it to a lower track. This time period, 30 - 60 seconds is happening on everything I do. Then rendering is slower than Camtasia 8. Moreover, your ads on youtube (which you apparently spent a bunch of money on, and NOT on development, because I can't watch youtube vids any more without seeing your ads EVERY TIME, and at the switch to a new video when the original one finishes, another Camtasia ad) talk of intros and outros, as if there's a number to choose from, but there's like THREE, and the rest say "subscription." That means I have to pay to get the good ones? I do my own anims for intros, outros, but takes awhile and I'm not getting much vids produced, so that's one reason I upgraded. But for all operations except the intros, etc, I'm using Camtasia 8 (because 2018 is proving to be a dog), but the intros for 2018 aren't good enough to warrant the upgrade, and the performance is so disappointing. Please tell me how to pursue refund for upgrade. There's a reason I went to Camtasia from Adobe Premiere some years ago, but I don't see a difference between Premiere and this 2018 Camtasia.
Photo of gregpardee1

gregpardee1

  • 2 Posts
  • 0 Reply Likes
  • DISAPPOINTED

Posted 4 months ago

  • 2
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
what type are your video clips: dimensions, frame rate, file type, etc.?

You're using CS8? Is that where the issue happens?

what are your PC system  specs?

regarding adding clip to top track them moving below, perhaps try this ...

with clip on top track, select clip on timeline; in canvas, right click and use send back/send to back

does that work faster?

regarding the CS2018 assets thing, recommend you contact free tech support
Photo of Dubie

Dubie

  • 961 Posts
  • 741 Reply Likes
Have you tried changing Hardware acceleration to "Use software-only mode"

Edit>>Preferences>>Advance tab>>Hardware Acceleration

Depending on your computer specs/video card it may help.

:)
Photo of rg

rg

  • 104 Posts
  • 55 Reply Likes
I've had a similar experience with v8.6 project files that were corrupted in some way.  Sometimes it's solved by re-saving the project with a new name, closing Camtasia, emptying all TEMP files, and then re-starting Camtasia.  (I would also recommend turning around in place 3 times and spitting, but this isn't in the manual.)

My PC is running Win10 Pro 64-bit with 32GB RAM and a core i7 processor running at 3.4GHz, with over 1TB of space available on the internal hard drive.  So I guess I'm saying this ought not to happen.  But it does.
(Edited)
Photo of Bob Lewis

Bob Lewis

  • 348 Posts
  • 172 Reply Likes
You have a great PC. There is a however. Camtasia 8.x is a 32 bit software and therefore under ideal circumstances it can only use 4GB of RAM which can get filled quicker than we want.
I like your ( recommend ... ).   I tried it but it did not work for me.