Camtasia 2018 Recorder - Is anyone else experiencing a few black frames near the start?

  • 1
  • Problem
  • Updated 4 months ago
If I could reproduce this consistently I would / will report it to Techsmith Support but for the moment I'm curious about whether anyone else is noticing it and whether it may therefore be a general problem or something specific to my system.
I just recorded a couple of tracks which, when I played them back, seemed to flicker for a moment. Certainly enough to provide a "whoa, what was that?" moment.
It seems to be always within the first second or so of a recording. When I step through the recording frame by frame, in one example frames 1 through 12 are normal, frames 13 and 14 are black.
In another one, frames 1 through 9 are normal, frames 10, 11 and 12 are black. In yet another, frames 12, 13 and 14 are black.
The only one that HASN'T had it this afternoon was one where I was recording the Camtasia editor playing back a project.
The sound seems unaffected.
Is this something that anyone else has noticed? (I'm on the 2018.0.1 patch.)
Photo of Mal Reynolds

Mal Reynolds

  • 372 Posts
  • 244 Reply Likes
  • Bemused, since I can't think of a reason for this happening seemingly only in the first second.

Posted 4 months ago

  • 1
Photo of Dave

Dave

  • 4 Posts
  • 0 Reply Likes
Yes I have had that problem and no I don't think it is a bug with the Camtasia software.  In my case I was blaming Windows 10 although that might be unjust.  There are a variety of reasons why Windows 10 can just start doing other 'more important' things and our programs are left waiting.  Your initial delay might be because it hasn't yet allocated enough memory or created the 'sand-box' for your program to run in.  Once that's done, your program runs faster.  The reasons I think blaming Windows 10 might be unjust is, that operating system is calling DLL files in a different way and older programs on the system might not be compliant with the overall design.  In my case, Microsoft Mail which worked fine in Windows 7, always seems to be involved when my system is going slow.  Initially I used the free software (Microsoft site) Process Monitor and Process Explorer, which with a learning curve will show you what is hanging. It was always EXPLORER.EXE, which is the operating system and I couldn't dig any deeper, but now I think it's the new format for calling DLL files and legacy software which hasn't been updated to play ball. 
Photo of kayakman

kayakman, Champion

  • 6250 Posts
  • 1834 Reply Likes
this is a know issue per tech support; I get it consistently with trec captures, always 1 to 3 black frames at start of capture

tech support's fix for me was to have me edit the registry to change Recorder from hardware to software mode; it worked

see https://support.techsmith.com/hc/en-us/articles/215138598
Photo of Joe Morgan

Joe Morgan

  • 5638 Posts
  • 2924 Reply Likes
I see you are correct kayakman
I just ran 5 straight tests of 10 second recordings. All of them had a few black frames.

I never noticed it because I start my recordings and don't talk for at least a couple of seconds.
I trim the start of my recordings close to the waveform without viewing them.

Now that I'm thinking about it, it seems like Camtasia 8 had the exact same problem long ago. It didn't bother me then either.
Photo of Mal Reynolds

Mal Reynolds

  • 372 Posts
  • 244 Reply Likes
Much appreciated.

It's annoying because I'll have to either:(a) Modify my recording technique and clip every recording; or(b) Take the chance that going to software mode won't cause any other side effects, and because(c) I've never had this problem with any previous version of Camtasia.