Camtasia 2019 upgrade - not good

  • 2
  • Problem
  • Updated 1 month ago
OK, I just have to vent. I have produced 37 video updates for my team with Camtasia 2018. I upgraded to Camtasia 2019 and lost my microphone. No problem, I'll just use the mic in my webcam to get it done and figure it out later. Made my recording - crash. Lost the video. This is not a good start.
And is it a support issue? The bigger question is why SHOULD it be a support issue. Everything was working fine, I chose to upgrade, and now I have problems. That should be enough - make the software better with each version - don't just look to get into my wallet.
Photo of mbublitz

mbublitz

  • 1 Post
  • 0 Reply Likes

Posted 11 months ago

  • 2
Photo of kayakman

kayakman, Champion

  • 7823 Posts
  • 2730 Reply Likes
sorry you're having those problems; I've not experienced them in doing about 500 screencasts in 2019

recommend you contact free tech support

Photo of croninjoshua

croninjoshua

  • 13 Posts
  • 2 Reply Likes
To be frank mr/mrs mbublitz you should not have spent another $100 for a product that doesn't work. They did you wrong. This isn't a cheap application yet it's broken out of the box. I could probably help solve your issue if you would like. Having "free" and "paid" support is ridiculous. If my post gets deleted ill email/facebook you if you don't mind.
(Edited)
Photo of Dave Cwi

Dave Cwi

  • 5 Posts
  • 0 Reply Likes
I'm on board having problems not with 2019 but the recent upgrade to 2019 where Techsupport will not respond AND the upgrade broke the product.  Any video now stutters and will not get past the first few frames including video produced by earlier versions of Camtasia
Photo of anthonysantiago1117

anthonysantiago1117

  • 4 Posts
  • 0 Reply Likes
I have been using camtasia for a few years... Just fine.  Just updgrade and its not working properly... i dont know what to do.

Photo of Mal Reynolds

Mal Reynolds

  • 513 Posts
  • 372 Reply Likes
Describing exactly WHAT isn't working properly and in what circumstances would be my first suggestion, and no, it's not a facetious one. "It's not working properly" and "it doesn't work" are two of the least useful sentences in the English language. A description of your hardware and operating system version would also be a good idea.

If you can't get an answer here then raising a support ticket would be my second one.
Photo of anthonysantiago1117

anthonysantiago1117

  • 4 Posts
  • 0 Reply Likes
Audio is not working properly. Viewer is totally black.  Playback not working properly.
Photo of Mal Reynolds

Mal Reynolds

  • 513 Posts
  • 372 Reply Likes
I take it back; "least useful" was too polite an understatement. the three most useless words - without exception - in the English language are "not working properly".

I think someone with more patience would need to look at this. Though I rather doubt that they will since you ignored the advice to be specific about what your problem is, what your hardware is, what you're doing... god forbid that you should provide a screenshot.

It would be better to jump to option 2 and contact technical support.
Photo of anthonysantiago1117

anthonysantiago1117

  • 4 Posts
  • 0 Reply Likes
no problem.. do you think i can call someone on monday...
i was just working on a project on the older version which was working fine.
i thought it would be the same. I guess i have to wait until monday.
not sure what to do .  ive spent about 5 hours trying to resolve the problem.
thanks
Photo of anthonysantiago1117

anthonysantiago1117

  • 4 Posts
  • 0 Reply Likes
nevermind. i dont need the remarks...
im upset becuase i paid for something and its not working.
(Edited)