Camtasia 2020 + Elgato CamLink 4K still producing grainy video

  • 1
  • Problem
  • Updated 3 weeks ago
  • (Edited)
I recently upgraded to the new Camtasia 2020 on macOS. I was excited to upgrade since it's supposed to have better webcam recording, but I'm not seeing it...

I have an Elgato CamLink 4K plugged into my Macbook Pro over USB so I can use the HDMI output of a GoPro 5 as a webcam. This gives me a 4K webcam instead of the built-in 720p webcam built into the Macbook Pro. Other apps work great to capture the 4K video from the GoPro connected over the Elgato CamLink 4K.

However, Camtasia 2020 still records video that is grainy and has motion blur really bad. I double checked the recording and it shows it's recording in 4K resolution, but it looks more like standard def with all the blur and artifacts...

Is there a technical reason why Camtasia 2020 can't record decent 4K video from this webcam?


FYI, my machine is a Macbook Pro 16" (8-core i9 cpu, 16 GB w/ AMD Radeon Pro 5500M) so I know it has the power to do this. Especially since other apps work just fine. This is really frustrating!
Photo of chris

chris

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 2 months ago

  • 1
Photo of Shawn

Shawn

  • 2 Posts
  • 1 Reply Like
You're lucky it's recording at all for you. I have a similar Macbook Pro using my Canon EOS M50 through Camera Live and Camtwist. The Camtasia 2020 recorder won't initialize at all. It used to work flawlessly and has suddenly stopped working at all. Of course, Snagit 2020 will record it and OBS has no problem with it either.
Photo of chris

chris

  • 3 Posts
  • 1 Reply Like
It's been 3 weeks now and absolutely no response from Techsmith about this issue... This is really sad, as Camtasia is a good product but their support seems to be lacking. Also, what's the technical reason that webcam recording sucks in Camtasia? Shouldn't it just be able to record at what ever resolution is coming from the video source? It's be really great to finally get a response from Techsmith about this....
Photo of fstedie

fstedie

  • 1 Post
  • 1 Reply Like
I couldn't find a definitive reason for it not to work, so I purchased the Camlink and tried it. No luck.
Best I can tell is that Camtasia has not been optimized to record incoming live video at such high data rates.So, I record my video and import/sync separately. Pain in the a$$ but it is the only way I can do what I want to do.
Photo of chris

chris

  • 3 Posts
  • 1 Reply Like
I really hope they release an update that fixes this! <fingers-crossed>
Photo of Logan West

Logan West

  • 1 Post
  • 0 Reply Likes
camtasia has bugs 
Photo of rimagico

rimagico

  • 2 Posts
  • 0 Reply Likes
This is an issue for me as well.  Disappointed in Techsmith's lack of response.  Any suggested work-arounds?