Camtasia 2020 Mac multi-core rendering

  • 2
  • Question
  • Updated 1 month ago
I am rendering a lot of teaching-related webcasts these days and was hoping that Camtasia 2020 would significantly speed up things, using all cores and GPU in my 16" Macbook Pro.

Now with two rendering jobs running in parallel (which need to do some video scaling, so they are busy), I get the following picture:



Bottomline: leaving the hyperthreading out of scope, the CPU cores are busy at 50% at best. Furthermore, Camtasia 2020 uses the GPU, but uses the builtin Intel graphics instead of the (more powerful) AMD one.

And it takes quite a while to get the rendering done. So any way to speed this up? Switching to discrete graphics? Optimizing system to use more CPU?

Best regards, Frank
Photo of frank.kargl

frank.kargl

  • 2 Posts
  • 1 Reply Like

Posted 1 month ago

  • 2
Photo of Brooks

Brooks, Camtasia Technical Product Manager

  • 299 Posts
  • 259 Reply Likes
Hey Frank,

I was just running tests on my 16" Macbook Pro. Definitely showed Camtasia using the Discrete graphics card, so I'm not sure why you would be seeing that. Most of the rendering acceleration (Canvas preview and video export) these days is done on the GPU. The entire guts of the rendering engine was re-written over the last several years to use cross-platform OpenGL acceleration. I'm sure there's more optimization we can do, but we hand off a lot / rely a lot on OS conventions / patterns. 
Photo of Aaron Y

Aaron Y, Employee

  • 111 Posts
  • 10 Reply Likes
Hey Frank,

Can you try this: https://support.apple.com/en-us/HT202043

We have seen in some instances where turning that off can help. Sometimes the systems gets in weird states where it won't ever use your dedicated GPU for some reason and turning this off, on and then off again can sometimes help (with reboots in between). 

I assume other apps aren't having this issue that may utilize all cores?
Photo of frank.kargl

frank.kargl

  • 2 Posts
  • 1 Reply Like
So switching that setting off and on (including the reboot) did the trick. Now it is using the AMD graphics for rendering the video and it's faster by an order of magnitude. Thanks a lot!