Camtasia 7.1 projects not compatible with 9.0.1

  • 1
  • Problem
  • Updated 1 year ago
I previously had Camtasia 7.1, recently upgraded to 9.0.1; when I try to open a previous project it tells me to open in 8 and upgrade the project and save. I don't have 8! what now?
Photo of admirera

admirera

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 5631 Posts
  • 2923 Reply Likes
Yeah, you need to open it in Cam 8 first and then save it. Download and install Version 8 and use your Camtasia 9 activation key to activate it.

Then you can open that project file in Cam 9.

You can download and install a new or an older version from this link.

https://www.techsmith.com/download/oldversions


You can keep all of the programs on your computer for as long as it makes sense to do so.You can even run more than one version at the same time.

Regards,Joe
Photo of bill

bill

  • 1 Post
  • 0 Reply Likes
Wow thats totally inconvenient as ALL previous recordings have to go through this process - crazy stations - couldn't the tech team come up with a built in system wizard to do this?

Also there are 7 versions of version 8 - I assume any one of them would do..

I tried exactly what you suggested and it did not work - I downloaded and installed V8.6.0 tried to open the file and it said:...@Unable to open project, a backup file must first be created@ (well I did that) and renamed and added to separate folder away from original file. It still did not work - how frustrating is this process!!
(Edited)