Camtasia 8.6 crash on startup Windows 10 build 14322 preview

  • 1
  • Problem
  • Updated 4 years ago
after Windows 10 preview build 14322 was installed, Camtasia 8.6 crashes upon startup. Hopefully Microsoft and/or Techsmit releases an update soon so I can continue.
Camtasia is great!
Photo of MVOverdijk

MVOverdijk

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Giovanni Stefani

Giovanni Stefani

  • 21 Posts
  • 3 Reply Likes
So here's my question.  Are you a developer?  Not sure why your using a preview build versus the release Windows 10 1511 (OS Build 10686.218) release April 12, 2016.  I'm not having any issues except that sometimes Camtasia 8.6 gets hung on starting and I have to kill the task and restart.
Photo of MVOverdijk

MVOverdijk

  • 5 Posts
  • 0 Reply Likes
As a gold partner consultant, I want/need to be aware of these developments.
Haven't got any issues with the preview builds until this one. With a bit of luck it only the fast lane insiders who will face this issue
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1444 Posts
  • 420 Reply Likes
Thanks for the report.  If you're willing, I'd like to get a crash dump from you to investigate further...

In the folder %LocalAppData%\TechSmith\Camtasia Studio\CrashDumps\ you should find a crash dump (up to 3, actually).  Please make sure that the date/time on the dump file matches the time of your crash.

Assuming it's a time/date match, please upload it to our support site, as follows:
1. Windows Key + E to launch Windows Explorer
2. Enter this in the address bar:  ftp://supportftp.techsmith.com
3. Login with these credentials:  User: customer  Pass: support
4. Drop the file in the d.orourke folder (that's me), and post here to let me know the file has been uploaded.

I'll take a look at the dump file and see if I can figure out what's causing the crashes.

Thanks in advance for your help.
Photo of campos.wanilton

campos.wanilton

  • 8 Posts
  • 0 Reply Likes
Upload mine for you check, available in your folder.
Photo of MVOverdijk

MVOverdijk

  • 5 Posts
  • 0 Reply Likes
@Dave O'Rourke, I've uploaded all 3 crash dumps. Thanks for your reply and assistance.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1444 Posts
  • 420 Reply Likes
@campos.wanilton and @MVOverdijk, thank you both.  I see 4 crash dumps.  I'm copying them down now.  I will look into them and report back here.
Photo of campos.wanilton

campos.wanilton

  • 8 Posts
  • 0 Reply Likes
Caused by driver webcam logitech, removing drive, Camtasia open fine again.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1444 Posts
  • 420 Reply Likes
@campos.wanilton Thanks for the update. That does help, and it fits with what I'm seeing in the crash dumps.

From the crash dumps, it appears that the crash occurs while we're initializing the Record Camera view. All 4 crash dumps show the same call stack, so it does look like you and @MVOverdijk are hitting the same issue. More specifically, the crash seems to be coming from Windows, in DirectShow, during a call to IGraphBuilder::Connect.

It's possible that disabling all camera devices is a temporary workaround. Of course, you wouldn't be able to use the camera features of the app, so that's not a permanent solution.
Photo of MVOverdijk

MVOverdijk

  • 5 Posts
  • 0 Reply Likes
I can confirm that the problem is with the webcam. I disabled the integrated webcam device in Windows Device Manager and Camtasia Studio 8.6 is back up and running! For now this temp work around will work for me and will test regularly after microsoft updates if the issue has been resolved.
 Thank  you for your help. I wasn't expecting it (as I'm running first release preview software), so much appreciated!