Camtasia2-freezes for a while, while editing

  • 2
  • Question
  • Updated 4 years ago
  • (Edited)
When I am editing my 30+ min video, and click anywhere in Camtasia, it just freezes and the mouse starts to show a loading wheel. This happens whenever and for whatever I do while editing. It can be a simple click in the editing section or on the video or selecting Ripple Delete Range and so it freezes for 20-30 seconds or even a minute or few. 
This has not happened with videos in the past so I dont know what I have done while editing this video.
I have done a lot of ripple delete ranges, one video clip speed, and some annotations. 
Please help. It is freaking annoying. 

I run iMac, Intel i7, 2.93GHz, 8GB memory, version 10.6.8. Snow Leopard. And Camtasia worked perfectly fine with past videos.
Camtasia 2.8.3 (91311)

I love the program but this is driving me nuts.
Photo of tine.gustincic

tine.gustincic

  • 1 Post
  • 0 Reply Likes
  • frustrated!

Posted 4 years ago

  • 2
Photo of davemillman

davemillman

  • 599 Posts
  • 202 Reply Likes
Surprised nobody else has replied. Try this: 
  1. Back up your hard disk, which I'm sure you do all the time anyway.
  2. Does the problem occur with any other projects, or just the 30+ minute project? 
  3. Save a COPY of the project, Does the problem occur with the copy?
  4. Delete half of the timeline in this copy. Does the problem still occur when you make subsequent edits on the timeline of the copy? 
  5. If the problem persists, come back and tell us more about the project: How many elements on the timeline, what types, etc. Give us more information to work with.