Camtasia 8 "mysteriously" stops working properly [audio drop out, latency glitch, audio bug] after release of version 9 - (praise, kind of)

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
I wanted to document this online for any other users.
First off, let me say I am a Full Stack programmer, I've been coding PHP, CSS, Mysql, JS, ect... one line at a time since 2001.

Second, let me say I am not "angry" persay, but my eyebrow is raised and I have lost some trust in techsmith as a result of this experience.

Here is how it went down:
Yesterday, Dec 26th I used Camtasia 8 and my Blue Yeti Mic to record a website report for a client like I always do nearly every day, I uploaded it in the usual way, via dropbox. Worked perfectly fine, recorded perfectly fine, AOK.

Today, Dec 27th I got an email from techsmith "time to update to version 9, only $99". I ignored it, im fine with C8, works great... 

Today I go to use the same set up I have always had, with a computer that had no changes to it, no hardware change nor software change, and guess what?

Camtasia 8 recorder "mysteriously" starts dropping my audio, consistently, every 3 to 5 seconds.

(we are not talking nonsense toy computer here, Yeti Blue Pro connected to an 8 core 64 bit, Windows 7 with a 960 graphics card +5 monitor 32g ram overclocked custom built PugetSystem's Serenity Machine that renders 100g premiere files in a flash that ran Camtasia 8 every day for over 1 year perfectly fine)

I spent 3 hours trouble shooting it. Here is where it gets strange, when I uninstall C8, disconnect from the web, reinstall C8 from the original exe, it "magically works" again. However, when I connect to the web, it does not.

I was surprised to run Fiddler 2 and monitor Camtasia 8 making outbound connections to various techsmith.com domains and IP's... I know what THATS about. LOL.

So, let me be direct here, as a programmer I know very well how easy and wise it would be to make sure deprecated software stops working or becomes glitchy, (I have done that for clients when they ask for it), and from my perspective I understand it, accept it even.

Simply put: I think techsmith is using a corporate investment strategy that involves deprecating software on purpose to increase ROI and bottom line and I do not care - but I want you to know that because of this I will jump ship one day when I find a suitable replacement.

So, for anyone else experiencing this, let me save you some time - you have 2 options:
#1- I would suggest you just buy the Windows 7 Camtasia 9 upgrade and the $50 of support, programmers work hard, pay them the toll and save yourself allot of time.
-or-
#2- Disconnect your system from the internet and re-install version 8 from the original EXE and as long as you don't update it you should be fine, just don't connect to the internet while using C8.

This is not some angry rant, I dont care, I really dont, I just want my programs to work. I rely on this software to deliver reports to clients.

So, GOOD JOB on Camtasia 9, it looks nice, thank you for that.
Also, GOOD JOB on the C8 "phase out planning", you got me.

Were I in my 20's I would de-compile it and look for proof, now I just go with my gut and do not have time for shenanigans.

If I am wrong, sorry, if I am right, well... HIGH FIVE.

Cheers.
Photo of ChristianZagarsk

ChristianZagarsk

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Luis Stamatis

Luis Stamatis

  • 19 Posts
  • 1 Reply Like
Interesting. For me that strategy sucks, in case if is true.
Photo of Michael

Michael

  • 42 Posts
  • 10 Reply Likes
That's very interesting, Christian. I can't imagine that Techsmith would do that. I'm interested to hear what they say.
Photo of Robert R.

Robert R., Online Community Admin

  • 1590 Posts
  • 492 Reply Likes
Official Response
Hi ChristianZagarsk;

I'm not in a position to comment on your claims but I can pass this thread on to someone more knowledgeable in those matters. I can though, make a few comments from a Support standpoint as there are a great many things that can cause audio to behave in the fashion you're describing, with Camtasia or otherwise. Camtasia Studio 8 has not been updated since August of 2015 which means there are a number of factors that can come into play. Most notably would be hardware drivers and/or Windows Updates. It is likely that an update on one (or both) of those has caused this behavior. There is also the possibility that Camtasia's settings have become problematic, which in turn is causing this issue. The solution that I recommend is to open a support ticket with our technical support team (which is free), as they will be able to collect diagnostic files and/or logs to look into the behavior.

Have you opened a ticket? If so, what is your ticket number so I can look into your case?

-Robert
Photo of Glenn Hoeppner

Glenn Hoeppner, Employee

  • 1838 Posts
  • 337 Reply Likes
Just to be clear, there is no kind of kill switch in Camtasia to encourage you to upgrade. Camtasia makes calls out to the internet to do things like maintain your signed-in state and report usage data (which you can opt-out of). So whatever issue your experiencing is coincidental. I would follow up on Robert's suggestion and open a ticket with Technical Support.

-Glenn
(Edited)
Photo of ChristianZagarsk

ChristianZagarsk

  • 3 Posts
  • 0 Reply Likes
Hi guys, 
the web lacks tone of voice. It matters not the least bit to me  -You could even delete this post if you wanted.

as a developer who also has to rely on SASS applications - I am not interested to debate the issue at hand, only document what happened and the solution to fix it.  (I see it every year from Adobe, Native Instruments, Micro$oft, Apple, ect... planned obsolescence - fantastic idea, even John Deer does it )

If the issue is coincidental then its because online remote responses from C8 to techsmith.com sub-domains and IP's are not functioning properly. If you really want to trouble shoot that fire up C8 and Fiddler2, then monitor outbound requests on a Windows 7 64b machine that has not been updated since March 2016, (i'm suspect you will quickly see the problem in the decoded responses).

On a more positive note
If this post has your attention, abandon it and consider this post here with actionable items:
https://feedback.techsmith.com/techsmith/topics/camtasia-9-feature-requests-debug-enhancements-and-i...
Photo of David D

David D, Technical Product Manager - Camtasia

  • 139 Posts
  • 172 Reply Likes
Official Response
Hi Christian,

Robert and Glenn kind of covered it already. We haven't shipped any updates to Camtasia Studio 8 since the release of Camtasia 9 in fall of 2016. No intentional change in functionality for Camtasia Studio 8 on our part. Apologies for the audio issues. Sounds like you've resolved it yourself already but if you do experience this or a similar issue again our Tech Support team can help.

Thanks!