Camtasia 9.1 crashes on Windows 10 Home

  • 1
  • Problem
  • Updated 3 weeks ago
Hello everybody!

I am facing some problems with Camtasia 9.1 on Windows 10 Home. I have recorded something, then it started to introduce glitches into the audio recording. I have reinstalled it, continued to record, went fine for a while, then it came back to the glitches. Besides this, it started to crash from time to time. I have removed it again, cleaned up the registries, reinstalled, went fine and I was able to finalize my current work.
For now I have no problems, but I wonder if there is a known issue and if there is a known long-time solution.
I did not have any problems of this kind on Windows 8.1.
Any help would be appreciated. Thank you!

Photo of Catalin Tudose

Catalin Tudose

  • 3 Posts
  • 1 Reply Like

Posted 3 weeks ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 5635 Posts
  • 2923 Reply Likes
It's probably going to be driver related or something along that line.
Tracking down the exact cause can be easier said than done. Especially through a back and forth communication in this forum.
What is probably needed here is a qualified tech support person to evaluate the problem.

This is a Free Service............... Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of Catalin Tudose

Catalin Tudose

  • 3 Posts
  • 1 Reply Like
I had a fresh Windows 10 Home system.
Anyway, I have already submitted a ticket to Techsmith support.
Thank you for the answer!
Photo of Joe Morgan

Joe Morgan

  • 5623 Posts
  • 2919 Reply Likes
No problem, you might be lacking a drivers then? Anyway, let us know if you get it resolved.What the problem was.It can help others down the road.Thanks {:>)
Photo of Catalin Tudose

Catalin Tudose

  • 3 Posts
  • 1 Reply Like
I am waiting for the answer from the tech support and I will let you know.
Photo of bnystrom

bnystrom

  • 186 Posts
  • 87 Reply Likes
In the meantime, go to Edit > Preferences > Advanced and set the Hardware Acceleration to "Use software-only mode". This seems to fix a lot of flaky behavior.