Camtasia 9: Can I set the default microphone?

  • 2
  • Question
  • Updated 4 months ago
Camtasia 9.1.2 on Windows 10.

My PC has three microphones: The built-in one, which I never use, the one on my headset, used for voice communication, and a Blue Yeti for my Camtasia recordings.

I often use the Voice Narration function. When I switch it on, it's always configured to use the headset mike, and I have to manually change it to the Yeti. Unfortunately, more often than not I forget to do that and end up with a silent narration. I have just wasted another 15 minutes and a few nerves this way.

Is there a way to change the default mike for Voice Narration? The Windows recording device, by the way, is set to the Blue Yeti already.

Photo of berndbausch

berndbausch

  • 10 Posts
  • 3 Reply Likes

Posted 4 months ago

  • 2
Photo of Fred Grover

Fred Grover, Champion

  • 2335 Posts
  • 333 Reply Likes
Hello berndbausch. As far as I know this is not possible in Camtasia as there is no specific setting(s) for a default mic. I have not found a way to make it default to a specific mic as that is controlled by Windows in the Recording and Playback Settings and you can only have one mic set to Defualt for now. It would be nice to have that option and if anyone else has any ideas or knows more maybe they will jump in and try to help out. By the way I am using a PC with Windows 10 64 Bit System.
The best thing to do would be to put a reminder either mentally or on a sticky note somewhere to help you remember to change the mic before recording. Just my suggestions and they are not written in gold anywhere.

Thanks for posting and have a great day/night.
Photo of berndbausch

berndbausch

  • 10 Posts
  • 3 Reply Likes
Thanks for sharing. One possible workaround is unplugging the headset, but this has the less than desirable side-effect that I can't listen to my recordings....
I'd like to reiterate that Camtasia ignores the Windows recording device default. It seems to have its own microphone management, or more likely it's hardwired to annoy me personally:

Photo of Fred Grover

Fred Grover, Champion

  • 2335 Posts
  • 333 Reply Likes
That now makes sense. I will have to try with more mics connected myself and see if this also happens. It seems strange that it does not use the Default Windows Microphone when in the Recording Settings. Not sure if others are having this same issue or not or if it is a bug or if it is the way of Camtasia to just give you the options to choose the Microphone. But, in my opinion it would be better if it just used the default and in the dropdown it let you see the other options for Microphones to use.
Have you tried to close Camtasia Studio 9 and then unplug all the Microphones you have then connecting them back up and setting the one you use the most often as the Default Microphone for recording ? Just a suggestion to see if it works or not.
Thanks for the update posting and have a great day/night.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 5648 Posts
  • 2929 Reply Likes

Okay, I got a registry hack for you if you don’t mind using it.

As you can see here in the image. My Andrea headset is the default microphone.


So go to Windows search type in regedit.


Go to HKEY_CURRENT_USER


Scroll down to TechSmith – Camtasia’s studio – 9.0 in this particular case – Voice Narration – Audio

you will select the audio folder by left clicking it.


You want to right-click the waveDeviceIn and select modify.


The edit string window will pop open. You will want to change the microphone’s name to the one you want to use by default. You will want to spell the microphone exactly as it appears in the drop-down menu in Camtasia. When you’re done select okay.


That’s it you’ve modified the registry. Even if you made a mistake it’s not that big of a deal you can change it back to the way it was. Or you can do a repair install and let Camtasia fix it for you.


And here’s an image showing my WebCam microphone as the default microphone at the top of the list in Camtasia 9.


Regards, Joe

(Edited)
Photo of Dubie

Dubie

  • 961 Posts
  • 741 Reply Likes
Good info Joe.
Normally don't see you post this geeky hack stuff.
You been holding out on us ey ?.  lol

:)
Photo of Fred Grover

Fred Grover, Champion

  • 2335 Posts
  • 333 Reply Likes
If you follow the instructions when it comes to changing anything in the Windows Registry that should work alright. But, regardless I would still advise to do a Registry Backup or if you feel uncomfortable with changing anything in the Windows Registry then get someone who understands it better to help with it.
Joe had a great suggestion and fix here in which I try not to post many Registry Edits as most users do not understand the Registry or some of the possible things that can go wrong or even how to do a backup beofre changing anything for their own safety. Joe has the experience I am sure. Let us know if you tried this option and if it helped you out or not.
It would be nice if one of the TechSmith people would give their input on this to give more of an explanation as if it is a bug or why it is not setup to match the Degault that you have set on Windows machine.
Thanks everyone for the posts and responses. Have a great day/night.