Camtasia 9 install refuses to start - Windows 10

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
I am attempting to install the trial version of Camtasia 9 on my Windows 10 Enterprise laptop.  When I run the executable, it runs for like 2 seconds, and then exits (I see this in task manager).  I get no feedback in the event log, or on the screen, as to why it refuses to install.

EDIT:  I found the installer log, and it seems that this is about as far as I get.  I can post the entire log if desired, but it seems to be just a bunch of variables

[25CC:24D8][2017-07-05T21:27:29]i000: Setting string variable 'TSC_BOOTSTRAPPER_INTERNAL_STATE' to value 'Install'

[25CC:24D8][2017-07-05T21:27:29]i000: Exception occurred: The type initializer for 'System.Windows.Interop.OSVersionHelper' threw an exception.

[25CC:1C90][2017-07-05T21:27:29]i500: Shutting down, exit code: 0x0
Photo of gbdickinson

gbdickinson

  • 2 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of gbdickinson

gbdickinson

  • 2 Posts
  • 0 Reply Likes
This was self-inflicted.  My laptop was an upgrade from Win 7 to Win 10, and during this the .Net installation got messed up somehow.  I reinstalled from this link: https://www.microsoft.com/en-us/download/details.aspx?id=53345 and now the installer proceeds as expected.  Thought I'd post back the answer in case anyone else runs across this.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1417 Posts
  • 373 Reply Likes
Glad you found a solution.  Thanks for posting it.