camtasia 9 requires windows 7 service pack 1 or higher os

  • 1
  • Question
  • Updated 1 year ago
Tried to instal the trial version of camtasia 9 and I am getting that message.
Funny is that I am running the latest service pack, system info also list it.... (start/computer/info)

So what is the cause of this message ?
Photo of nitramka1983

nitramka1983

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 1

Be the first to post a reply!