Camtasia 9 UI Issues, introduces new incompatibilities with input devices

  • 3
  • Problem
  • Updated 2 years ago
These are problems with the UI or just the Camtasia 9 app in general, and none of these were/are and issue in CS 8.

1) Cannot access Windows Taskbar (to click on app icons) AT ALL with the Application maximized/open. To access the Taskbar, I literally have to minimize the application, first. What a PITA.

2) If I detach the Canvas and dock it on my 2nd Monitor, every time I re-open the app to the very same project I was last working on, I have to move it back to the 2nd monitor EVERY TIME! Arrrgggggggh. What compounds this annoying issue is the bug that cause the PROPERTIES panel to not display any properties, half the time. The only remedy to that bug is to close the app and re-open.

3) Wacom tablet stylus buttons no longer respond correctly (ie., RMB to click CUT). Worked fine in CS8....used it many times per day. My Logitech keyboard has some accessory buttons for common tasks. I had one mapped to CTRL + X for CUT....works in CS8, but not in Camtasia 9.

What did you guys do to cause input devices like this to work only half-way? I'm so used to using my Wacom tablet for everything, as I practically never use a mouse...but have to in Camtasia 9.

4) No longer an option to select a portion of a recording > FILE > PRODUCE SPECIAL > PRODUCE SELECTED. I used this all the time in CS 8. Not available in Camtasia 9.
Photo of dnashj33

dnashj33

  • 68 Posts
  • 13 Reply Likes

Posted 2 years ago

  • 3
Photo of kayakman

kayakman, Champion

  • 6363 Posts
  • 1878 Reply Likes
I can see/access the Task Bar when CS9 is maximized; maybe something to do with how your monitor is configured [I only use 1 monitor]

you can still produce-selection-as; just right click the selection on timeline

suggest you contact tech support ...

This is a free service and you can submit a ticket here:https://support.techsmith.com/hc/en-us/requests/new

Or call, >>> 1.517.381.2300
Toll Free: 800.517.3001 (U.S. & Canada Only)
8:00 AM to 7:00 PM EST Monday through Friday
Photo of dnashj33

dnashj33

  • 68 Posts
  • 13 Reply Likes
Thanks, but it has nothing to do with how my monitor is configured. It works properly with ALL OTHER APPS. Camtasia 9 is the lone exception. Even on CS8, it works properly. You can see the detached canvas opens up, just like it was on the 2nd monitor, when opening the app > last project file.

There are just too many bugs/problems with this app to fill out all the support tickets needed to address each one of them. They are aware of many of these issues and they would know why things like these, suddenly don't work in v9

 
(Edited)
Photo of Josh Holnagel

Josh Holnagel, Employee

  • 424 Posts
  • 78 Reply Likes
Just a quick note on #4:

What kayakman said is correct. You can right-click on the timeline selection to produce only that section of your project. If you'd still like to use the program menus to do so, the option has moved. It's now found under:

Share > Produce Selection As...

For #1, I'm not having this issue with Camtasia, BUT I've had this issue in the past with other programs. I've never been able to figure out the what/why it happens. I'm really sorry you're running into this because I know how frustrating it is, but if you could at least let us know what monitor setup you have (assuming Windows 10, based on your screenshot) I will pass that information onto the dev team. Include resolution and connection type, please. Also, does it still happen if you have no external monitors connected and maximize Camtasia?

-Josh
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

I concur with Josh.  The inability for me to access the Windows Taskbar is an issue I have dealt with through various windows versions.  The only common theme I recall is the application involved is at full screen.

Sometimes the issue is so persistent the only recourse have been one of the following:

  • Exit full screen, or tabbing to another application.  Then disabling AutoHide.  Sometimes re-enabling AutoHide also works.
  • Tapping the Windows button.
  • Rebooting..
  • Screaming has yet to help; despite all attempts.
Photo of dnashj33

dnashj33

  • 68 Posts
  • 13 Reply Likes
I've noticed that if you work in your project for a while, scrubbing along the timeline is VERY choppy...as in it will not update for 2-3 seconds. I have to close the app and restart to get decent playback performance.

If I choose GPU DECODING in PREFERENCES panel > Advanced tab, I get all kinds of visual artifacts while trying to scrub the timeline. Dark screen are massive artifacts like this.

System: i7 970, 32GB, video content stored on an SSD drive, GTX 1070 graphics card.