Camtasia 9 won't open.

  • 5
  • Problem
  • Updated 10 months ago
I tried opening it, and it isn't working. I restarted my computer and everything. And Camtasia is not running in the background. 
Photo of Mewpixel Rblx

Mewpixel Rblx

  • 7 Posts
  • 1 Reply Like
  • Concerned

Posted 2 years ago

  • 5
Photo of erinaubry1

erinaubry1

  • 4 Posts
  • 2 Reply Likes
Same here! I just upgraded and can not get the program to open.
Photo of elaine

elaine

  • 1 Post
  • 0 Reply Likes
same issue but I don't have win 10. I bought Snag it as well and it won't work either
Photo of Joe Morgan

Joe Morgan

  • 4875 Posts
  • 2519 Reply Likes
Did the programs install and did they place Icons on your desktop?

If so, try right clicking the Icons and chose "Run as Administrator"

If the programs won't install. Right click the .exe file and chose "Run as Administrator"

Does that work for you and if not could you provide some specifics.It's hard to guess at what may be occurring.

Regards,Joe
Photo of katiesokool Roblox Girl

katiesokool Roblox Girl

  • 1 Post
  • 0 Reply Likes
I get 6-4 bit cant INSTALL
Photo of suelaurent5280

suelaurent5280

  • 2 Posts
  • 1 Reply Like
I'm having the same issue (Windows 10)
Photo of Rick Stone

Rick Stone

  • 4509 Posts
  • 2015 Reply Likes
My Windows updated the other day and I went to launch camtasia and got nothing. But I did find it on my Task List and killed it. Once I did that it did seem to start up okay.

Have you tried that? ;)

Cheers... Rick :)
Photo of suelaurent5280

suelaurent5280

  • 2 Posts
  • 1 Reply Like
Thanks Rick! Yes, I did try that, and it does work, but I'd rather not have to do that every time I want to open it. :) ( But yes, I'm not 100% stuck, just 20% "annoyed", haha)
Photo of Fred Grover

Fred Grover, Champion

  • 2335 Posts
  • 333 Reply Likes
I have also done what Rick has suggested and I run a Windows 10 64Bit Laptop and it worked after that and I also checked in the task Manager on the Startup Tab just to make sure it was not starting up and it was not in the list. After I rebooted it and used the Run As Administrator Option I have not had that issue again - Knock on wood. Let us know if you are still having this issue or not and hopefully not  as it is nice to have things working correctly.

This would be great to hear some feedback on from all users having this issue and if any of the suggestions here helped or not.

Have a great day/night and thanks for posting.
Photo of AXL_LOW Lord

AXL_LOW Lord

  • 2 Posts
  • 0 Reply Likes
dont work on win 10 x64
Photo of karengreenhaus

karengreenhaus

  • 1 Post
  • 0 Reply Likes
I just upgraded to Camtasia 9 and can't get it to open. I have tried all the suggestions above, to no avail. Little frustrating. It shows up in the task manager when I open, and I kill it, but it still doesn not open. I have tried the run as administrator, still does not open. I have a Lenova Windows 10 x 64bit
(Edited)
Photo of kayakman

kayakman, Champion

  • 5443 Posts
  • 1498 Reply Likes
suggest you contact free tech support
Photo of graham.flower462

graham.flower462

  • 1 Post
  • 0 Reply Likes
I recently downloaded the free trial, and I found I had this issue too. I'm using Windows 10.
The Task Manager fix that has been mentioned previously wasn't an option for me, as when I clicked on the icon, Camtasia briefly popped up in Task Manager, but then disappeared completely.
So, I went to the application / .exe file in the installation files, and right clicked, went to properties, then compatibility tab. I then selected it to run with compatibility to Windows 7. It then worked first time. Hope this helps. :)
Photo of Shreeya Saxena

Shreeya Saxena

  • 1 Post
  • 0 Reply Likes
Facing same problem.
Photo of kayakman

kayakman, Champion

  • 5579 Posts
  • 1564 Reply Likes
recommend you contact free tech support
Photo of The Wooden Lego !

The Wooden Lego !

  • 1 Post
  • 0 Reply Likes
it won't open period, i get a pop-up that says "there is no disk in drive. please insert disk into drive D:" please help. and yes it is from camtasia (i thought it was from elsewhere at first)