Camtasia Export Local File MP4 causes webcam to go black occasionally [Windows 10]

  • 1
  • Problem
  • Updated 6 months ago

Hi there,

Details
---------
O.S. - Windows 10
Webcam - Logitech HD Pro Webcam C920
Microphone - Blue Yeti

I've been recording my screen and webcam for various tutorial based videos. When I export the project using the options -> Share -> Local File -> then leave everything as defaults to generate an MP4, at certain frames my webcam will go black for a split second.

I can confirm the raw footage DOES NOT have this issue, it is only when I export the project. I have also tested recording with the webcam in other software and the black screen does not happen.

If you are interested in seeing an example:
https://www.youtube.com/watch?v=lPK8wJwa7HA&t=

At timestamp 7:45, the black screen occurs.
Photo of michaelmuinosofficial

michaelmuinosofficial

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Muscle Whisperer

Muscle Whisperer

  • 176 Posts
  • 94 Reply Likes
I am NOT an expert, far from it.
However, from following the threads here, I'd guess that you have a frame rate mismatch, and the black screen occurs where Camtasia can't make up for a frame.
1) Make sure what frame rate your webcam is shooting at
2) Verify that Camtasia is working at the same rate
3) Confirm that your output video is listed at the same rate.
You may have a problem with web recording at 29.95 fps, but Camtasia working at 30 fps.
Hope this helps, until someone more knowledgeable can respond.