Camtasia extremely slow to do anything

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
I have Camtasia 8.6.0 and it's almost impossible to produce any video project because it's so slow. It's been like this for a few years but only recently have I needed to produce a video project. My current video is only about three minutes long. Video plays back at about 1 frame every 1-2 seconds (I'm not exaggerating) regardless of length, so doing anything is next to impossible. My laptop should be able to comfortably handle it. Also the UI controls in the video playback area are extremely small.

System information as follows:

      System Manufacturer: Dell Inc.
             System Model: Precision 5520
                     BIOS: 1.14.2 (type: UEFI)
                Processor: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz (8 CPUs), ~2.9GHz
                   Memory: 32768MB RAM
      Available OS Memory: 32618MB RAM
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 288 DPI (300 percent)
       System DPI Setting: 240 DPI (250 percent)
           Card name: Intel(R) HD Graphics 630
      Display Memory: 16436 MB
    Dedicated Memory: 128 MB
       Shared Memory: 16308 MB
        Current Mode: 3840 x 2160 (32 bit) (60Hz)
         HDR Support: Not Supported
         Native Mode: 3840 x 2160(p) (59.997Hz)
Photo of djacobs

djacobs

  • 3 Posts
  • 1 Reply Like

Posted 1 month ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 9087 Posts
  • 4787 Reply Likes
Maximum canvas/project size of Camtasia 8 is 2048 x 2048 30fps.
If your recording your 4K screen and editing it in Camtasia.
It has to down sample the footage to 2048 X 1152. That alone will cripple Camtasia's editing capabilities.

If you change your laptops resolution to 1920 x 1080. Record and edit at that resolution. I think you'll find the program will run well.
If you want to edit 4K. Its time to upgrade, or switch to a program that supports 4K.

Regards,Joe
Photo of djacobs

djacobs

  • 3 Posts
  • 1 Reply Like
You were right. Dropping the resolution on my screen helped enormously. Thanks!
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
You're using half your RAM for the GPU, but at 32-bit color and 60Hz  let's work out the math:
3840 x 2160 x 4 bytes/pixel - you need a 32GB video card just to produce 1 frame. 
So 1 frame each 2 seconds - makes sense.  Also your i7-7820HQ is 4 cores and 8 threads, kinda  weak for what you're trying to achieve.

Recommendations:  16-bit color and you could Theoretically produce 1 frame per 1 second. 

Remember that the Trek file is uncompressed, so a modern workstation with 128 GB RAM still wouldnn't be satisfactory (for me) so you'll need the power of 4 or 6 very hi-end graphics cards. 


Photo of rg

rg

  • 323 Posts
  • 251 Reply Likes
I don't know why it is so slow for you.  My Win10 Pro PC is 64-bit but that shouldn't make much difference since v8.6 (which I use) is a 32-bit program.  I have 32GB memory and an Intel i7-6700 which runs at 3.4GHz speed.  However:  I do not record anything full-screen; the maximum I deal with is UHD 1920x1080 at 30fps (often going down to HD from there).

Now, I have experienced some slowdown difficulties when using source files that are mp4 but recorded with current cameras and which have sizes just shy of 2GB.  For some of these, sync can sometimes be an issue due to encoding differences; repackaging these files using WinX or Handbrake usually resolves the problem with no noticeable quality loss.
Photo of Dustin Smith

Dustin Smith

  • 58 Posts
  • 12 Reply Likes
Hmmm...  My hardware is less than half what yours is and I never saw an issue like that when I used 8.6.... I'm not sure that 8.6 supported 64 bit, which could leverage all that ram you have...  I've run Camtasia on some pretty crappy hardware and not seen performance that lame... something's not right but not sure what.

Photo of rg

rg

  • 323 Posts
  • 251 Reply Likes
v8.6 is a 32-bit program.  (Still, that should not cause the massive sluggishness reported.)
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
Nor did you ever try a 4K video, 32-bit color depth and 60 fps!!
Photo of rg

rg

  • 323 Posts
  • 251 Reply Likes
Good point -- since v8.6 doesn't support 4K and I have not yet had any requests for 4K (at any fps) I have had no reason to explore this.
Photo of djacobs

djacobs

  • 3 Posts
  • 1 Reply Like
Joe is correct. I dropped my screen's resolution to 1920x1080 and it's almost back to normal. Slightly juddery playback, but certainly 95% better. Thanks a lot for the help!
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
Jittery?  I had that too, turned off hardware acceleration - no more jitters (although rendering took a bit longer).