Camtasia for Mac 3 Editing Gremlins

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
I love Camtasia for Mac and PC. I'm a longtime almost daily user. I've never before had editing issues with Camtasia for Mac or Camtasia Studio.

I create rather simple tutorial visual reinforcement for Web and Graphic Design students. My videos are never any longer than 8 minutes. My workflow consists primarily of editing out sniffles, stumbles, silences and coughs, adding two or three annotations per video at most, and an occasional transition at beginning and end. I might split a too long video into chunks and create two projects, or combine two screencasts from the same project. Once in awhile I pull in an MP4; occasionally I split audio and video so that I can replace mistakes I missed while recording.

My issue occurred on my late 2015 Retina 5k iMac 4GHz i7 AMD Radeon 2018 MB, 16 GB ram. Camtasia for Mac 3.03 installed. Running El Capitan 10.11.6. I always reboot before recording or editing video. I always save to and edit from the local hard drive. I record at 2560 X 1440.

My problems occurred last night while editing an 8 minute long project that combined a 30 second recording and a 7 min 30 second recording, both created in the same project, minutes apart. I'd finished editing about half of the project without issue. I had 4 tracks: 2 annotations, a very brief replacement audio track recorded within the project. I'd made about 10 edits right clicking to split and right clicking to apply ripple delete. About mid-way through, I could no longer bring up a menu when I right clicked. I could access the same commands on the menu bar, but it made the last half of editing take about twice as long as the first half. If I saved the project manually, right click would work once after each save. It was weird. And very frustrating.

Also during the second half of editing, it became almost impossible to select an annotation on the timeline without creating a marker (what I needed to do was change the length). Oddly, the drag cursor would show up, but when I tried to drag, I'd get a marker instead. To select and change the length of the annotation, I had  delete the marker, click away from the timeline and then reselect the annotation to move or change the length. Every time, at least once.This has never happened before. Ultimately, my finished product was excellent, but it really put a damper in my workflow and productivity when the timeline editing gremlins started wrecking havoc. 

When I create a new track, I always adjust the height so that I can keep track one as large as possible. (The audio waveform size in Camtasia for Mac 3 definitely an issue for comment, but it deserves its very own conversation.) 

Thoughts? Suggestions to avoid these issues in the future? Are these known issues? Is anyone else seeing these anomalies?

Thank You,
susanne
Photo of susannemistric

susannemistric

  • 100 Posts
  • 76 Reply Likes

Posted 2 years ago

  • 1
Photo of davemillman

davemillman

  • 486 Posts
  • 154 Reply Likes
Susan,

You sound like an experienced user, but in your detailed description you did not mention if you quit Camtasia or rebooted, and did the problem return? If it returned were you able to figure out what triggered it? 

I'm also on OSX 10.11.6 with Camtasia 3.0.0 (I'm in the middle of large projects so not upgrading until the projects are complete and archived). One project has 300 items on the timeline with no major issues so far. I've crashed Camtasia 3 twice since it was released, and had to restart it once. That's been the extent of the bad behavior I've observed.
(Edited)
Photo of susannemistric

susannemistric

  • 100 Posts
  • 76 Reply Likes
As stated, I always reboot before working on any recording or editing projects. I've never had a crash with version 3, and this was my first time having an issue that interfered with productivity. I'm really hoping to learn of a potential solution, or that I'd stumbled onto a known bug that is being addressed. Fingers crossed!
Photo of Paul Middlin

Paul Middlin, Employee

  • 846 Posts
  • 190 Reply Likes
I'm still not quite sure whether you're saying this is something that happened once, or something that happens every time you edit...
And, no, I don't believe we have seen this.
Photo of davemillman

davemillman

  • 486 Posts
  • 154 Reply Likes
> About mid-way through, I could no longer bring up a menu when I right clicked. I could access the same commands on the menu bar...

Susan, one question: After you reboot, is the right-click menu still gone, or does it return? That's what we're asking.
Photo of susannemistric

susannemistric

  • 100 Posts
  • 76 Reply Likes
I had to finish that tutorial immediately, so I completed the project using the menu bar method that worked, albeit slowly, instead of right clicking.. I didn't reboot at that point. I'll let you know if right click behaves shortly, as I begin a new series of tutorials..
(Edited)
Photo of susannemistric

susannemistric

  • 100 Posts
  • 76 Reply Likes
Happy to say all is working fine since that one time issue! My students were extremely happy with last week's videos, so the bit of extra time spent working around that little hiccup was well worth it!