Camtasia makes NVDIA Shadowplay recordings lighter than the actual recording

  • 3
  • Problem
  • Updated 6 months ago
  • Acknowledged
When trying to edit NVDIA Shadowplay recordings  (.mp4) at 30/60 FPS, the recording when imported into Camtasia will have a lighter color than the actual recording itself.
Photo of hososokiwa

hososokiwa

  • 2 Posts
  • 1 Reply Like
  • frustrated.

Posted 6 months ago

  • 3
Photo of brucerothwell

brucerothwell

  • 300 Posts
  • 86 Reply Likes
I’ve seen something similar, on my Mac though, and discovered that when I exported the MP4, there was actually 2 choices of MP4.... one was called MainConcept, I believe.

When using the MainConcept codec, the MP4 looked much better.
Photo of Joe Morgan

Joe Morgan

  • 7599 Posts
  • 4152 Reply Likes
Yep, they sure do.

My suggestion is ignore TechSmith advice and follow mine.
      This has been a problem since Camtasia 2018 was released for Nvidia graphics cards.

Their advice is to disable your graphics card and edit in software mode only. Which also disables graphics card acceleration that assists with timeline playback.


Without it, timeline playback hits the bricks. This is a 1920 x 1080 60fps Shadowplay recording playing back in the timeline of Camtasia 2019. I only placed that video on the timeline there are 0 edits, 0 titles, 0 callouts, etc. I’m using the Microsoft basic render driver. As you can see in the task manager. My graphics card is contributing up to nearly 60 percent. The canvas is not washed out.



With the same footage in “Software only mode”. Playback isn’t horrendous but it isn’t smooth either. It’s not smooth at all. I’ll put it this way, playback such that I wouldn’t want to edit in this mode. So, If you want to edit 60 fps video. You’re going to want the graphics card enabled.

TechSmith’s secondary advice is to take this extra step. Converting your footage in Handbrake. Make the footage compatible with Camtasia. Which to myself, is an unnecessary step when you have perfectly good footage. Here is a link to TechSmith’s workarounds. https://support.techsmith.com/hc/en-us/articles/360005120411-Camtasia-Windows-

Unfortunately, Microsoft’s render driver will only push my Nvidia card to about 60 percent of its capacity in my experience. That’s the best “I could” get out of it using its drivers. But that’s a heck of a lot better than shutting it down.

Here’s my second piece of advice. When you go to produce your video.

Save your project.

Switch Camtasia’s preferences to software only mode.

Restart Camtasia so the changes take effect.

Then produce your project.

Why is this? I haven’t tried to test whether or not software mode renders better than the Microsoft basic render driver. One person reported in the forum that he got better results using software mode only as opposed to using the Microsoft basic render driver.

I’ve used and still use a lot of assorted video related software. Camtasia is the only program I’m aware of that took it upon themselves to manipulate Nvidia graphics cards with a Microsoft driver. So perhaps it’s best to just to wait a bit longer? Rendering in software only mode.

I rendered a few videos using the Microsoft render driver. Yet, I didn’t detect any issues. Never putting the videos under a microscope. Nor entirely sure what I would be looking for either?

That’s my take on it.

Regards, Joe

Here’s my specs for context.

Windows 10, 64-bit, English EA - -

 4th Generation Intel Core i7-4770 processor 3.40 GHz (8M Cache, up to 3.9 GHz)

16GB RAM Dual Channel DDR3 1600MHz - 4 DIMMs EA - -

NVIDIA GeForce GTX 660 1.5GB GDDR5 EA - -    Supporting   4 Displays

Samsung 860 EVO V-NAND 1TB SSD SATA 6Gb/s           3 EACH


Photo of raybettis

raybettis

  • 5 Posts
  • 3 Reply Likes
Joe, your suggestion is spot on! I have followed it since I first read it. Much too long ago. They really need to fix this.
Photo of hososokiwa

hososokiwa

  • 2 Posts
  • 1 Reply Like
$250 and they don't have driver support for the latest graphics cards? That's a load of horse shit, I think i'm better installing free software which supports the codecs.  
Photo of raybettis

raybettis

  • 5 Posts
  • 3 Reply Likes
Haha, don’t get me started on how utterly upset I really am. :)
Photo of Brooks

Brooks, Camtasia Technical Product Manager

  • 179 Posts
  • 149 Reply Likes
Hey folks,

We believe we have a fix for this issue (at least it fixes the issue on the two NVIDIA GPUs we have where the problem was manifesting). I'm hopeful we are going to cut a release and have it out in the wild within the week. I can't guarantee that, but that's what we're aiming for. So keep an eye open for the next maintenance of Camtasia 2019 for a fix. I believe the version number will be 19.0.3 on Windows. We're especially interested to hear if this doesn't fix the issue for you. In which case providing your GPU model and the source content would be super helpful. Thanks for your patience on this front.

Brooks
Camtasia Technical Product Manager
Mobile Technical Product Manager
TechSmith
Photo of raybettis

raybettis

  • 5 Posts
  • 3 Reply Likes
Thank you for the update!