Camtasia on 4K system

  • 1
  • Problem
  • Updated 1 month ago
I have been using Camtasia 8 for some time, but on a 4K system, it does not display properly. I assume it has to do with scaling, but I don't want to change the scaling just to use Camtasia. I decided to try V. 2018. It displays fine, but doesn't run. I downloaded a sample project and loaded it. Click on the arrow - nothing happens. The tool itself seems to work, but it doesn't animate. Codec problem? Who knows? I certainly don't think it is ready for prime time.
Photo of reiddg

reiddg

  • 35 Posts
  • 4 Reply Likes

Posted 2 months ago

  • 1
Photo of philipcw

philipcw

  • 7 Posts
  • 2 Reply Likes
Try changing the GPU hardware/software acceleration preferences settings.

On Windows I had issues with scaling when I switched to a 4k laptop. Basically you adjust your Windows display settings and then you have to signout and sign back in for the the setting to apply in some applications like Camtasia.

Camtasia 2018 UI Change scaling size
https://feedback.techsmith.com/techsmith/topics/camtasia-2018-ui-change-scaling-size
Photo of reiddg

reiddg

  • 35 Posts
  • 4 Reply Likes
No progress with changing window settings for Camtasia 8. Certain window areas seem to be a fixed number of pixels wide which doesn't work on a high res. display.

Regarding running video in 2018, I was able to start Camtasia as 'administrator', and it would run. It was then that I noticed that I could not resize the windows. Curious, I restarted it, but not as administrator, and it both ran and was resizable. It seems to me that there are some uninitialized settings at play here. It might be that it is necessary to run in the administrator mode first after which it will run normally. Right now, it is working.