Camtasia Open Captions

  • 1
  • Question
  • Updated 1 year ago
I have been attempting to create an MP4 with open captions.  I have followed all instructions that I have seen here as well as elsewhere on the web.  But in the generated MP4 the only way I see the captions is when I run via the generated HTML file.

I have:
  • Taken an existing recording.
  • Used text to speech on the audio track.
  • Edited the text to remove translation errors.
  • Used the custom production option to create the MP4.  (The only option is MP4 with smart viewer. If I choose to produce to a local file, a couple of other MP4 options appear but those all indicate that captions will not be included.)
  • On the Options tab, I select either burn in or under.  Neither gives me captions.
  • I have also selected the option when the dialog opens to not use the smart controls.
The result is a standalone MP4 that does not display the captions.

Environment is Windows 10, Camtasia 9, recording originally captured with Camtasia 8.
Photo of david.syskowski

david.syskowski

  • 2 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of kayakman

kayakman, Champion

  • 6249 Posts
  • 1834 Reply Likes
the steps you describe work for me to get burned in captions in the resulting MP4 [just tested again]

could you do a short screencast walking us through the editing and production so we might see where the issue is?

please host on screencast.com and share like here
Photo of kayakman

kayakman, Champion

  • 6249 Posts
  • 1834 Reply Likes
also, you can produce without the controller; start with controller selected, in options tab, select burned in captions, go back to controller tab, and un-select produce with controller; do production and you will only get the MP4 [with burned in captions]
Photo of david.syskowski

david.syskowski

  • 2 Posts
  • 0 Reply Likes
Thank you.  Not sure if my success was due to trying yet again on a different day, or whether the sequence that you suggested was the trick.  But I did what you suggested (request burned in captions, then returning to the main tab to remove the smart player controls) and it worked.  Unlike before, now the only thing generated is an MP4, not the HTML file and the other assets.  I tried on a second video and once again got the results I wanted.  It seems like these choices are conflicting if they are indeed independent.  If I choose burned in captions, the application should automatically unselect the smart controls or at least indicate there is going to be an issue.