Camtasia recorder 9 crashes constantly

  • 2
  • Problem
  • Updated 4 months ago
The recorder v8 also crashed every now and then but this nice feature "recover" allowed me to save my work. In 9, this has not worked even one time. The frustration of seeing my hard work constantly going down the drain is too frustrating. Goodbye Camtasia.
Photo of Jochumzen .

Jochumzen .

  • 1 Post
  • 0 Reply Likes
  • Frustrated

Posted 2 years ago

  • 2
Photo of SUPERARR

SUPERARR

  • 68 Posts
  • 19 Reply Likes
Uninstall 
Upgrade windows
upgrade drivers
Reinstall Camtasia 9

Worked for me!

try 
http://download.cnet.com/Driver-Booster/3000-18513_4-75992725.html

To get your drives up to date- be very careful there are a lot of imitators out there.
and even read the fine print on this one as they will try to install programs you do not need!

Good Luck
Photo of Frank

Frank

  • 36 Posts
  • 20 Reply Likes
You cannot blame Camtasia for this. I work with both version 8 and version 9 and never had any issues with the recorder (at least not since version 8.6).

What you describe very much sounds like a driver or system configuration problem. There could also be a driver conflict of some sort.

I suggest you check your system carefully. Running into these kind of problems with other software made me reinstall Windows and install one driver at a time to see at what point things go wrong.

One good example of a problem I once ran into was a video capture device (from another company) that installed and worked correctly but that was totally screwed up every time I ran Windows Media Player, forcing me to reinstall the driver each time. It took me a while though to figure out the cause because it is so common to play media content that you do not think of something going wrong in the background.

So as you can see, the problem can be subtle and unexpected. FYI, I have run into some problems and even a bug with Camtasia 9 on Windows 7 64 bits. But the recorder is the one part that has not given me any problems so far and I do screen recordings at least once a week.
(Edited)
Photo of Jess Wilkinson

Jess Wilkinson

  • 28 Posts
  • 9 Reply Likes
Camtasia 2018 is giving me the same problem, when record crashes (typically 1hour + recording) it most times does not offer a recovery file option. Poof the file is gone. It mostly seems to happen when I exit to editor. 1440p captures too.