Camtasia: s l o w start, no feedback as starting

  • 1
  • Idea
  • Updated 1 year ago
Camtasia 9 is a resource beast, and takes a long time to load.
During the 30-45 seconds it is cranking up, there is no user feedback.

What about immediately popping up a flash screen, as the OS on every smartphone does, to let the user user, "Hey, I got your click, I'm cranking it up".

Keep me, the user, in the information loop and remove that momentary anxiety, "Did I, or didn't I, properly click the button?--Only Camtasia knows for sure!"
Photo of Bruce Morehouse

Bruce Morehouse

  • 67 Posts
  • 22 Reply Likes

Posted 1 year ago

  • 1
Photo of wayne

wayne

  • 110 Posts
  • 30 Reply Likes
The first thing that we all consider, in issues such as what you are experiencing, is the system specs.
What is the Make and model of your system?
Memory and CPU?

Also, to make sure that Camtasia is in fact loading.
Open the Task Manager.
Right click the Task Bar, choose [Task Manager]
Then click on [More Details]
So show everything that is happening on your system, during this time.
(Edited)
Photo of Bruce Morehouse

Bruce Morehouse

  • 67 Posts
  • 22 Reply Likes
D'oh--I should have included that info!  Thanks for the suggestion.
Dell Latitude E6430, (i7-3540M CPU @ 3Ghz)  12GB RAM, Windows 7 64bit
I did use the task manager, so I knew it was running.  
Just tried again this morning, and it was down to 12 seconds before something showed up.

I did notice that it didn't prompt me to check for updates (I hadn't used it in a while before the previous launch), so it may be that it is an internet delay compounding the issue (I'm in a rural situation with 700KB upload, 4MB download, speeds).  All the more reason for a window that pops up quickly.  Hard to test against all environments!

Thanks Wayne for checking in.
Photo of wayne

wayne

  • 110 Posts
  • 30 Reply Likes
Launch Camtasia.
Click on [Edit]
Then [Prefrences]
When Dialog opens.
Click on [Advanced]
Untick the [Enable Automatic UpgradeCheck]
&
Untick the [Promot before upgrade check]
Click [OK]
Close Camtasia
And then open it up again, and see if it is any faster.
This will let you know, on rather it is a connection to the internet or another issue.

Your system specs are good, so that should not be an issue.
Photo of Bruce Morehouse

Bruce Morehouse

  • 67 Posts
  • 22 Reply Likes
Hey--whadya know?   3 seconds this time!

Since popular culture has the (only slightly?) insulting "FAIL!",
I think we need its analog, to be used (for example) in this instance.

Not knowing what that might be, and until a suitable, monosyllabic, exclamation surfaces, I'll go with "YES!"
(voiced with a drawn out  "essss" at the end, for emphasis).

To this, I add "Thank you!"

Bruce
Photo of wayne

wayne

  • 110 Posts
  • 30 Reply Likes
I learned from experience with Adobe products, as they used to be auto-internet upgrade check.
I would disable it when my internet was as bad as yours.
I have 50mb down and 9mb up now.
But, I still do not allow any program to auto-check for updates.

Glad it is faster for you now.
Have a good one and enjoy using Camtasia.

Wayne