Camtasia SCORM 1.2 TOC Bug

  • 1
  • Problem
  • Updated 4 months ago
  • (Edited)
Hey guys,

I'm having an issue when exporting a video recording to a SCORM 1.2 course.

Normally, I add markers that represent the "chapters" in the TOC and then export it as SCORM with multiple videos based on the markers. When the course is uploaded to the LMS and played, normally when you click on a marker "chapter", it goes to that video.

However, just recently, this is no longer the case. When clicking on a marker "chapter", the current marker is replayed and it does not move to the one selected. You can move forward and backwards (using the arrow buttons below the TOC) to get to each chapter, but you cannot click on one to view. 

This seems like a bug as older Camtasia projects will export and function correctly. I do have the latest version of Camtasia and tested this out on SCORM Cloud. Is anyone else encountering this issue?
Photo of Kenny Dyer

Kenny Dyer

  • 14 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of Robert R.

Robert R., Online Community Admin

  • 1560 Posts
  • 468 Reply Likes
Hi Kenny;

This might happen if the video has not yet buffered enough via the player (indicated by a grey bar at the bottom of the player, where the Play button is). If the video has not been loaded to that chapter, it will likely load to the closest available "chapter" (i.e. the start of the previous chapter). If you hit play then let it buffer a little, are you able to skip to the loaded video via the ToC?

-Robert
Photo of Kenny Dyer

Kenny Dyer

  • 14 Posts
  • 0 Reply Likes
Hey Robert, I tried that out but it will not advance even when giving it time to load the next video chapter.
Photo of Kenny Dyer

Kenny Dyer

  • 14 Posts
  • 0 Reply Likes
To follow up, I noticed the exported file is missing the config_xml java script file. That's probably what is causing the issue. For some reason, it's not being created.
Photo of Ben Rhodes

Ben Rhodes, Employee

  • 198 Posts
  • 85 Reply Likes
Hi Kenny,

With the SCORM changes we did last year around SCORM bookmarking, we no longer export `config_xml.js` for SCORM projects.  The purpose of this file to allow a user to preview a production from their desktop without uploading it to a web server.  This is not something we can do with SCORM projects so it was removed. 

The same data used to display TOC information is contained in `[production name]_config.xml`.  And it sounds like you are seeing the TOC markers being displayed in the player, so I think that is loading just fine.

I just did a fresh production with markers / split video from Camtasia 2018.0.7.  It worked as expected testing with SCORM Cloud (https://cloud.scorm.com/) in Chrome, IE11 and Edge.

Can you try creating a free account on SCORM Cloud and uploading your project there and see if you get the same experience?

Ben
Photo of Kenny Dyer

Kenny Dyer

  • 14 Posts
  • 0 Reply Likes
Hey Ben,

Thanks for the great information. I get the same results when testing in SCORM Cloud. I believe it comes down to the video I am using, but I don't understand why. It's a standard mp4 video just like the ones I have used in the past. Could I send you a test project to take a look at?
Photo of Ben Rhodes

Ben Rhodes, Employee

  • 198 Posts
  • 85 Reply Likes
Kenny,

Can you open a support ticket.  https://support.techsmith.com/hc/en-us/requests/new? When you do can you put "attn Aaron Y" in the ticket.

Ben
(Edited)