Camtasia Studio 8 not showing cursor data in camrec recording

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Message received when trying to turn on Cursor Effects:

one or more selected media does not contain cursor data. Cursor Effects will only be applied to camrecs containing cursor data.
Photo of Johng

Johng

  • 8 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 2
Photo of GIl611

GIl611

  • 4 Posts
  • 0 Reply Likes
I've got the same problem.

Any idea is welcome.
Photo of dustybirdy

dustybirdy

  • 4 Posts
  • 2 Reply Likes
I just got this issue solved, Thank you Kevin, for the tip. 
The recording file format needs to be set on .avi

After setting recording mode to AVI, 
the cursor will *NOT* be visible while recording the screen, 
but it *WILL* show when the recorded file is replayed.

------------------------------------------------------------------------
To change recording format on the screen recording bar
follow these steps:

Step 1 From "screen recording" bar, 
go to > Tools >Option(window open) >Saving >
Record to (look right for down arrow)
>drop down arrow(two options) >.avi >OK

Step 2 
From "screen recording" bar,
Effect >Cursor(option appears) > Show Cursor, or Highlight Cursor, etc......

This did it for me. 
record in avi format is a must.
-----------------------------------

This solved my cursor not recorded issue.

Thanks again Kevin. 
(Edited)
Photo of domclean

domclean

  • 1 Post
  • 0 Reply Likes
Thx Kevin, I'll test it out later

Thx!  Doug
Photo of Mbarek Akaddar

Mbarek Akaddar

  • 1 Post
  • 0 Reply Likes
Thank youuuu!  Very useful tip 
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey there,

In the camtasia recorder, are recording as a camrec, rather than an AVI file? Also, was the file you imported into Camtasia Studio recorded with the same version of Camtasia, or a prior version?
Photo of Johng

Johng

  • 8 Posts
  • 0 Reply Likes
Hi Logan, yes it is in camrec mode NOT AVI.

I'm doing the recording in Camtasia Studio 8 and immediately after the recording I'm in the edit mode to turn on cursor effect, that's where the Camtasia system message "One or more selected media does not contain cursor data. Cursor effects will only be applied to camrecs containing cursor data" appearing in red font.

regards,
john
Photo of dustybirdy

dustybirdy

  • 4 Posts
  • 2 Reply Likes
I got this same exact things happened to me today. 
A posting of Kevin said the recording needs to be set on .avi
helped me. And I believe this is where you can solve this issue.

Set your record mode on screen recorder bar to AVI.
This did it for me. Here is the detailed steps:

---coping from another posing replying to Kevin regarding this ---

I just got this issue solved, Thank you Kevin, for the tip. 
The recording file format needs to be set on .avi

Otherwise the cursor will not be visible while recording screen,
neither will show up while playing the recorded file.

To change recording format on the screen recording bar
follow these steps:

Step 1 From "screen recording" bar, 
go to > Tools >Option(window open) >Saving >
Record to (look right for down arrow)
>drop down arrow(two options) >.avi >OK

Step 2 
From "screen recording" bar,
Effect >Cursor(option appears) > Show Cursor, or Highlight Cursor, etc......

This did it for me. 
record in avi format is a must.
-----------------------------------

This solved my cursor not recorded issue.

Thanks again Kevin. 
Photo of GIl611

GIl611

  • 4 Posts
  • 0 Reply Likes
I solved my problem.
I clic on "record the screen"

On the recording toolbar, I clic on "effect" tab
clic on "option"
select "cursor" tab
select the option "make cursor effect editable in camtasia studio"
Photo of Johng

Johng

  • 8 Posts
  • 0 Reply Likes
Hi GII611,
I checked out your suggestion. The Recording toolbar / effect / Option / Cursor/ window has the option "make cursor effect editable in camtasia studio" ticked by default.
Photo of Owen Iverson

Owen Iverson

  • 4 Posts
  • 0 Reply Likes
i also just recorded a camrec and have no cursor displaying in Camtasia Studio.  i just upgraded the Studio to 8.2.0 and recorded under the previous version (8.1.2), does that matter?  (EDIT: i just uninstalled 8.2.0 and re-installed 8.1.2 and it still doesn't show up)

also, when i try to apply a cursor effect, i DO NOT get any messages about "does not contain cursor data", so it seem to apply any setting i choose, it's just not visible. (yes the "mouse cursor visible" option is checked :)

also any effects i apply to the cursor (like warp or ripple) don't affect the canvas either.
(Edited)
Photo of Josh Tompson

Josh Tompson

  • 1 Post
  • 0 Reply Likes
Before You start recording in the recording toolbar, under "Effects" tab select "Options..." ,
select " Cursor " tab and than select option " Make cursor effect editable in Camtasia Studio ".
When You want to edit recorded video, under " Tools " tab select " Cursor Effects... "
and there You have option to apply cursor effects You want.
(Edited)
Photo of Matt

Matt

  • 1 Post
  • 0 Reply Likes
When I click on Effects tab from recording toolbar and click on Options there is no Cursor tab to allow me to select this option? Where else can i turn on the cursor for my recordings? THanks
Photo of paolo.zama

paolo.zama

  • 7 Posts
  • 2 Reply Likes
SOLVED!

I had the same problem
After 2 hours of tests I found the problem: the color depth!!!
Just changed the color depth from 16bit to 32bit!
Photo of jhorine

jhorine

  • 1 Post
  • 0 Reply Likes
Worked for me! Thanks!

Jason 
Photo of Pam Pennington

Pam Pennington

  • 1 Post
  • 0 Reply Likes
Where is the color depth setting?
Photo of paolo.zama

paolo.zama

  • 7 Posts
  • 2 Reply Likes
It is a property of the screen.
Show the desktop > Right click > Screen resolution menu > Advanced settings
Photo of ryankittleson

ryankittleson

  • 3 Posts
  • 0 Reply Likes
I tried everything here and no go.  I don't have a Cursor tab in the effects menu, and my screen was set to 32bit from the start. any other ideas?
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
Make sure the " Make mouse cursor visible" option is checked in the "Cursor" TAB. Of the Editor.
See Image Below, Click to Enlarge.

Regards, Joe

(Edited)
Photo of ryankittleson

ryankittleson

  • 3 Posts
  • 0 Reply Likes
thanks! that did it.
Photo of First Vette

First Vette

  • 2 Posts
  • 0 Reply Likes

I'm now having this problem (complete with message in red, '...does not contain cursor data.').  When I open the 'Effects/ Options' window, there is no tab for 'Cursor', only 'Annotation' and 'Sound'. Any thoughts?

Photo of Fred Grover

Fred Grover, Champion

  • 2444 Posts
  • 383 Reply Likes
That option is not available from the Camtasia Studio Recorder. Try using the Camtasia Studio Editor with a video capture on the timeline and see if that might work. Take a look at Joe's image above to see the option. If that still does not work could you share more information on how you are recording and editing or some screenshots of what you are looking at please ? Thanks for posting and have a great day/night.
Photo of First Vette

First Vette

  • 2 Posts
  • 0 Reply Likes
I changed the Resolution to 32 bit True Color and opened the Recorder from inside the Editor.  Problem solved, and I'm replacing my captures.  I've done some extensive edits on one of the new captures and so far so good.  Thanks for your help.
Photo of Fred Grover

Fred Grover, Champion

  • 2444 Posts
  • 383 Reply Likes
Your welcome and if you have anymore questions feel free to ask them here. Have a great day/night and thanks for posting back your information.
Photo of Kelly Vandever

Kelly Vandever

  • 1 Post
  • 0 Reply Likes
I had the same problem and I think the issue was that my computer (HP) was trying to send me an alert (about a recall on my power cord) and it was dorking up the computer.  Since I took care of the message, I haven't had the problem again. (Knock wood!)
Photo of Abe S

Abe S

  • 1 Post
  • 0 Reply Likes
My problem still there (on a particular camrec file) all the settings mentioned for cursor were and are as suggested. The problem was originally not been able to open the project:
https://feedback.techsmith.com/techsmith/topics/error_the_project_file_cannot_be_opened_make_sure_th...

Fixed that upgrading to the lastest version of camtasia (8.5.2). But one of my camrec which displayed the mouse cursor previously no longer does on this latest version. 

In this case, I see I might need to redo the whole video, however I was really hopping to avoid that.
Photo of Ignacio Oyarzún

Ignacio Oyarzún

  • 1 Post
  • 0 Reply Likes
Now I have to do everything from scratch thank to this crappy bug.
Photo of j.ruukholm

j.ruukholm

  • 1 Post
  • 0 Reply Likes
This is a crazy annoying bug that has been driving me up the wall.
I got in contact with support, but their assistance was pretty minimal.

Their suggestion was that I switch the file type in the recording options from .trec to .AVI
Unfortunately this isn't much of a solution for someone utilizing the layered aspects of the .trec files.

I have switched most of my recordings to .AVI, but I just found myself revising an old recording I did as a .trec and my cursor began to disappear in certain video clips, even if I hadn't touched or edited the clip.

I got crazy frustrated, thinking I would now have to go back and do the whole thing from scratch, but then, in an IT Crowd inspired stroke of genius, I closed Camtasia and opened it again and lo and behold, my cursor was back!

I don't expect this to be a solution in every situation, but if you find that editing your video is messing up your cursor data, restart the program and see if it helps.

P.S. I saved my work before closing the program, taking the risk that the disappearing cursor wouldn't be fixed, but I got lucky and my cursor came back and I didn't even have to lose any work.

Hope this can help somebody, 'cause I feel your pain
Photo of Richard Franklin

Richard Franklin

  • 6 Posts
  • 2 Reply Likes
When I click on Effects tab from recording toolbar and click on Options there is no Cursor tab to allow me to select this option? Where else can i turn on the cursor for my recordings?
Photo of Joe Morgan

Joe Morgan

  • 7243 Posts
  • 3949 Reply Likes
Cursor effects are only available from the recorders toolbar when you are recording to AVI.
See Image Below



The cursor is automatically recorded to .trec and .camrec files and you can turn the cursor on or off in the Camtasia editor.

Regards, Joe

(Edited)
Photo of Fred Grover

Fred Grover, Champion

  • 2444 Posts
  • 383 Reply Likes
Joe stated that "Cursor effects are only available from the recorders toolbar when you are recording to AVI." That is incorrect as I recorded in the .trec and the .avi formats as neither one shows that option in the Camtasia Recorder under the Tool Options.

However it is true that the cursor is automatically recorded to .trec or .camrec (.camrec files are for Camtasia Studio 7) formats in the Camtasia Studio 8 Editor and can be turned on or off by using the Cursor Effects Tab. Just wanted to straighten that out here.

And Joe if I missed something in the Camtasia Recorder Toolbar Options when in the .avi for using the show Cursor Option then post a screenshot of where you seen it. That option in Camtasia Studio 8 is only available in the Camtasia Studio 8 Editor but it does not matter in the Recorder if it is set to .avi or .trec format other than in the .avi format in Camtasia Studio 8 the Cursor Effects are not available except for the .trec or the .camrec (Camtasia Studio 7 shows the .camrec format) only. I can say that my CS 7 on Windows 10 64Bit OS does not work the greatest. When I record something and it plays back it is just a black screen but I do not use it much since Camtasia Studio 8 came out. Thanks and I hope you all are having a great day.

Cheers :) Fred.

 
Photo of Joe Morgan

Joe Morgan

  • 7243 Posts
  • 3949 Reply Likes
Hey Fred,

Photo of kayakman

kayakman, Champion

  • 7078 Posts
  • 2321 Reply Likes
I'll try and clarify ...

if you capture to trec, you will be able to edit cursor effect in Camtasia Studio's Cursor Effects UI

if you capture toi AVI, you will not be able to edit cursor effects in Camtasia Studio's Cursor Effects UI

if you capture to AVI, you will be able to record the cursor using Recorder's Effects/Options tools; the cursor and any properties will be burned into the video, and will not editable post-capture; these cursor properties are not available if you capture to trec
Photo of mark.p21

mark.p21

  • 1 Post
  • 0 Reply Likes
It transpired as well! First time I've utilized camtasia and I spent stacks of hours taking a shot at my undertaking on my PC, until it began colliding with the point where I couldn't do anything to it and couldn't complete the task the cursor was there all through. Regardless I needed to finish my venture so needed to utilize my macintosh. The document and all the altering I did was shockingly not transferable to camtasia on Mac, so I needed to restart the entire venture from the first screen catch video. The main way I could discover to exchange this document to Mac was as an AVI record. However when I opened it up on my Mac-no cursor. I had no clue about the cursor settings until I read this, however like you I'm so baffled. I simply needed to finish my undertaking without my cursor as I came up short on time on it, with all the messing around on the PC that continued slamming.

invoice resell