Camtwist, Camera Live, Canon EOS M50, Camtasia, Mac

  • 3
  • Problem
  • Updated 5 days ago
In the past, I have been able to use Camtwist with Camera Live and my Canon EOS M50 to record my M50 as a webcam in Camtasia. For some reason, that no longer works, but I can still get it to somewhat work in Snagit 2020. OBS has no issue with this. Camtasia will even recognize the camera as a webcam, but then refuses to initialize the recorder. 

Yes, I know I can record my camera through OBS and then import over the screencast and sync the audio. No, I don't want to have to do that. It has worked before, and I can't see any reason it shouldn't work now and in the future.

Screencast documenting the issue: https://www.screencast.com/t/G5zzcnPY
Photo of Shawn

Shawn

  • 2 Posts
  • 1 Reply Like

Posted 2 months ago

  • 3
Photo of Jonas Hmann

Jonas Hmann

  • 1 Post
  • 1 Reply Like
I have the exact same problem with the exact setup, only my camera is a Nikon D3300. It would be great if this could be fixed.
Photo of Jacob Moore

Jacob Moore

  • 1 Post
  • 1 Reply Like
I'm having the same issue. Getting the message, "Waiting for device initialization". Any fixes?
Photo of Shawn Wargo

Shawn Wargo

  • 1 Post
  • 0 Reply Likes
I just (finally) upgraded from Camtasia 2 to 2020. Spend some $$... but it seems worth it.

I am using my iPhone with EpocCam (1920x1080) on my MacBook Pro 2019 (10.15.5) and it worked flawlessly in Camtasia 2... but now I get the infinite "Waiting for device initialization". As the original post... it can even see it during New Recording setup.

Switch back to Camtasia 2, again, it works flawlessly. I also isolated it specifically to this EpocCam... because 2020 does work with the built-in FaceTime HD camera (1280x720)

I found this article about Camtasia 3.. and Mac OSX System Settings... but I have Camtasia 2020 enabled for Camera, Microphone, Accessibility, File Access and Screen Recording :|

https://support.techsmith.com/hc/en-us/articles/360018592411-Camtasia-Mac-Recording-Stuck-on-Waiting...

So, apart from enabling/disabling System Settings... I've restarted Camtasia 2020, uninstalled/reinstalled and rebooted. No luck :(
(Edited)