Can't copy to clipboard

  • 1
  • Problem
  • Updated 2 years ago
I set the snagit screenshot to copy to the clipboard, but do not open the editor. But after each screenshot I will open the editor, and will not be copied to the clipboard.

I have opened the security settings in the privacy settings, I am the latest version of macOS system, and I have tried to restart the system and re-install Snagit. Still can not solve the problem.
Photo of Microhoo

Microhoo

  • 2 Posts
  • 0 Reply Likes
  • sad

Posted 2 years ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 719 Posts
  • 177 Reply Likes
Hi,

What version of Snagit are you running? This appears to be working in our latest version, 4.0.6. Also where are trying to paste the image? I've seen a few websites where it doesn't always work.
Photo of Microhoo

Microhoo

  • 2 Posts
  • 0 Reply Likes
I found this magical bug. If I set the screenshot shortcut key through Preferences-Keyboard, I can not open the editor at the end of the screenshot and copy it directly to the clipboard as I did in Capture Window. But if I set the shortcut key through the Capture Window, then I can copy it to the clipboard as it was set and do not open the editor. Although both are shortcut keys for the same function.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 719 Posts
  • 177 Reply Likes
Hi,

Sorry for the confusion. We actually have 2 different capture windows and the hotkeys in Preferences-Keyboard apply to the old capture window. I've attached a screenshot showing where to edit the hotkey for the new capture window (green), and also how to enable copy to clipboard for the old capture window (red). Let us know this this clears up some confusion.