Can't get Snagit 2020 to work with my webcam (yes, permissions were already granted)...HELP!

  • 1
  • Problem
  • Updated 1 month ago
I am using Snagit 2020 on a Mac. I am unable to get Webcam recording to work for quite some time. The webcam settings was previously set to ON, yet no webcam would record.

I uninstalled and reinstalled Snagit. I confirmed that all system permissions (for camera, etc) have been granted for Snagit 2020.

Now the webcam setting is on OFF, and clicking it does nothing.

Can you help?

Thanks.
Photo of David Giller

David Giller

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 month ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1535 Posts
  • 389 Reply Likes
Hi,

Sorry about this! The first thing I would try is to reset the permissions with the operating system by running tccutil reset All com.TechSmith.Snagit2020 in Terminal. Then you'll need to grant webcam permissions again by attempting to enable it in the capture preferences view.

If this doesn't work, then I would open up a help ticket with our Tech Support team.
Photo of David Giller

David Giller

  • 3 Posts
  • 0 Reply Likes
Luke - Thanks for the quick response. I went ahead and followed those steps. I ensured that Camera permissions were granted. I restarted the computer...no change.

See attached screenshots for reference.

I've created a ticket on this issue.




Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1535 Posts
  • 389 Reply Likes
Is webcam enabled in Screen Time settings?

Photo of David Giller

David Giller

  • 3 Posts
  • 0 Reply Likes
That checkbox is populated. In fact, I have Content & Privacy Restrictions turned off, so everything is populated.

(Edited)