can't capture screen video snagit 2.1.5

  • 6
  • Problem
  • Updated 6 years ago
  • Solved
What happened to being able to record the screen??? Why is SnagIt trying to use my webcam to record my screen???

My hypothesis is that a solution will be offered that invariably requires breaking some other perfectly stable, never-caused-a-problem-with-any-other-piece-of-software-but-techsmith, working component of my system. Is it a codec thing? Is sandboxing the issue? I just find the perpetual, not-quite-ready-for-showtime-but-we'll-sell-it-to-you-anyway software incredibly frustrating. Mmmmyeah. Just a little bit. But prove me wrong. Please. Tell me what setting I've stupidly set wrong so I can actually use the software and it will make my day.
Photo of bigwhaledork


  • 1 Post
  • 0 Reply Likes
  • frustrated.

Posted 7 years ago

  • 6
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 640 Posts
  • 97 Reply Likes

Thank you for letting us know about the trouble with Snagit. We certainly apologize for the issue you are experiencing while trying to capture a video.

The window you're seeing with the ellipsis isn't related to the webcam, that is simply a countdown window that is needed while we are launching the Snagit video recorder.

With the 2.1.5 release we did not make changes to the video capture process, however, the bug you're seeing is one we have had a very difficult time tracking down, it's a bit of a phantom issue. I realize this doesn't make it any less frustrating to have a product fail on you, but I wanted to give you some context into the history of the issue.

When Snagit attempts a video capture, we are relying on a number of system components to provide the frames and capabilities to capture a video on your screen, and in certain cases (your's currently), the underlying pieces don't seem to respond and launch properly. However, as I mentioned, we have been unsuccessful in finding reproducible steps to hone in on the root cause.

Now, onto actually getting you up and running:

1) Exit Snagit
2) Open Activity Monitor (in /Applications/Utilities)
3) Filter processes by "Snagit":
4) If any Snagit processes are still running after exit, please end those via Activity Monitor using the "Quit Process" button.
5) Check for system updates (especially QuickTime)
6) Restart Snagit

If you are still experiencing the same video capture issue, please post back and we will continue troubleshooting and do our very best to get this resolved in a timely manner.

Thank you very much for posting about this problem and we do sincerely apologize for this annoying issue.

Photo of Ron N

Ron N

  • 2 Posts
  • 0 Reply Likes
I have the new SnagIt 2.0 for Mac... but after recording one video and wanting to use it again, I get the message "Video Capture Failed"

The only way to fix it is to close SnagIt and open it again. But after I record each video, I have to close and re-open. This is definitely a bug :(

This reply was created from a merged topic originally titled
"Video Capture Failed".
Photo of Jorge Salcedo

Jorge Salcedo

  • 1 Post
  • 0 Reply Likes
I updated to Mac V 2.1.3 (75596) to be able to capture video. 9 out of 10 times I try to do that it fails: "Video Capture Failed - Failed to initialize video recorder process". I'm running on an iMac 2.5 GHz Intel Core i5 with 16 GB RAM, OS X V 10.7.5.

This reply was created from a merged topic originally titled
2.1.3 Video Capture (almost) always fails.
Photo of John Tenny

John Tenny

  • 3 Posts
  • 0 Reply Likes
I had/have the same problem and here's what I heard from TechSmtih:

"First, I would like to have you disconnect all external audio devices that may be connected to your machine.
Next, we'll want to exit the Snagit application.
Then, please go to the Finder and click on the Go menu. Hold down the Option key, and then click on the Library entry that appears in this menu.
In the window that appears, please open the Preferences folder.
Here you will look for any files that begin with "com.techsmith.snagit" and move any and all of them to the Trash.
Now, reopen the Snagit software, set it to record a video, and mute the audio input. Does the same error occur?"

My response after trying the above:

"I followed your steps and it's working as expected, both muted and unmuted, using the built in microphone. When I plugged in the headset/mic and switched to the headset/mic without restarting Snagit, it failed.
If I quit Snagit, plug in the headset/mic, start Snagit, it records fine. The sequence seems to be the key."

the bug is related to adding the headset after Snagit is running.
Photo of mbritt1216


  • 1 Post
  • 0 Reply Likes
That worked. Many Thanks!
Photo of Jeff Axup

Jeff Axup

  • 5 Posts
  • 2 Reply Likes
I was having the same problem, and here are the causes I can find for the bug. (I have a registered older Mac version, and I am currently in trial mode on the new version.)

- I don't think it's an audio issue for me. I tried plugging in my remote mic and internal and saw the same behavior.
- I was hitting ctrl-shit-z to end the movie recording, which is my shortcut to do normal screen caps. that appears to have been the issue. There is a separate keyboard shortcut to do a video. If you try to do a normal screen cap while a video is being recorded it gives the error message and trashes the video being recorded. Using ctrl-shift-V or clicking the red end recording button seems to be more reliable.
- I also found another bug where I would click the red 'record video' button and it wouldn't switch into the recording video mode as it normally does. I had to close the app and kill all snagit processes in the Activity Monitor to reset it to where it would start recording again.

This app appears to be a bit unstable and something as small as the wrong keyboard shortcut can cause the video recording to fail and abandon currently recorded data. It should fail more gracefully than that.

This conversation is no longer open for comments or replies.