Why Are Captions Not Showing Up In Video?

  • 3
  • Question
  • Updated 5 months ago
  • Answered
  • (Edited)
I am on the 30 day trial version of Camtasia Studio 7.1 (for PC) and am persuaded to purchase the program with one glaring exception: the "Captions" do not show up on the MP4 Video when you viewed outside Camtasia or the HTML format. I spoke with tech support and they indicated the only way to have the captions show up as they appear in Camtasia is to actually re-record the screen, or import the captions when posting the video to youtube. Importing the captions does not solve the problem because the captions do not appear in the uploaded youtube video unless "CC" is actually turned on, which most people don't even know should be on. It also does not work because I want to import the videos to my website. This seems absurd, in my insignificant opinion. I would expect the program would be able to show the captions exactly as I want them when making the video inside of Camtasia. Help? Thank you in advance.
Photo of Mark Roos

Mark Roos

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 3
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1290 Posts
  • 237 Reply Likes
Hi Mark,

There's 2 ways to do captions... closed captions and open captions. You can do both with Camtasia Studio.

Open captions are burned into the video when you produce, so there's no way for the viewer to turn them off. They're always on, and look the same wherever you put the video.

Closed captions are not burned into the video. Instead, during playback, the player draws the captions on top of the video. The closed captions can be toggled on/off by the viewer, but the look of the captions may vary between different players.

Here's a short screencast to illustrate the point:
http://screencast.com/t/dGtvioXwC (3:15)

Hope this helps.
Photo of haryad8

haryad8

  • 6 Posts
  • 0 Reply Likes
sorry i have a problem with caption too can u help me ? i send u this photo every time when i want produce and share give me this title box and after finish i can\t see caption on video
Photo of kayakman

kayakman, Champion

  • 3546 Posts
  • 639 Reply Likes
this dialog means that your project has [captions] but you are producing without the player; it is the player that displays the closed captions

be sure and produce with player, and upload all the produced files, playing the video by targeting the .html file [not the MP4]; as a test, try produce and share to screencast.com and your captions should show OK
Photo of haryad8

haryad8

  • 6 Posts
  • 0 Reply Likes
thanks dear for your help .. and im try with ( Flash/HTML5 format.) it was succeeded.
 
Photo of vlady lupu

vlady lupu

  • 1 Post
  • 0 Reply Likes
Hi. I am in camtasia studio 8. How can i choose my captions to be open?
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2384 Posts
  • 341 Reply Likes
Hi,
You need to use the Custom Production Settings to do this. Here is how.
Kelly

Photo of Eileen

Eileen

  • 2 Posts
  • 2 Reply Likes
I have read this issue as well as watching your video. I still do not know where the toggle on/off button or setting for the closed captioning is.
Apparently I have made all my captions closed captions. How do I make them open in my project?
Also, I have produced this project, and the closed captioning option is there, but it does not appear when I play. How do you turn the closed captioning on with flash player when viewing the video?
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1278 Posts
  • 233 Reply Likes
Eileen,

I made a short Jing to show in more detail how to produce with open or closed captions: http://screencast.com/t/fjMo0bwF

Hope this helps.
Photo of Eileen

Eileen

  • 2 Posts
  • 2 Reply Likes
Thank you very much. That really helped clear up everything. I really appreciate it.
Photo of Peggy Marcy

Peggy Marcy

  • 1 Post
  • 0 Reply Likes
I agree that it helped tremendously. But I really don't understand why you can't make that option available in a more obvious way that does not require custom production.
Photo of Mr Camaleo

Mr Camaleo

  • 1 Post
  • 0 Reply Likes
Just did my first caption enabled video and I like to share a trick for Camtasia 2 Mac users

Open the [path to your video folder]/media/xmpFile.xml file

Look for (is at the end of the file):
<rdf:li xmpDM:name="captionsenabled" xmpDM:value="false" >

Change to (false => true):
<rdf:li xmpDM:name="captionsenabled" xmpDM:value="true">

Save... Done! :D

Reload in browser by hitting [control][R]

Be aware that, when you export the video again, the setting will be overwritten.

@dro: is it possible to have an additional option so that we can decide if we like captions on or off when the exported video plays?

Thanks!
Photo of Nilima Patel

Nilima Patel

  • 2 Posts
  • 0 Reply Likes
Hi All, I am running version 7.01 of Camtasia... I have produced 2 videos in exactly the same way... I have imported captions in exactly the same way BUT when I Produce and Share, one video works and has CC button available, but the other does not! Please help!
Photo of Nilima Patel

Nilima Patel

  • 2 Posts
  • 0 Reply Likes
Should have mentioned I am producing using Custom Settings and MP4 version.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1290 Posts
  • 237 Reply Likes
@Nilma: Try this video, that I posted above for Eileen, which explains the difference between closed captions (with CC button) and open captions (without the CC button) in Camtasia Studio 7.x.

http://screencast.com/t/fjMo0bwF

Hope this helps.
Photo of Sandra Rogers

Sandra Rogers

  • 2 Posts
  • 0 Reply Likes
Dear Dave,
Your answer explains how to create the two different types of captioning---closed or open---however, it does not address the issue that Nilima and Mark had. I have the same situation: I did everything according to the TechSmith guidelines, but when I try to view the closed captioning in the MP4 format, they do not appear. There is no option (CC) to turn them on. I can see that I did it correctly when I get the preview of the video in HTML. However, when I play the final MP4 I don't see any captioning. Note: I'm using Camtasia Studio 7; the open captioning with underlay works. The closed captioning with overlay does not.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1278 Posts
  • 233 Reply Likes
Sandra,

Closed captions are displayed by the player. Closed captions are not part of the video. This is why closed captions can be toggled on/off.

The "overlay" vs. "underlay" is simply where the captions are positioned, either on top of the video (overlay) or under the video (underlay).

The "open" vs. "closed" captions describes whether or not the captions are part of the video itself (open), or text that is read by the player and displayed over the video during playback (closed).

It sounds like you've produced with closed captions, and that they're working correctly when you launch the video using the HTML. This is because the HTML loads the player. The player loads the video, and separately reads the text captions, and as the viewer you can toggle them on/off. If you produced with closed captions, then the MP4 is the video only. If you want captions, you must play the video using the player, either by hosting all the files on your own web server, or by using the Share to Screencast.com option.

Hope this helps.
Photo of Sandra Rogers

Sandra Rogers

  • 2 Posts
  • 0 Reply Likes
Yes, thank you. I talked with our media team about this. I understand now that the video with open captions and underlay is part of the video and therefore plays fine. The closed captions with overlay is a separate layer from the video and will not play in regular video players like Windows Media Player on my desktop. I'll need to upload the whole Camtasia project file to our FTP and link it directly to our website, not just the MP4 video file.
Photo of kowen67

kowen67

  • 2 Posts
  • 0 Reply Likes
Dave, I can see the captions in the html file and not in the MP4 as you explained. If I upload the MP4 to youtube will the captions then show, or do I have to choose "share to youtube" directly when producting for the captions to show. Or what do I do?! With thanks Katherine
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1278 Posts
  • 233 Reply Likes
Katherine,

If the captions are showing up when you double click the HTML, but not when you double click the MP4, this would indicate that you've produced locally with closed captions.  If you upload just the MP4 from this file set to YouTube, then you're only giving YouTube a video.  To get closed captions on YouTube, you should choose the "Share to YouTube" option, because Camtasia will pass the captions up to YouTube as part of the upload process.

Alternatively, you could choose to burn the captions into the video (a.k.a. open captions) when producing locally to MP4.  In this case, you can just upload the MP4 to YouTube.  Since the text is burned in, it will always show.  Of course, with open captions, the viewer can't turn them off.  Sometimes this is easier, because the viewer may not know where to find the closed caption setting.

I don't know which approach you're after, but both are possible with Camtasia.  Hope this helps.
Photo of kowen67

kowen67

  • 2 Posts
  • 0 Reply Likes
Thank you so much Dave. I really appreciate the quick answer. I have got captions in the MP4 now. Phew. :-)
Photo of alexandra janney

alexandra janney

  • 2 Posts
  • 0 Reply Likes
Hello David,

Having read all of the above:

How would I get an mp4 file with open captions displayed under the video? This option was available in Camtasia 7.
Photo of kayakman

kayakman, Champion

  • 3546 Posts
  • 639 Reply Likes
this is how to do under video captions in CS8 ...

http://www.screencast.com/t/tN84hLjmzM5y
Photo of alexandra janney

alexandra janney

  • 2 Posts
  • 0 Reply Likes
Thank you so much for this reply.

It would be great if Camtasia actually made a process easier for users. I feel that it was there before, it was very simple, and it produced the needed results.

Now it seems that there are a lot of extra steps that not a lot of users are comfortable with.

When I follow the directions for custom options and select the "Under" option for captions - the system sends a message that it changes the dimension of the video to adjust to captions visible "under" the video, but it does not.

I work for a university and help professors with their videos. Captions is a requirement for us. I see the need for a more simple (as in Camtasia 7) approach for creating under the video captions.

It feels that we as users, have to work around to create this space that the program is not producing, thus creating all the extra steps.

But thank you, again

Alexandra
Photo of Martin

Martin

  • 1 Post
  • 0 Reply Likes
Hi.

Please no screencasts ... they are blocked at our institution ... Simple question ... I need Open Captions ... captions should be burned into the video .... we are embedding MP4 into HTML 5 ... Where is the open / closed switch in Camtasia 7?

Thanks.
(Edited)
Photo of kayakman

kayakman, Champion

  • 3546 Posts
  • 639 Reply Likes
start a custom production; set captions properties on the smart player/options tab
Photo of James Haxton

James Haxton

  • 5 Posts
  • 0 Reply Likes
I made a Minecraft YouTube video and Since my Mic was all Like Crackling I decided to subtitle all of it with Captions, I've seen all the answers for closed and open captions but when I exported as MP4 it just didn't stay with It. How do I make it so they see the captions no matter what?.
Photo of kayakman

kayakman, Champion

  • 3546 Posts
  • 639 Reply Likes
you have to burn the captions into the video using open captions; 2 choices: over the video, or below the video

perhaps try by doing a custom production and setting options accordingly
Photo of James Haxton

James Haxton

  • 5 Posts
  • 0 Reply Likes
thanks really helped
Photo of Razmik Badalyan

Razmik Badalyan

  • 2 Posts
  • 0 Reply Likes
Hello,

imported Georgian subtitles .srt file. letters are not displayed correctly. tried different fonts, but every time displays strange symbols or rectangles, see screenshots.
instead, it should be something like this - ქართული ასოები

Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2384 Posts
  • 341 Reply Likes
Hello,
You might need to install the Windows font pack for that particular  font to display correctly.

Windows will try and get you close to what you need with some languages, however, to display all of the correct characteristics of a font style, you will need to install those languages on your computer.

Once you go to the Windows language website and install those fonts, you will need to restart your computer.
You might also need to set your computer's system language settings over to that country/region.

I hope this helps!
Kelly
User Assistance
TechSmith
Photo of Razmik Badalyan

Razmik Badalyan

  • 2 Posts
  • 0 Reply Likes
Hello,

Thank you all for feedback.

Opened file with subtitle editor and changed font to Sylfaen. Now shows correctly.

Changing font to Sylfaen in Camtasia Captions didn't do the same, though.
(Edited)
Photo of kimberlylorek

kimberlylorek

  • 2 Posts
  • 0 Reply Likes
Can you create a DFXP file using Camtasia 8? I'm posting to Brightcove and they need this file in order for the captions to show up. Help!