Capture directly to the Editor in Snagit 13?

  • 5
  • Question
  • Updated 1 month ago
  • Answered
I press the Print Screen button, capture my image, then a toolbar appears and I have to click the Camera icon and then it opens in the Editor window.  Is there a way to make the capture appear in the Editor as soon as I select the area I want to capture?  I was able to set this in v12.  If that's not possible, I will have to downgrade back to 12 because I capture images all day long, and this is very frustrating.
Photo of Christine

Christine

  • 6 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 5
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2882 Posts
  • 638 Reply Likes
Hi Christine,
Snagit 13 is able to be customized to exactly how you want to capture.

To turn off the One Click interface so you don't have to choose Image Capture all the time, choose View > Hide One Click.


Then, with that closed, use the Capture interface to choose how you want to capture.

So, if you want to use the All in One capture setting that opens the image in the Editor, just choose these options.


I hope this helps!
Kelly
Customer Engagement
TechSmith
(Edited)
Photo of JL1

JL1

  • 286 Posts
  • 127 Reply Likes
Great. Much better that way!
Photo of Christine

Christine

  • 6 Posts
  • 2 Reply Likes
Perfect, thank you!
Photo of i1patrick

i1patrick

  • 12 Posts
  • 10 Reply Likes
Thank you for this info!  I was really unhappy about that extra step.  I've used SnagIt for many years and consider it a vital tool.  I'm very accustomed to my SnagIt captures going right into the Editor as soon as my capture action is complete.  It's pretty much muscle memory now.  The appearance of that toolbar (and the extra click to make it go away) was enthusiastically unwelcome.
Photo of DeeAnn Lee Gibson

DeeAnn Lee Gibson

  • 2 Posts
  • 1 Reply Like
I agree! I also noticed that I have technical issues with this version. After I get the image, nothing happens. It's so frustrating. It's hit or miss. Today it isn't working right and I need it. Tech support was no help. After a while. It started working on its own. I hate this version.
Photo of George Crofton Sr.

George Crofton Sr.

  • 1 Post
  • 1 Reply Like
I have owned Snagit 8, 9, 10, 11, 13 and now the trial version of 2018. The only problem that I have ever had is with Snagit 2018. I give up on it. The Editor will not load or display, that makes it worthless. I am going to stay with 13 until the bugs are eliminated. I would like the update but ...
(Edited)
Photo of Annik Stahl

Annik Stahl

  • 10 Posts
  • 1 Reply Like
This did not work for me.

 1. I did  View > Hide one Click
2. Image > Region > Preview in Editor is on, copy to clipboard is off.

I perform a capture using my preferred hotkey and while it captures, it sits there until i press the Camera icon to open it in Editor. How can I get the Editor to open automatically ( like it has for EVERY OTHER VERSION of this product)?

I tried restarting the program and now my hotkeys don't even work.

I'm beginning to rue the day when I blindly updated and paid $25.
Photo of Annik Stahl

Annik Stahl

  • 10 Posts
  • 1 Reply Like
Photo of snagit

snagit

  • 1 Post
  • 1 Reply Like
It's nice to know it's so customizable, but I'm on board with the new features. On the fly video or image capture and the ability to change the size of the capture area, all before making the commitment to an image. Thanks
Photo of romeovoid

romeovoid

  • 2 Posts
  • 2 Reply Likes

Please instruct me on how to capture 'image' direclty to Editor.  I don't want to have to use the below panel to choose capture mode.

Photo of José RAMOS

José RAMOS

  • 1 Post
  • 0 Reply Likes
Also waiting on this. I don't want that extra step to capture something. 
Photo of i1patrick

i1patrick

  • 12 Posts
  • 10 Reply Likes
Mostly just make sure when you're in SnagIt, you're capturing images starting from the left middle tab labeled "Image" and turn on "Preview in Editor" on the right.  If you start SnagIt with these two set correctly, it will go to Editor after you capture.
Photo of Dubie

Dubie

  • 1348 Posts
  • 1080 Reply Likes
If you have One-Click active than just make a image and/or video profile to do what you want to do and use that instead of the big red button.



Or if you prefer the capture window.



:)
(Edited)
Photo of i1patrick

i1patrick

  • 12 Posts
  • 10 Reply Likes
Yeah, uh no. That always-on One-Click screen booger will never be welcome on any computer I own.  So, aside from that, was there anything incorrect in the advice I provided?
Photo of Dubie

Dubie

  • 1348 Posts
  • 1080 Reply Likes
To each their own.
For me working on three monitors now the one-click option gives me the best workflow.
I hover over the one-click sliver at the edge of the monitor,  click one of my profiles and done.

This is just my preference. Having the big capture window pop up and then change the settings to have a different type of capture is time wasted thus my comment as a option using different capture profiles unless of course you always do captures the same way all the time then cool.

Here I primarily use five different ways of captures and without profiles it would suck.

Never indicated anything wrong with your comment.
I was just throwing another option out there so others are aware of it.

all good :)
(Edited)
Photo of i1patrick

i1patrick

  • 12 Posts
  • 10 Reply Likes
I can see that. For me, it's that "fly out" action when I'm not looking for it that was a huge annoyance with the One Click thing. 

I did try your suggestion.  For some reason, it wouldn't let me select an All In One capture type.  Any Preset that uses All In One pulls up that extra little mini-window between capture and editor that a lot of us are trying to avoid.  I edited it to Region capture type and it's fine now.
Photo of Dubie

Dubie

  • 1348 Posts
  • 1080 Reply Likes
Preset are more for only Image or only Video captures.
The all-in-one has default settings that are not changeable.

Click either the Image tab or the Video tab. Not the all-in-one tab.

Set all your preferences and then click the green save button.
Name it and/or set a hotkey if so desired.

Now you  just click your preset or hotkey instead of the red button and make your capture .
No mini-bar :)
(Edited)
Photo of romeovoid

romeovoid

  • 2 Posts
  • 2 Reply Likes
I created a preset but am still presented with that interstitial panel (to chose image or video) before going to the editor.  Can no one from techsmith answer my question?

I just want to hit my keyboard shortcut, go to the all-in-one selection, then straight to the editor (just like in the good old days).
(Edited)
Photo of Dubie

Dubie

  • 1348 Posts
  • 1080 Reply Likes
When you create your preset you have use the "Image" or "Video" Tab.
Not the All-in-one tab. The all-in-one selection is well... Image and video all in one.
You have to chose.
The All-In-One is set by default (not changeable)  to show the mini-bar to chose Image or Video.

Therefore you have to make a preset for just a Image capture or a Video capture.




New preset: 
1. Image tab ( or Video tab), 
2. Type of selection (and any other options you want) ,
3. Open in Editor turned on.
4. Click Green Save Preset button.



Name your preset and add your hotkey



You should now be able to make your capture with your new preset hotkey without the mini-bar (panel) showing up and your capture will go to the editor.
(Edited)
Photo of mwclendenen091

mwclendenen091

  • 6 Posts
  • 2 Reply Likes
I agree with romeovoid:
Even if I am using All-in-One, I do not want to see this thing: 

If I want to do video, I will use the video preset.  If I want just an image, I'll use the image preset.  If I want pano, I'll use the pano preset.  For All-in-One, I want to either chose my selection area, or click on a scrolling arrow.  After that, take me to the editor!

If TechSmith wants to add things like this for those that don't know what they want to capture, fine.  But give me a freakin' way to TURN IT OFF!

Hi-Ho, Hi-Ho...it's back to SnagIt 12 I go...
Photo of mwclendenen091

mwclendenen091

  • 6 Posts
  • 3 Reply Likes
I agree with romeovoid:
Even if I am using All-in-One, I do not want to see this thing: 

If I want to do video, I will use the video preset.  If I want just an image, I'll use the image preset.  If I want pano, I'll use the pano preset.  For All-in-One, I want to either chose my selection area, or click on a scrolling arrow.  After that, take me to the editor!

If TechSmith wants to add things like this for those that don't know what they want to capture, fine.  But give me a freakin' way to TURN IT OFF!

Hi-Ho, Hi-Ho...it's back to SnagIt 12 I go...
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
I have tried all recommendations here and I am still getting the popout to choose. i have hidden the "one click" and done presets and tried everything here...NO it's not working for me. Please send an update TECHSMITH.  I used to love the product now I'm thinking of rolling back to older version!!! ugh. 
Photo of Rick Stone

Rick Stone

  • 5143 Posts
  • 2418 Reply Likes
Hi there

Can you perhaps record a video showing us your preset settings and how things are working on your end? If we can see first hand, it's possible that we may note where you are going wrong. 

On my own system I'm using the latest Snagit and I never see the intermediate dialog unless I specifically choose to. It would seem that somewhere along the way you may have missed a configuration step. And that may be easily revealed in a video showing us how you have configured things.

Cheers... Rick :)
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
I don't use video much but I will try. 
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
when i try to capture the video, my capture window goes away. I've used Snagit for almost 7 years...trust me...there's a problem here. 

I will try to use Snipit tool to  capture my settings and the popup. 
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
Can you tell me how to capture this? 
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
So those are settings and when I click the print screen button, I get the cross hairs. I choose my area and when I click the popup appears even though the setting is off.  
Photo of debora.nipper

debora.nipper

  • 7 Posts
  • 0 Reply Likes
Photo of Rick Stone

Rick Stone

  • 5143 Posts
  • 2418 Reply Likes
Hi there

Sorry to run off on you. Had a lunch meeting to attend.

Looks like the issue is that you have the "All in one" selected and you likely just want "Image".



Cheers... Rick :)
Photo of jrodriguezpr

jrodriguezpr

  • 1 Post
  • 0 Reply Likes
that worked for me thanks
Photo of Patrick  McCarthy

Patrick  McCarthy

  • 15 Posts
  • 8 Reply Likes
A-HAH!!!!!
The missing piece for me was:
1. I had to go find the main Hotkey binding for PrintScreen and CLEAR it (Set to None)
2. Created a nice Image Preset
3. Associated it with its very own HotKey.... PrintScreen.....
Voila, done!
Photo of maria smith

maria smith

  • 1 Post
  • 0 Reply Likes
In the Notifications area, click the red TechSmith Snagit icon to open the Capture window on the screen. If you're in the Snagit editor, click the Capture button in the toolbar to bring up the Capture window. The Capture window gives you a lot of flexibility depending on what type of screen capture you want to take.
if anyone face printer issue click here https://www.brotherprintersupport247.com/blog/fix-samsung-printer-error-code-u1-2320/
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
I can't for the life of me get rid of that persistent secondary selection:


Please help! I've spent over an hour trying to change settings. 
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2863 Posts
  • 627 Reply Likes
Hello,
We're here to help... what do you mean?
Can you explain more about what you need or are trying to do?
Kelly
Photo of Rick Stone

Rick Stone

  • 5335 Posts
  • 2525 Reply Likes
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
I have image selected as the option - not video - when I click printscreen I can select an area of my desktop to create the screen capture. After my selection is made using the mouse, I have to then either select image/video/redo/ or x. I don’t want to have to select image option each time I do a screenshot. It’s redundant. I only use snagit for image capture. I need the selection to go into the clipboard directly with no additional steps.
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
i've tried to create a new preset for images, however I can't select hotkey as printscreen as there is a error message saying that hotkey is already in use. Even after I've deselected the hotkey "printscreen" as an option elsewhere in the app.
Photo of Rick Stone

Rick Stone

  • 5335 Posts
  • 2525 Reply Likes
Yeah, that whole print screen hotkey is kind of troublesome. When I started bumping up against it, I just opted for a new hotkey combination. I can't tell you why, but I opted for Ctrl+Shift+A as my key combo for images.
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
I would like to use Printscreen. If TechSmith could confirm there is no work around...
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2863 Posts
  • 627 Reply Likes
Hi,

Can you take a look at this support article on how to change the behavior of that hotkey to match what you need?

https://support.techsmith.com/hc/en-us/articles/204189118-Snagit-Windows-Capture-Directly-To-Image-U...
Thanks,Kelly
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
It is set to "Print Screen"
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
Clicking "print screen" starts the screen capture process. The part I don't want is the step having to confirm what the screen capture was. Similar to the image I uploaded before showing the camera icon, video icon, full screen icon, recapture and X.
Photo of Rick Stone

Rick Stone

  • 5335 Posts
  • 2525 Reply Likes
Where exactly do you have Print Screen assigned? Does it show up as shown below?



If so, make sure that Image is configured and the selection is as you want.



Notice that on the left side, if "All in One" is selected (it's the option just above Image), you are forced to choose the type of capture.

Other than this, you need to simply ensure your preset (if you are using one) has been properly configured.

Cheers... Rick :)
(Edited)
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
As above is almost exactly how i have my settings. Image is the forefront option on the left as in the image. I do however have "copy to clipboard" selected. NO other changes or differences
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2863 Posts
  • 627 Reply Likes
So are you saying this isn't working for you?
Please send a screenshot of your entire SNAGIT capture interface. We need to see what you have going on to give you more information.

Did you save the profile?

What is happening when you press Print Screen right now?
Kelly
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like
I can't take a screenshot because the interface disappears when i hit "printscreen"...
Photo of Joe Morgan

Joe Morgan

  • 6889 Posts
  • 3783 Reply Likes
If you're using Windows 10, hitting the windows key and PrtScn will take a capture and put it in a folder called Screenshots  in your pictures folder.
Photo of jp

jp

  • 9 Posts
  • 1 Reply Like