Capturing on a Youtube Comments Page

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
There's a problem when capturing a screen section from the comment's page of a youtube video.

I tried to snag the section of the page which includes the video description and also part of the first comments. However, it was not possible. The crosshair does not jump sections. If I start defining the video id section, it doesn't go into the comment's section. If I start defining the comment's section, the crosshair doesn't go up towards the video id section. 

I did notice that sliding the crosshair towards the far right; outside of the video and comments section, it freely moves from top to bottom; only when in the video or comments section does it get limited, or restricted, vertical movement.

I'm including a link to the page I was traying to capture with Snagit for Chrome.

https://www.youtube.com/all_comments?v=LTq8TrA3hb4
Photo of EduardoCarrilloNET

EduardoCarrilloNET

  • 9 Posts
  • 1 Reply Like
  • happy

Posted 7 years ago

  • 1
Photo of Kelly Rush

Kelly Rush, Product Manager

  • 366 Posts
  • 79 Reply Likes
Hi,

This is definitely going to be a known issue (hopefully one of our developers will give a better technical answer tomorrow). Due to the nature of how capturing in tabs works right now, we're going to be limited in crossing over some sections of pages, depending on how the page was designed. I'm willing to bet that this is something we might be able to work around in the future, but for now, it's going to be a limitation.

I'll mark this as acknowledged so that you guys know you're not doing anything wrong! :)
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
Official Response
Yep.  This is a known issue.  When the cursor crosses over content embedded in an <iframe> element, we lose mouse events until it has reached the other side.  We are looking into a fix.  If it isn't addressed by the public release next week, it should be fixed shortly thereafter.
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
This was fixed for the 1.0 release, so I'm going to mark this problem as resolved.
Photo of EduardoCarrilloNET

EduardoCarrilloNET

  • 9 Posts
  • 1 Reply Like
It totally does!!!
The crosshair is responsive and slides smoothly in all directions.

Awesome!!! :-)
Photo of Kelly Rush

Kelly Rush, Product Manager

  • 366 Posts
  • 79 Reply Likes
Thanks for initially reporting this one Eduardo!

This conversation is no longer open for comments or replies.