Choppy playback motion w/staggered monitoring when more than 2 or more tracks playback - Camtasia 8.6 & 2019

  • 1
  • Question
  • Updated 3 months ago
  • (Edited)
Why does video motion stop or stagger monitoring when 2 or more tracks are stacked on playback?. The playback freezes the video motion or makes it very choppy while the cursor continues as well as the audio track.

This happens in Camtasia 8.6 & 2019  if you add more than a few edits of moving video footage. Especially if you add transition effects it makes it drag even worse.

My HP PC has 16 GIGS of ram and an iCore 5 Intel processor. Yes, I know not the grandest workstation but you would think the footage would keep running before stagnating so quickly.

It seems after a few edits, stacks of tracks and effects, Camtasia becomes overloaded so easily.

What I have to do is render section by section then reassemble for the final export rendering.  And it gets pretty difficult along the way to see if my edits playback ok if you can imagine that process.

Hence, I've had to waste many hours completing music videos, etc, and have to always overcompensate for what Camtasia seems to lack.

I will say music videos do have more edits with more stacked tracks.

Maybe someone knows a way that I could better optimize my camtasia settings for better playback or will possibly know the exact amount of ram I need to upgrade to get a more smooth playback.

I believe my system is above stated Camtasia PC system requirements to handle edits.

Photo of Michael

Michael

  • 8 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of Muscle Whisperer

Muscle Whisperer

  • 102 Posts
  • 75 Reply Likes
Hi Michael, we have a long (and heavily commented) thread on this problem.
Yesterday Camtasia came out with an update that we hope addresses some of the problem.
For many of us, it's not the track stacking but the source video that is the cause of your problem. If your source video is high-resolution (h.264, h.265) or in an .MTC container, try running it through a converter program such as HandBrake to an .MP4 file. This usually solves the stuttering problem.
Try that out and let us know the outcome. But first, update your Camtasia program.
Photo of Michael

Michael

  • 8 Posts
  • 0 Reply Likes
Ok will look into this for sure!
Photo of Joe Morgan

Joe Morgan

  • 8064 Posts
  • 4358 Reply Likes
It may be the files as Muscle Whisperer has suggested.

However, an i-5 is less than ideal.
As you input more information into a project. Videos,images, multiple tracks, edits, transitions, etc.
The volume of information the processor/CPU has to deal with goes up exponentially.

You may be simply overwhelming the CPU.

Unfortunately, TechSmith has never adopted any tools to deal with this problem.

There are a vast number of ways to ease the burden on a CPU. Lowering playback resolution, proxy videos, per-rendering the timeline,etc.

What the Muscle Whisperer is essentially doing is creating a proxy file, except he can't switch back to the original quality video and render the video with it. Which has it's advantages.

There was a post where someone said they were rendering low resolution videos of the original. Adding that to Camtasia and grouping it with the original. Editing the group with the low resolution video on top so Camtasia can play it back much smoother.
However, without trying it myself, there are drawbacks to editing grouped videos.
Plus its another long winded workaround. Producing videos just to get started.

This is a huge Camtasia drawback. I hope they incorporate some common sense solutions one day.

Regards,Joe
Photo of Ed Covney

Ed Covney

  • 706 Posts
  • 398 Reply Likes
Try the same rendering but without h/w acceleration. I just did renders of 1000 seconds of Aqua Man (~mid file) at 1920 x 1080, it noticeably missed frames every second or two (jumpy) when I used H/W acceleration (nVidia GTX 970). A second render without h/w acceleration, took longer but was smooth as silk.
(Edited)
Photo of Michael

Michael

  • 8 Posts
  • 0 Reply Likes
Now sure where the h/w acceleration setting is if you can point me to it. Thanks! 
Photo of Joe Morgan

Joe Morgan

  • 8064 Posts
  • 4358 Reply Likes
If you haven't found it yet, its in user preferences.



You must restart Camtasia for it to take effect.
Photo of Michael

Michael

  • 8 Posts
  • 0 Reply Likes
Thanks Joe!
Photo of Michael

Michael

  • 8 Posts
  • 0 Reply Likes
Hi all and thanks for all the cool support and ideas. Very much appreciated!