Choppy/Laggy Video when in preview and the studio! Please Help!

  • 9
  • Problem
  • Updated 10 months ago
I record gaming videos and when i play everything is smooth, and while i am playing and recording it is smooth but once is made into a file the video is really Choppy/Laggy! I only have Windows XP but my computer is really good! Please Help!
Photo of Eric Warren

Eric Warren

  • 2 Posts
  • 0 Reply Likes
  • Sad

Posted 6 years ago

  • 9
Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
So, you have recorded in-game footage. If you play the raw file directly, it is smooth. If you play it in camtasia studio, and add it to the timeline, it plays smooth too. But when you produce your video, the endresult is choppy?

That means there's something wrong with your producing settings. As what file are you trying to produce, and using what settings?

If I misunderstood you, please rephrase the problem.
Photo of Eric Warren

Eric Warren

  • 2 Posts
  • 0 Reply Likes
No when play and record it is smooth, but after i end the recording and it makes the video in to a preview it Choppy/Laggy as well in the studio.
Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
Okay, so you have recorded a movie in-game. While recording that movie in-game, everything is smooth.

After the recording, you play back the recording in that preview window, and it is still smooth. You say: save and edit to bring it in camtasia studio. You drag it to the timeline and from there it is choppy. After producing, its still choppy, am I right?

Have you increased the resolution of the project and are you thus stretching the video?

What codec/fileformat are you using in camtasia studio when you produce your video?

Note that even on my high-end system, the preview becomes choppy in Camtasia Studio when I go to a high resolution such as 1080p. 720p does run quite well on my pc. After producing the video, the end result does play normally, but bad settings in camtasia studio can result in a choppy output too.
Photo of kayakman

kayakman, Champion

  • 6858 Posts
  • 2187 Reply Likes
some details that might help here ...

what version of CS?

what was dimension of capture?

what are editing dimensions in project? how long is the project? what edits do you make to project?

is the choppiness seen on produced video [render out of the editor]; what production specs do you use; output file type? what are dimensions used for final video production?
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
I'm having the same issue and TechSmith's customer service / tech support is completely unhelpful. I'm amazed that they're ignoring this because it's such a well-documented issue.Has anyone gotten any help from TechSmith with this issue?
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Kari,

I've posted my contact info on one of your other posts to assist you further.
Photo of Couponsam Coupon

Couponsam Coupon

  • 1 Post
  • 2 Reply Likes
Is there an option to reduce the preview resolution?
Photo of Johannes Olsson

Johannes Olsson

  • 1 Post
  • 1 Reply Like
There should definitly be a way to reduce preview resolution. It's choppy as fuck! Unworkable...
Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
Kari, what exactly do you experience? I tried asking Eric, but he never confirmed what he experienced. Without getting the full picture its hard to troubleshoot the issue.
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
While editing, the preview video is choppy & lags behind audio. Doesn't matter what type of video file I use. The produced video is fine - it's just during preview that it's a problem. I have not increased the resolution of the project. I'm running Camtasia 8 on a Win7 PC, a setup which seems to often result in this stuttery video problem, if I believe the results of my web searches... I've followed tips for fiddling w/ regedit settings, updating drivers of all kinds... etc. ANY help would be greatly appreciated.

Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
Do you have any kind of effects on your video clips, and in what resolution are you working? I notice on my powerful pc, that when I go above 720p or I use effects such as changing speed, that the preview can't cope. Rendering the video always works, no matter what resolution or effects I apply to my video.

Then again, I used other video editing software too, and they compensate by making a very ugly preview window on a very tiny resolution, and even then time stretching is laggy until its pre-rendered. So unless Camtasia Studio changes something to improve this, it is something that will happen.
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
This happens whether there are effects or not, when clips are short or long, and no matter what resolution is set to.
Photo of Nick Herber

Nick Herber, Technical Support & IT Manager

  • 27 Posts
  • 3 Reply Likes
@Eric - I would say that if you are still having trouble with it after all of the tips so far in this post, perhaps putting in a ticket with our Tech Support team would help? That way they can get specific diagnostics and see if the issue is coming from your system - or if you can share your content with them, take a look at the content and see if we can reproduce it on our end. Unfortunately for this problem, there are quite a few things that can lead to this issue.

@Kari - Having taken a look at your ticket with Technical Support, it looks like your system is unfortunately below the system requirements for the software in a couple of areas. In that situation, the poor performance - while very unfortunate - is to be expected.
(Edited)
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
@Nick - Sadly, this exact same issue is widely reported as being a Camtasia problem on Win7 PCs. Is there an ETA on when TechSmith will fix this bug so Win7 users can use Camtasia?
Photo of Nick Herber

Nick Herber, Technical Support & IT Manager

  • 27 Posts
  • 3 Reply Likes
@Eric - I apologize, I also forgot to provide a link:

https://techsmith.zendesk.com/anonymous_requests/new

@Kari - I am sorry that it is not operating for you the way all of us would like, but there are several different things that can cause this. Yes, some users are seeing this issue, but there are other threads that show that the issue was resolved by applying things like an increased memory patch or trying it on a different machine or even working with lower resolution videos depending on the situation. Not all of these instances are the same source issue, though the symptoms often present in similar fashion.

In your instance I am afraid, there are no patches that will help. The machine you submitted information on falls short of not only our recommended system specifications, but also the base required ones.
(Edited)
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
@Nick - Unfortunately, I know enough to know that it is incorrect to claim that my PC's memory is causing this issue.

This is well-documented as a hardware acceleration issue re: running Camtasia on Win7.

I'd appreciate it if anyone could provide assistance with this. I'm gradually going through lots of potential regedit keys. This'll take me AGES to solve unless someone else who has already found the key is willing to share. (If so, please share with TechSmith staff, as well. Despite hearing their customers mention this repeatedly, they have not been equipped to handle the situation.)

Cheers to anyone who can help w/ this regedit key. :-)
Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
If hardware acceleration is the issue, you can check that out by ensuring AERO is chosen. In windows 7, when you either select windows classic theme or windows basic (so no transparency in the taskbar) then hardware acceleration is also disabled. I often see systems well capable of running with HW on, but set to this theme become slower, so you could look into this. Note that if your pc is a bit slow, windows may popup a message suggesting turning off aero. If this has happened once, and you said yes, chances are you're using windows 7 basic theme.

To change, right click your desktop, personalise. Select a theme other than windows 7 classic or basic. You'll be able to select a different color too. Basic is always light blue, and classic is windows XP look.
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
@Leon - (sigh) if only that were true.

I've never used Aero (I always customize) & everything I've found says that using Aero is one of the biggest culprits. All tips I've found say to change the theme to Win Basic or Classic - anything except Aero.

Nor can I change acceleration using Desktop settings, because in Windows 7 Home, users are unable to fiddle w/ that option. (And WinXP Mode isn't available for Win7 Home.)

Hence me fiddling w/ regedit.
Photo of LPChip

LPChip

  • 38 Posts
  • 1 Reply Like
It is. Have you actually tried enabling Aero?

I know about how it usually is the culpit. I'm a network/system administrator, and I have solved many issues because of this. An example: A user was having a problem that his video played all choppy and laggy and wouldn't play on his beamer. I did quite some research and found out that I had to enable hardware accelleration. I went to the place where I'd expect to enable it, and it was all grayed out. A lot of more research led me to the conclusion that in windows 7, hardware acceleration cannot be changed, but it is always disabled when using windows classic theme or windows basic theme, while it is always enabled when using windows aero theme.

I tested this on windows 7 professional, but it should apply for home premium just as much.

For the sake of testing this issue, for me it doesn't matter whether I have classic, basic or aero enabled. Then again, I have a really powerful rig with more than enough memory here.

Just give it a try. For all we know, hardware accelleration is your issue, and by using Aero, it works better. Then again, if your system specs are too low (below recommended) then it will never work unless you upgrade your system.
Photo of Kari

Kari

  • 17 Posts
  • 11 Reply Likes
Yup, been there done that. And I discovered what others have also reprted: Camtasia works better on Win7 when Aero is *not* being used. (A quick 'net search will reveal that changing it to Aero causes - doesn't solve - these problems.)

Actually, hardware accel *can* be changed in Win7. There are work arounds. For most software, there are work arounds that can be done in Admin mode. (Sadly, TechSmith software is an exception.) Another work around is to change one the relevant reg keys. (Again, a quick 'net search can provide some basic info about this.)

I know I'm not alone, based on the oodles of posts around the 'net from Win7 users having probs running Camtasia. From what I can tell, lots of users gave up. I can't afford to give up. If TechSmith would refund my $$ so I could invest in a competitor's product, I'd be happy to give up. I'd also be thrilled to give up if I tested their official (privately stated) theory to no avail, & they were willing to reimburse my costs of demonstrating this for them. I simply can't afford to invest in their theory, when other users report that it will not work.

(sigh) It's sad to see such a wide-spread issue go unfixed. :-(
Photo of Perla Durgaswaroop

Perla Durgaswaroop

  • 49 Posts
  • 4 Reply Likes
I'm facing this problem too. The video in the preview bar  is laggy and if i click on certain part of the timeline, it doesn't immediately show the clip at that point but shows the previous one. Basically it is laggy. This happened probably with the last  but one update. 
Photo of Kay

Kay

  • 1 Post
  • 1 Reply Like
I'm having the same problem.  Video is laggy.  Audio is fine.  
Photo of Ryan Tran

Ryan Tran

  • 1 Post
  • 1 Reply Like
Same problem here, Video Preview is supper laggy even when I set the preview zoom to 25%. This is w/ the latest version (v8.4x).
(Edited)
Photo of herve lepocher

herve lepocher

  • 1 Post
  • 0 Reply Likes
A solution and a clue to the problem.

Same problem when recording in-game video. Recording was smooth when I used a GTX 970 video card, but when I used a weak Radeon 8570 video card the recording was very NOT smooth. Found a solution for the 8570 - instead of playing the game in "full screen" mode I played (recorded) with the game in windowed mode, with the window size less than a quarter of the monitor surface area. Result is a smooth recording.
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1441 Posts
  • 410 Reply Likes
First we wanted to thank you for your patience while we worked to address this issue.

We are pleased to announce that that we have just released our newest and most powerful version of Camtasia and it includes some performance improvements that may help with getting better rendering performance.

We don't expect that this will resolve the issue for everyone, as the performance you will see is dependent on many factors, including...

  1. Your CPU speed and number of cores.  This is often the bottleneck when decoding large dimension H.264 video.  The decoding is multi-threaded, so it will take advantage of multiple-cores.
  2. The location of the source files on the timeline.  Slow disk I/O can kill performance.  Do not store your video files on a network drive.  Always keep your recordings and other content you plan to import into the editor on a fast, local drive.
  3. The power settings in Windows.  For laptops especially, the default power options attempt to save battery by putting limits on the CPU.  This is a trade-off, of course.  To get faster speed, you'll use more battery.  When you're plugged in, you might consider using a "High Performance" power plan, for example.  Check out the Power options in the Windows Control Panel if you're interested.
  4. Source video greater than 30 fps.  The timeline still runs at 30 fps, so any source video with higher frame rates just causes a  Note:  We have many requests for 60 fps support, and our plans for this have been covered elsewhere in this forum.  If you're interested in that topic, you can join the conversation here.

If you'd like to try the new version, you can download it here.  Please feel free to post your feedback and feature requests here in our Community forums and remember, all technical support-related inquiries should be directed to our dedicated Technical Support team at https://support.techsmith.com/ 
Photo of LPChip

LPChip

  • 1 Post
  • 0 Reply Likes
Good god, the upgrade to 9 is waaaaay too expensive. Damn, there I was hoping it was going to have a reasonable price. Guess I'm stuck with 8 then...
Photo of Paula Villegas

Paula Villegas

  • 1 Post
  • 0 Reply Likes
I have a Alienware 15 with SSD drives, a GTX 980M and a graphics amplifier with a GTX 1070 and Camtasia is SLOW the video preview which basically the most important is choppy, laggy, slow I'm desperate with this, I bought a +1200 USD in hardware to use Camtasia and it doesn't work well
Photo of Joe Morgan

Joe Morgan

  • 6541 Posts
  • 3595 Reply Likes
What type of footage are you using? Is it a Camtasia recorder recording? Is it a game video recorded with Shadowplay at 60fps?
Is it Camtasia 9.
Need some details
Photo of Hobbes

Hobbes

  • 10 Posts
  • 5 Reply Likes
Apparently this is a known issue and it is now in the "Planned" phase of trying to correct it. ( https://feedback.techsmith.com/techsmith/topics/smooth-video-preview-when-behaviors-are-applied )  

I am with many others where I thought this was just my computer. and I shared in the other thread.....  I am using Camtasia 9 and I have been going to IT and Corp trying against all odds to get approval for an upgraded computer, when I (and IT) originally thought my current computer should have been powerful enough.  I guess maybe I our original intuition was correct as this just might be a common issue with Camtasia.  

With the projects we have coming up in the next couple months, I really hope this fix is followed through and applied.   At the moment I have to literally rend the video (up to 30 minutes)......watch to see how elements line up........go back and edit to and take my best guess on how to adjust.......re-render (again up to 30 minutes)....watch rendered video.... go back and edit to and take my best guess on how to adjust.......re-render...you get the picture.  

In a project with loads of behaviors this can take what should be a 4-5 hour project (with what you see is what you get in the editor) to a couple day project as it is now.
(Edited)
Photo of Bert Charles

Bert Charles

  • 4 Posts
  • 0 Reply Likes
***Fixed*** The last two days I been having problems with camtasia being laggy-choppy. I been using the software for almost a year now without fail until March 3rd,[2018]. Here's my solution to Camtasia Laggy Choppy Playback.

So I know something had to go wrong with Camtasia and that it was not exactly a system failure. So after trying many type of different methods including a system restore. I had to result to resetting my windows 10. (Macs users,  I can't help ya but maybe ya can incorporate ya own thing. )

I know for many of y'all might be thinking why reset won't i lose my work and files. 

Windows 10 reset will reset your pc or laptop to the factory install settings. But you have an option to keep all your current documents(photos, and videos, and everything else) along with your window settings. 

When I performed the reset, I was nervous but the only thing that was erased was the apps/programs that I downloaded. 

Windows did provide a pdf file of all the programs that were uninstalled during the reset process and it even had links to the software home site. *Kudos windows.

I reinstalled camtasia and voila no more laggy or choppy videos. I don't believe Camtasia support couldn't suggest this.

I hope this helps y'all. Perform a reset and your system will be corrected to play the videos smoothly again.
Photo of Hobbes

Hobbes

  • 10 Posts
  • 5 Reply Likes
Does the new 2018 version that was just released fix this major issue?  Or not?
Photo of kayakman

kayakman, Champion

  • 6739 Posts
  • 2128 Reply Likes
suggest you download the 30 day trial and give it a try
Photo of ChristianJones

ChristianJones

  • 5 Posts
  • 0 Reply Likes
Hi Hobbes,

If you haven't tried this already, No.
When playing video in the timeline/preview window, it is very choppy - especially text transitions.
I finding myself exporting/sharing the video just to get an idea of what it looks like.
I'm running Windows 10, on an i7-6600U @ 2.6ghz with 16GB of RAM and AMD Radeon R7 M365X with 1GB of RAM.

I have changed the priority setting as mentioned by Codin - no changes there either.

Any ideas on how to improve the preview without rending?
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 6541 Posts
  • 3595 Reply Likes
Any ideas on how to improve the preview with rending?


Unfortunately for you  ChristianJones,
Your computer is not well equipped for video editing. The i7-6600u is a dual core processor  that only meets minimum requirements to run Camtasia.
Your GPU is so low powered it's not worth mentioning. 16GB of RAM is the best thing you have going.
It's a shame your computer is to slow to take full advantage of it.
You can find Camtasia Min Requirements Here.   https://www.techsmith.com/camtasia-system-requirements.html
I'll post them below.

Camtasia 2018 System Requirements Camtasia (Windows)

  • Microsoft Windows 7 SP1, Windows 8.1, and Windows 10 (Required: 64 Bit versions only). (Recommended: Windows 10)
  • 2.0 GHz CPU with dual-core processor minimum (Recommended: 2.8 Ghz 6th Generation Intel® CoreTM i5 Processor with 4 CPU Cores or better or equivalent or better AMD processor)
  • Integrated graphics is acceptable however 4K and/or 60 FPS media will perform best with discrete graphics cards
  • 4 GB RAM minimum (Recommended: 16 GB or more)
  • 2 GB of hard-disk space for program installation
  • Display dimensions of 1024x768 or greater
  • Microsoft .NET 4.6.0 or later version (included)
  • Dedicated Windows-compatible sound card, microphone, and speakers (Recommended)
  • Windows N requires the MediaFeature Pack for Windows N
  •  

If you work with 4K , 60fps or Behaviors. The recommendations are even higher.

  Guidelines for 4K, 60 FPS, and Behaviors

 

Regards,Joe

Photo of Codrin .

Codrin .

  • 1 Post
  • 0 Reply Likes
that happenes because you don't have enough resources. even wondered why there are pcs with 64gb of ram and ridiculous stuff like that? rendering and editing. 


this helpes. go to task manager, find camtasia, right click go to details, right click on camtasia set priority, set it between above normal and high. never set to real time.
Photo of Lumo

Lumo

  • 1 Post
  • 0 Reply Likes
I have the same problem here with the laggy preview. Running recent Camtasia 2018 on a Core i7, 16GB Ram, Radeon R7.
Already happens with a simple predefined Intro with Text animation.
Really annoying...
(Edited)