Chrome and mult-monitor capture slow w 2018/2019 versions if Chrome in use

  • 1
  • Problem
  • Updated 1 month ago
Starting in Q1 2019, time to be ready to actually capture even simple images after triggering a capture (key shortcut, "start capture"  button) has slowed dramatically when using multiple monitors, the latest version of Chrome or in combination. What's worse is that the delays can be retriggered depending on the actions taken while waiting or when ready to actually capture.

This applies for both the 2018 version and a trial version of 2019 on multiple computers (win 7, 8.1, 10).

This is making the product unusable. I understand that this is being worked on, but this REALLY needs fixed ASAP.

Possibly this is due to the overly complex options that are made available automagically even when all that  is requested is a simple image capture (e.g. define window region w cursor).
Photo of Neil Thomson

Neil Thomson

  • 3 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of Paul

Paul

  • 1586 Posts
  • 1177 Reply Likes
I hate it when people say "no problem here" but I have to say it because it's true, for me.

How many monitors are you using?  I'm using two. 

You might need to log a call with support.  It's free to do so:

"You can open a support ticket instead of posting in the community! We offer free, individual tech support from a team of knowledgeable agents, from 8am-7pm ET (GMT-4) Monday-Friday. Open a ticket at support.techsmith.com or call +1 517 381 2300."
Photo of Joe Morgan

Joe Morgan

  • 6692 Posts
  • 3693 Reply Likes
Same story here, I just captured Chrome on in separate tabs on 3 monitors as a test.
Not a problem, Quick fast capture.
Maybe upwards or 1 second to complete. Windows Screen capture is no better or worse.

1 monitor is 2K the others are 1920 x 1080.

If you're having problems with 4K monitors, I can't test for that.

Regards, Joe
(Edited)
Photo of Paul

Paul

  • 1586 Posts
  • 1177 Reply Likes
Why didn't the link paste - try again:

You can open a support ticket instead of posting in the community! We offer free, individual tech support from a team of knowledgeable agents, from 8am-7pm ET (GMT-4) Monday-Friday. Open a ticket at support.techsmith.com or call +1 517 381 2300.

There you go.
(Edited)
Photo of ben.sacherich

ben.sacherich

  • 16 Posts
  • 8 Reply Likes
Is the issue only apparent when your mouse is over a Chrome window?  I am experiencing this known issue:

https://support.techsmith.com/hc/en-us/articles/360021618171-Snagit-Windows-Crosshairs-Lag-on-Capture-with-Chrome

I'm curious if there is a registry value that can disable the scrolling region detection.  I'm wondering if that is the cause for my lag.
Photo of JOSE

JOSE

  • 9 Posts
  • 0 Reply Likes
Same problem here, known issue for 4 months and not fixed?