copy --> paste non functional

  • 9
  • Question
  • Updated 1 week ago
  • Answered
  • (Edited)
Snag-it 10 & 11 Copy --> paste is non-functional. Stopped working for no discernible reason.

Have uninstalled and re-installed several times -- still not working.

On-lines directions are old and do not apply to MS Word -- (can't copy/past into anything.)
Photo of shaw cartier

shaw cartier

  • 3 Posts
  • 0 Reply Likes
  • ticked

Posted 7 years ago

  • 9
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Shaw,

You are definitely correct, Snagit should be able to copy and then have an image that is ready to be pasted into a Word document.

Just to make sure I'm answering the correct question, here is a quick video showing one way to copy and paste from Snagit to Microsoft Word: http://screencast.com/t/UzY1Ja5Fl

Let me know if this is similar to your workflow or if there is a different step that is failing for you.

Thank you and sorry for the trouble with Snagit,

Jason
Photo of Mike Campbell

Mike Campbell

  • 1 Post
  • 0 Reply Likes
In case it helps, I experienced this problem today and was about to buy an upgrade, etc.  Then, I realized that the problem (in my case, perhaps not generally) was that when I did a copy using the torn edge option, a copy/paste worked if I used the default settings (torn edge on right and bottom).  The problem occurred for me only when I changed that to torn edge at the bottom only.  I haven't looked into this further to see what other options do or don't cause problems, but thought I would thrown this into the mix.
Photo of Shiva Kumar

Shiva Kumar

  • 0 Posts
  • 0 Reply Likes
still not working. I'm facing the same issue.
Photo of Cynthia Kelley

Cynthia Kelley

  • 1 Post
  • 1 Reply Like
Jason,
I have been copying and pasting from Snagit for years, but in the last few months, the paste function has been working erratically. I cannot paste into any document or email from Snagit. This happens when trying to paste to Windows applications as well as Google Docs. Sometimes after 5 minutes of trying the item finally copies from Snagit and I can paste; sometimes it doesn't.
Obviously others have this issue. can you please investigate?
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 95 Reply Likes
Hi Cynthia,

Sorry for the trouble with Snagit. Are you using the method shown in my video above or are you copying in another way? Either way is absolutely fine, I just want to make sure we can test the exact case in which you are using Snagit.

Thanks!

Jason
Photo of Kees Buth

Kees Buth

  • 1 Post
  • 0 Reply Likes
I am having the same problem.

Kees Buth
Photo of Lori Burtch

Lori Burtch

  • 1 Post
  • 0 Reply Likes
I love Snagit and rely on it for a lot of my work. I, too, just installed Snagit 11 Editor and cannot copy and paste anything - it's so annoying! I want to use my traditional shortcuts (CTRL+C for copy and CTRL+V for paste) and no go. Also, it seems that drop down windows linger for far too long. I'm getting really bummed. What is going on?

LB
Photo of Helena Bayler

Helena Bayler

  • 1 Post
  • 0 Reply Likes
This has stopped working for me. I have been using SnagIT for years and suddenly the copy and paste function has stopped working. It seems that I have to use the Editor but I don't want to do this. I want to capture the screen and paste it directly into my document from the Clipboard. 
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
If I understand correctly, it sounds like a custom profile where the capture goes straight to the clipboard, bypassing the editor would be really helpful. I made a video showing how to set one of these up. I also have it auto-applying a border to the image so it stands out in the documentation. 

How-to video: http://www.screencast.com/t/AMDhSayG6 

Please let me know if this is helpful. 
Sincerely,
Mike Curtis


(Edited)
Photo of Irmao Uniol

Irmao Uniol

  • 1 Post
  • 0 Reply Likes
I have the same problem as Cynthia described above. Actually, I just noticed that among all the screen shots in the thumbnails, some do copy (and I can paste them), some don't. But it's always the same ones that work, and the same ones that don't.
Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
I also have the same issue... I have found if the document, email or whatever it is I am trying to paste into isn't open BEFORE I capture from snagit to the clipboard it will NOT let me paste it in.  This needs to be fixed immediately!  This has been happening since 2 updates ago.
Photo of Jessie O'Donnell

Jessie O'Donnell, Influencer Relations Coordinator

  • 178 Posts
  • 30 Reply Likes
Hi David,

I am sorry you are experiencing this frustrating issue! I'll chat with the product team and see if I can get an update on this for you.

Jessie
Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
Thank you, Jessie... I appreciate that!
Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
Jessie,  new information for your support team.  It is clearly the snag-it program because if I close snag-it completely... copy and paste works just fine again.  Can we PLEASE get an update?
Photo of acole

acole

  • 1 Post
  • 1 Reply Like
I have the same issue, extremely irritating.  Copy\Paste from Snagit suddenly stops working.  Have to close my app, take the screenshot again, then reopen app and copy paste.

Photo of delete13

delete13

  • 3 Posts
  • 2 Reply Likes
Hi,

I have the same issue and awaiting for a fix.
Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
Snag-It.... could we get  a status update please?  I think this is more than enough data to show there is truly an issue.  How can we help further?  What do you need from us?  Let me know and I will provide it.
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Hello everyone, 
I'm checking with our support team to see if they have insights can could answer here. I can't find a knowledgebase article, nor am I having success replicating this based on my understanding. There could be a few things happening here. I think it would be best to open a ticket with our support team if you haven't already. https://support.techsmith.com/home They can get diagnostics, share screens and dig to the root of this. 

Sorry for the trouble with something as seemingly simple as copy/paste.
Mike Curtis


Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
Request #67000 opened.  If you can get it expedited that would be awesome!

Photo of delete13

delete13

  • 3 Posts
  • 2 Reply Likes
Hi,

Solved with Snagit 12 update. Thanks for the support.
Photo of David Simmons

David Simmons

  • 6 Posts
  • 1 Reply Like
Snag-It 12 update did NOT fix it for me, however, I did find a fix!  Snag-It support wasn't very helpful, but then again, they didn't know what to look for as their logs had nothing in them and the app appeared to be working just fine.  

You must go into each Microsoft Office App (Including Outlook) that you want copy/paste to work for correct and disable the blue tooth plugin (comm add-in).  I know... strange as hell but it did the trick!  See below:

File --> options --> add ins --> comm add ins (near the bottom & click GO) --> delete bluetooth.
You have to do this for every office program and then the clipboard works fine!

So, to clarify... it is not a snag-it issue so to speak.  It is another Microsoft bug.  Meh... we are used to those!  ;-)
(Edited)
Photo of ThrustKnightly

ThrustKnightly

  • 1 Post
  • 0 Reply Likes
Bluetooth not present in my Office installation - Snagit 11 copy/paste problem still exists.
Photo of djn-buffalo

djn-buffalo

  • 1 Post
  • 0 Reply Likes
Thanks David. This worked for me, so far! This issue has been driving me crazy for a while. I should have searched sooner.
Photo of Robert

Robert

  • 1 Post
  • 0 Reply Likes

This worked for me so far!

an example of my problem:

at a web page, CTRL+C to copy the URL, go to Outlook 2007 and create new email, CTRL-V to paste and NOTHING.

NOTE: someone in one of these comments mentioned that pasting didn't work when opening a new file, but if the destination was already open

So, same as above, but I opened a new email first, went to IE and ctrl+c to copy the URL, go back to the new email to CTRL+V to paste and worked. Tried first method again and didn't work

After disabling Bluetooth, I can copy URL, open new email and paste successfully.

I have tested and confirmed that this works on Outlook, Word and Excel 2007.

And I'm on Win 7 and SnagIt 12.2.2

thank you for this!! 

(Edited)
Photo of Thomas Winslow

Thomas Winslow

  • 1 Post
  • 0 Reply Likes
My recommendation - Do what I did. I gave up, uninstalled Snagit and went back to the free Windows Snipping Tool. At least it works, cannot say the same for the new Snagit. If Snagit wants the make the new product at least as good as the old product, I may go back. Until . . .
Photo of karen.shaw

karen.shaw

  • 3 Posts
  • 0 Reply Likes

the Snipping Tool is inadequate for what I have to use SnagIt for, unfortunately, otherwise I would skip it altogether.  Wish I had a Mac, wouldn't have this issue.

Photo of kurtsligh

kurtsligh

  • 2 Posts
  • 0 Reply Likes
This has happened on and off  for me over the years.  It's be aggravating as heck to say the least.  Sometimes it will copy/paste after the umpteenth try, sometimes it won't.  But here's what worked (this time) for me.  I changed the image I always use and went to the torn paper on bottom and right image.  It copy/pasted on the first try.  But that image is not really appropriate for most of my work so I immediately went back to my normal image and it continued to copy/paste.  Maybe changing images resets something and allows the copy/paste to start working again.
(Edited)
Photo of karen.shaw

karen.shaw

  • 3 Posts
  • 0 Reply Likes

Thank you very much -- that's very interesting -- will try it!

Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2899 Posts
  • 652 Reply Likes
Hi kurtsligh,

Can you give us a bit more information on your copy / paste issue?

What version are you using?
What are you trying to paste into?
What kind of image are you attempting to paste? SNAG file, saved image file, file with special effects, etc.

If you could be as specific as possible with what is happening, we will try to get you some help.

Thanks,
Kelly
User Assistance
TechSmith
Photo of karen.shaw

karen.shaw

  • 3 Posts
  • 0 Reply Likes

I sent the snapshots of the overlays that I am receiving in an email to TechSmith, but haven't received a response.

The copy paste is from SnagIt 11 into Word Proff+10.  Just a simple copy paste.

Thanks.

Karen


Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2899 Posts
  • 652 Reply Likes
Hi,
I don't have that version so I cannot test it. But, I think there are some things we can try to see if we can pinpoint the trouble. (listed below the image)

Also, as a Word user over the years, I have found they have certain settings they enable by default in various versions. So, it might be good to check out the copy / paste settings in your Options or Settings dialog box. I know specifically for me, the Smart Cut and Paste option has been the cause of paste problems. Maybe disable that feature then try your normal copy/paste to see if things improve.

For my version they are here:
 

Try these things and see what happens

In Snagit Editor, with your capture open, please try the following scenarios and see if any work:

1. Press Ctrl + A on the keyboard then Ctrl + C on the clipboard. Go to Word and press Ctrl + V to paste the image.

2. In the Tools tab >  Styles group box, click the Copy All icon. Go to Word, right-click the page, and choose Paste.

3. Drag a selection in your capture, then in the Tools tab >  Styles group box, click the Copy Selection to Clipboard icon. It's the small icon under the scissors icon. Go to Word, right-click the page, and choose Paste.

4. Copy your capture in any of the above methods and try pasting in another Microsoft program like Excel or PowerPoint. Does it work?

Kelly
User Assistance
TechSmith
Photo of mroorda

mroorda

  • 2 Posts
  • 1 Reply Like
I am having the same problem.  I am using Snagit 10.0.2 (build 21), purchased a long time ago. 

All day long, I have been capturing, and then editing in Snagit Editor and then pasting into Powerpoint.  Now, out of the blue, the paste action will not work into Powerpoint.  I can paste back into Snagit Editor if that is useful information.

As well, the problem is related to the addition or change of image styles.  I have been using the torn edge all day.  But now if I add a an image style (any style) then I cannot paste.  If I do not use a style then I can copy/paste just fine.  I can add a shape and then copy/paste fine.  But as soon as I add the image style, I can no longer paste. 

I have stopped and restarted the Snagit program and still have the problem.  As well, I cannot toggle the torn style off once I choose it.  Maybe related.
Thanks
Matt
(Edited)
Photo of mroorda

mroorda

  • 2 Posts
  • 1 Reply Like
Wait a minute....if I wait 10-15 seconds after copying, then I can paste.  All the above is still applicable, but if I wait, then the paste works OK.
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2823 Posts
  • 610 Reply Likes
Hi mroorda,
I'm glad things started working for you again.
I wonder if all the copy/pasting you have been doing all day in conjunction with running PowerPoint has caused a bit of memory congestion with your system.

Perhaps save your PPT then close PowerPoint. Do the same for other programs you are running, then open them again. I suspect things should work as expected.

Maybe even do a reboot of your PC.

Thanks for using Snagit!
Kelly
User Assistance
TechSmith
Photo of Kane Francetich

Kane Francetich

  • 2 Posts
  • 0 Reply Likes
mroorda, thank you for mentioning the wait time.  I have been frustrated with this for over a year, where I would have to keep copying/pasting for 5 minutes before one would finally paste.  Afterall, that's a normal workflow, right?  Copy something, then immediately paste it.  Now, if I count to 10 before pasting (do not even try pasting before then or you have to start over) I am able to reliably paste every time.  Not ideal, but much better than the frustration I've been dealing with.  BTW, I am using Jing rather than Snagit - same underlying engine from TechSmith, I imagine.  Thanks again.
Photo of Kane Francetich

Kane Francetich

  • 2 Posts
  • 0 Reply Likes
Follow up: Not sure if it is because I upgraded to Win10, or if Jing has been updated, but I have not had this problem for several months now.  It's been copying and pasting great.
Photo of delete13

delete13

  • 3 Posts
  • 2 Reply Likes
Hi Guys, i had the same issue than everybody here. The issue comes from 1 setting : copy to clipboard with transparency. You disable it and then, it works, you can paste in gmail or whatever. Enjoy ;)
(Edited)
Photo of Daniel Grzeszczak

Daniel Grzeszczak

  • 9 Posts
  • 0 Reply Likes
Hi. Please read carefully. Mac, Safari (only). Chrome works perfectly but I don't want to use two different browsers. I did not buy Snagit for Mac to use Chrome :)
Photo of Robert R.

Robert R., Online Community Admin

  • 1570 Posts
  • 475 Reply Likes
Hi;

Apologies for the mixup, however when I paste from Snagit into Safari 11, Chrome 64, Firefox 58, Opera 51, and Vivaldi 1.14, I have no issues with it working.

Are you using any security software or any clipboard utilities (I tried with both Alfred and PhraseExpress on and off and no issues)? How large are the images (in terms of resolution) are you using? When I copied content that was true 1280x720 it was quick, but an image at true 2560x1600 took a solid 5-10 seconds to paste (interestingly, it was the slowest with Chrome, taking closer to 10-12 seconds, likely due to the sheer size of the image)?

-Robert
Photo of Daniel Grzeszczak

Daniel Grzeszczak

  • 9 Posts
  • 0 Reply Likes
I'm happy that we understand each other. Thanks :) . I don't use any security software. I think (If I do) I wouldn't experience that problem via Chrome. Thank you for asking for images size. I experimented with small sized and dimensions as well. Nothing... :( Simple images not larger than 1920x. more like 320x, 1024 etc.

Gmail etc. doesn't work also via Safari. No idea what might be the reason if it. I cleaned up my Mac. got updates from Techsmith. Reinstalled the app. I'm experiencing this issue privately (MacBook Air) and at work (also MacBook Pro)
Photo of Robert R.

Robert R., Online Community Admin

  • 1570 Posts
  • 475 Reply Likes
Hi Daniel;

Perhaps I was unclear; I am not experiencing the issue with the aforementioned versions.

The recommendation I have now is to open a support ticket to see if there are any steps that can be taken to mitigate the issue. Note though that the issue likely stems from your Safari app itself, since you can paste into Chrome. It's worth mentioning that Chrome is Google's browser so if they changed something on the back-end (which they do all the time) other browsers will take time to update to accommodate said changes. However where that is rendered moot is that I am able to paste into gmail using Safari 11.

You can open a support ticket here; please be sure to reference this thread in your ticket.

-Robert
Photo of Daniel Grzeszczak

Daniel Grzeszczak

  • 9 Posts
  • 0 Reply Likes
I did open the ticket yesterday - https://support.techsmith.com/hc/requests/437996
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2899 Posts
  • 652 Reply Likes
Hi delete13,

Thanks for posting what worked for you! We appreciate that.
Kelly
User Assistance
TechSmith
Photo of Luke Betts

Luke Betts

  • 2 Posts
  • 0 Reply Likes
Thanks for the tip. But where do I disable this setting? I am using jing on a Mac OX. The problem I've had is pasting into GMAIL using Safari. Pasting works fine into other programs. Thanks!
Photo of Jennifer XtraMath

Jennifer XtraMath

  • 2 Posts
  • 0 Reply Likes
Hi. I was previously able to cut/paste jing screenshots into my gmail messages (using Chrome on Windows) but now it won't work. In fact, it makes Chrome freeze altogether.
Photo of Jennifer XtraMath

Jennifer XtraMath

  • 2 Posts
  • 0 Reply Likes
I updated Windows yesterday and it fixed the copy/pasting function for Jing. Problem solved!
Photo of Perry Butler

Perry Butler

  • 1 Post
  • 0 Reply Likes
I also have BIG problems with copy and paste - also using WIndows 10 Snagit12.
After working a while the problem come - only by rebooting can I get it back.
BUT - it is actually not only in Snagit, but the clipboard in general.
Sad to say - the Snipping Tools works - I would hate to go back to this.
Any suggestions?
Photo of kurtsligh

kurtsligh

  • 2 Posts
  • 0 Reply Likes
I randomly clicked on 'Image' and then chose one and saved. I now do that very often and haven't had the problem in more than a year
Photo of Chris Lawrence

Chris Lawrence

  • 3 Posts
  • 0 Reply Likes
I was fine with 12, but having moved to 13 the Ctrl-C doesn't work. I must click into the image and then do the Ctrl-C otherwise the image is not copied. This has badly affected productivity as there is one more stage to the paste, which over a day can add an hour or more. Not impressed!
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2879 Posts
  • 636 Reply Likes
Hi Jess,
This is a pretty old thread....
Have you opened a ticket with support to get help?
What version of Snagit do you have?
Was this working previously and just stopped working? If so, have you installed some other software lately? Have you rebooted your system to see if that helps?
Kelly
Photo of Jess

Jess

  • 3 Posts
  • 0 Reply Likes
I can't figure out how to open a ticket. Can you please help?
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
You can open a support ticket instead of posting in the community! We offer free, individual tech support from a team of knowledgeable agents, from 8am-7pm ET (GMT-4) Monday-Friday. Open a ticket at support.techsmith.com or call +1 517 381 2300.
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2879 Posts
  • 636 Reply Likes
Thanks, Paul!
Photo of Jess

Jess

  • 3 Posts
  • 0 Reply Likes
thank you!