Cursor cannot be captured in active window capture.

  • 1
  • Problem
  • Updated 3 months ago
I'm using the Snagit 2020.1.1 (64bit) Build 5510.

In the `Capture active window` of the `Window`, the cursor is not captured even if `Capture Cursor` is enabled.



If it is `Region (Select region at capture)`, the cursor will be captured.
I've tried re-creating the preset and changing the hotkey, but it doesn't solve the problem.

Could this be a bug in SnagIt?
Or is it a problem that can't be dealt with because of the specification of Windows or something?

Photo of Kurozumi

Kurozumi

  • 3 Posts
  • 0 Reply Likes
  • confused

Posted 4 months ago

  • 1
Photo of JL1

JL1

  • 351 Posts
  • 160 Reply Likes
I would suggest opening a support ticket. This is a users' forum.
Photo of Kurozumi

Kurozumi

  • 3 Posts
  • 0 Reply Likes
Thanks JL1.

I misunderstood that I was reporting a problem to TechSmith in this forum.
I will follow your advice and contact them with a support ticket.

Photo of Rick Stone

Rick Stone

  • 6638 Posts
  • 3199 Reply Likes
How exactly are you triggering the capture? By clicking a button or by using a keyboard shortcut?
Photo of Kurozumi

Kurozumi

  • 3 Posts
  • 0 Reply Likes
Hello Rick Stone.

I usually use the shortcut key. (Alt+PrintScreen)
By the way, even if I clicked the red Capture button, it didn't work.

Photo of Rick Stone

Rick Stone

  • 6638 Posts
  • 3199 Reply Likes
My curiosity is centered on the simple fact that if one is perhaps clicking the red capture button, well, where is the mouse pointer when the capture is triggered? My guess is that it's over on the red capture button and not inside the window or area you are capturing. So there's really no way to capture something that isn't there.

One workaround would be to use an image of the mouse pointer and just add it to the capture once complete. I'm not sure exactly what images may be included as I've been using SnagIt since what feels like forever. So I'm "tainted" in knowing what may be installed by default. Among my collection of stamps is a grouping named "interface". You might pop open your Stamps area and type "Cursor" and see if you have one listed.

Cheers... Rick :)
Photo of davidlambert

davidlambert

  • 407 Posts
  • 150 Reply Likes
I think it might be a bug as the settings as depicted above work fine on my device with both the 'big red button' and my hotkey (print screen, without 'Alt')



This image was cropped after window capture in order to reduce image size.
(Edited)
Photo of ehorwitz

ehorwitz

  • 42 Posts
  • 19 Reply Likes
The only thing I do differently is set the Time Delay to at least three seconds. That gives me time to click ol' Big Red, move my cursor to where I need it, and then have the capture frame appear with my cursor in the correct location.

But I gotta say I like Rick's idea of the cursor stamp. That covers a multitude of sins.