Cursor Jumping on Mouse Click in Recorded Video Preview and Rendered Video

  • 4
  • Question
  • Updated 6 months ago
  • Answered
My mouse cursor Jumps on Mouse Click in the Recorded Video Preview and Rendered Video.

I'm Using Win8.1
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 4
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Sorry to hear that you are experiencing this problem. What version of Camtasia Studio are you using ?There are a few things and options in Camtasia Studio that may or may not help with this problem. There can be lots of things causing any audio or video problems so more information the better it is for others to try and help.  Let us know and thanks for posting. Have a great day.
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Camtasia Studio 8.4.3
Latest build
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Do you have a sample video to look at ? Also, have you tried Unchecking the Use GPU acceleration if available or keeping a checkmark in that box under the Camtasia Studio 8 Tools>Options settings to see if that makes a difference. Another thing is how much memory does your computer have ? Check this and see if any of it helps and I hope this information helps a lttle and you like it. Thanks for posting and have a great day.
Photo of InfraChic

InfraChic

  • 4 Posts
  • 6 Reply Likes
Having the same issue.  Running Windows 10.  I'm on a Laptop with an Nvidia graphics card and second Monitor.  I've had to reduce my laptop's display resolution to 1280x864 as that's our standard recording setting for all videos.  I find that during recording my mouse works perfectly on my laptop. When I play it back with the Cursor Highlighted, any time I click the mouse jumps up and left.  It's very consistent. I've unchecked GPU acceleration, I have 16GB of ram.  The only things really running are Camtasia and the small program I'm running. Total ram usage: about 50% during idle and 75% during recording.  
I'm getting told that these videos ARE NOT acceptable due to the mouse jump.  Please help.  It's only started happening since I was forced to move to Windows 10.  I"m also having severe issues with my graphics accelerator on my card rejecting camtasia.  I've even had to go flip a few registry keys to get it to stop.  
For the cost of what my company and I pay I expect this program to work regardless of Graphics card driver.

Heidi
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Heidi I am sorry to hear of your experience and problem. I will not be getting Windows 10 my new laptop until Nov. 4th when it is completed. I wish I could try and reproduce this problem but I am still using Windows 7 and 8.1 and cannot get the same results you are currently having. From what you listed for your system specs it should be a good enough system to do the work and for the software. Are you using the latest version of Camtasia Studio and do you have an uploaded video we can take a look at that shows the issue ? Let us know and thank you.

On the other hand with this issue I would suggest that you also contact TechSmith Support and I have provided that information below for you. They are better equipped to help solve or find a solution if there is one to take a look at your project(s) that are giving you the problems. I hope you like and that this information helps you a little and please post back what you find out with the solution they give you for other users to see.

TechSmith Support Information

http://support.techsmith.com/

Phone: +1.517.381.2300
Toll Free: 800.517.3001
(U.S. & Canada Only)
8:00 AM to 7:00 PM EST Monday through Friday

Thanks for posting and have a great day/night.
Photo of Katie Cullen Montgomerie

Katie Cullen Montgomerie

  • 2 Posts
  • 0 Reply Likes
Hi there, I'm also on Windows 10 and have the same issue as Heidi. 

Heidi - could you please share if you have been advised of a solution to this annoying problem?

Thanks, 

Katie
Photo of InfraChic

InfraChic

  • 4 Posts
  • 6 Reply Likes
Yep easy fix. It's a DPI issue. You're DPI setting in Win 10 must be set to 100% and not 125% which is the default setting of Windows 7, 8, 8.1 and 10.
How to change that?  Right click in desktop go to Display settings.  In Display, scroll down and select Advanced Display Settings.  In Advanced Display settings select Advanced Sizing of Text and Other items.  Under Change Size of Items select Set a Custom Scaling Level.  In the Custom Sizing Options dialog change the Scale to this percentage of normal size: to 100% then select OK.  I believe you hit apply after the dialog disappears and accept any changes. It also may require a "reboot" of the system before it takes effect.

Heidi B.
Photo of Brent Schaus

Brent Schaus

  • 1 Post
  • 0 Reply Likes
Thanks, Heidi. That worked a charm.
Photo of francesco.todini

francesco.todini

  • 2 Posts
  • 2 Reply Likes
It's a pity when you have a 4K Monitor and you HAVE to use 150 dpi, otherwise you can't read a lot of what is on your Monitor!
Photo of Katie Cullen Montgomerie

Katie Cullen Montgomerie

  • 2 Posts
  • 0 Reply Likes
Cheers Heidi! Works perfectly now!
Photo of rectorsquid

rectorsquid

  • 1 Post
  • 0 Reply Likes
Hi, this is not really a fix since so many laptops are coming with high DPI screens these days. Instead of changing system settings, it would be better of Camtasia got fixed. Windows 10 has been around long enough for the developers to get a copy and fix this problem.
Photo of f.l.m.m.krijnen

f.l.m.m.krijnen

  • 1 Post
  • 1 Reply Like
Hello this problem is still there, will it be fixed ?
We testing version 9 (30days test), we use at the moment flashback pro.
This program cannot go faster than 15 fps, so Camtasia is maybe a better choice.
I am working on a UHD screen, putting it to 100% dpi is not real an option.
(Edited)
Photo of francesco.todini

francesco.todini

  • 2 Posts
  • 2 Reply Likes

With a 4k Monitor (28") you cannot read anything with 100% dpi. Is there a solution to this bug (other than 100%)?

Photo of kmakowski

kmakowski

  • 3 Posts
  • 0 Reply Likes
any update? I want to keep using the 125 option as this makes things easier for the end user to read
(Edited)
Photo of veprikae1969

veprikae1969

  • 1 Post
  • 1 Reply Like
any update? I want to keep using the 150 option as this makes things easier for the end user to read. Also, I can to use Camtasia on my laptop.
(Edited)
Photo of meganj

meganj

  • 1 Post
  • 1 Reply Like
I am having the same problem and changing the dpi is a poor solution. Has anyone found a work around? Also on windows 10 with 16 gigs of RAM and an Nvidia 940mx GPU.  Changing screen resolution works as a sudo zoom, but does not look good for the end user.  Is this problem on the road map? 
Photo of dharrel

dharrel

  • 2 Posts
  • 1 Reply Like
I am running into this as well, and am not very happy about it.  I wanted to use mouse click effects, however this problem makes these unusable.  
Photo of Rick Davidson

Rick Davidson

  • 2 Posts
  • 0 Reply Likes
I'm having this exact problem as well. Do Techsmith folks read this forum or is it just for users to air their problems and then go off and use another software?
Photo of Rick Stone

Rick Stone

  • 6586 Posts
  • 3157 Reply Likes
Hi Rick (nice name!)

I'm not a TechSmith person. I'm just another user same as you. But I can attest to the fact that I do see several official TechSmith reps engaging here. I've even seen the CEO post!

As for your issue, have you made any cuts in the video? I know that cuts are likely to affect the issue where the mouse may be in the process of moving, but when you cut something out, it appears to "jump" because that segment is now gone.

I'm not claiming that's the answer. Merely a possibility.

Cheers... Rick :)
Photo of Kajal Roy

Kajal Roy

  • 1 Post
  • 0 Reply Likes
I'm not a TechSmith individual. I'm simply one more client same as you. Be that as it may, I can validate the way that I do see a few authority TechSmith reps connecting with here. I've even observed the CEO post!
http://www.punebeauties.com
(Edited)
Photo of Rick Davidson

Rick Davidson

  • 2 Posts
  • 0 Reply Likes
Thanks for the replies!

Fellow Rick - I get this issue no matter what when I have my screen scaling at 125% (like someone mentioned above, I increase the scaling so that the content is more readable). I've spent a few painful hours now going through all the different scenarios - 1 monitor, 2 monitors, 100% and 125% scaling at 1920x1080, 250% at 4k, etc. Editing makes no impact, the raw recording has the mouse jumping (always up and to the left) when I click. I've looked back over my past videos and now that I've noticed it, I can see it happening everywhere - I'm surprised that my viewers haven't mentioned it! It became super apparent when I went to add cursor click effects. Its not happening on my screen itself as I'm making the recording, it only appears on the trec recording file. 

From all of my investigation, it seems that setting screen scaling  is the to 100% is the known fix, but that is not a viable option for me. 

If anyone has any other ideas aside from screen scaling I'd love to hear it and give it a try.

Thanks.
Photo of Joe Morgan

Joe Morgan

  • 8751 Posts
  • 4665 Reply Likes
Have you tried recording directly to to AVI?


You could try extracting the contents or your existing .trec's and see if that solves the jumping cursor in those recordings.
Just place the .trec in the media bin and right click.
.trec is a container format. The cursor information is separate. If you extract the AVI that information should be flattened and therefore,  might not jump?


Regards,Joe

I'd like to hear back from you if either method works. Fail or Success.
Photo of dharrel

dharrel

  • 2 Posts
  • 1 Reply Like
I posted about this two months ago, and found Techsmith support very responsive.  I experienced the cursor jumping problem when recording on a laptop with no external monitor connected.  Support suggested I update my video drivers, which did not help, and then try recording with an external monitor connected.  The cursor jumping problem no longer occurred in recordings when the external monitor was connected!  

It seems this problem occurs under different circumstances, and what worked for me will not work for all.  
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Here I am again (original poster of this thread) and having the same issue four YEARS later.

I'm up against a huge production deadline and been working along with no issues. WIN 10 and 125% scaling (client contract specification) without issue... until today. The jumping is back! I have windows updates disabled and have not made any changes to the system since yesterday... when it was working fine at 125%
I'm happy to provide a system nfo file or belarc report if this would help troubleshoot.

PLEASE, PLEASE, PLEASE!! help me resolve this.

running V9.1.2 (build 3011) - Mar 5 2018 (64-bit)
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Just an update: I was asked by Aaron from  Techsmith to provide a dxdiag report this morning. I sent it along. I did take a look at this when I started having the issue a few days ago and noticed there are two DPI settings and they weren't set at the same values. I cant seem to figure out where/how to edit the User DPI value or if i even can or could even be part of the problem or if this is normal.
(Edited)
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Aaron responded (thank you) asking me to do the following:

Please update Video Driver: http://us.download.nvidia.com/Windows/Quadro_Certified/391.58/391.58-quadro-grid-desktop-notebook-win10-64bit-international-whql.exe

Update Touchpad Driver: https://downloads.dell.com/FOLDER04210938M/3/Dell-Touchpad-Driver_9HG8R_WIN_10.2207.101.108_A00_02.EXE

Once that is done, please do the following:

- I would like you to do the following:
1. Open your task manager (ctrl + alt + delete) and click on the Processes tab and make sure CamtasiaStudio.exe is not running. If it is, right click on it and click End Task.
2. Hold the windows key down on your keyboard and hit the R key to open the Run Window.  Type regedit and select OK to open the Registry Editor
3. Browse to HKEY_CURRENT_USER\Software\TechSmith\Camtasia Studio\9.0 and delete the 9.0 folder.
4. Click on your Start Menu. Click on All Programs or All Apps. Scroll down to Techsmith and click on Camtasia Studio.
5. See if you have the same issue!
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
I accomplished what was suggested and sent the following response to Aaron:

Hi Aaron,

 Thanks for the response and suggestions.

Yes, I had been fiddling with the nvidia settings trying to get it working and had scaling set to 100% when I ran the dxdiag you requested.

 I have accomplished each of the steps in detail and unfortunately still have the issue.

 I installed the suggested nVidia driver (custom > Clean Install)

 

touchpad driver suggested was already installed (I reinstalled)

 Set to preferred/required settings in windows Display settings:

1920x1080

125% scaling

 deleted the registry folder indicated.

 I have provided a new dxdiag report taken following the above efforts.

 Let me know what else you’d like me to try or info I can collect.

 We have some systems here having the issue and others that don’t

Photo of kmakowski

kmakowski

  • 3 Posts
  • 0 Reply Likes
Keep bugging them bverboort! Thanks for fighting this battle for all of us :)
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Hi all stakeholders. I haven't gotten any further instructions or requests for infomation. This is still an issue for me and others here. Could someone from support please provide a status?
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
Still hoping to get some sort of update and a resolution on this. In the process of continuing to try to find a solution on my own, I found this post. https://feedback.techsmith.com/techsmith/topics/camtasia-8-cursor-in-wrong-place Is this the same issue? Is there an open support ticket for this report. What about this thread? Is there an open support ticket? if so, is there a case ID and disposition associated with it? Can someone there at Techsmith please render some sort of response or something we can try that may help with trouble shooting? Has the support team been able to reproduce this issue?
Photo of kayakman

kayakman, Champion

  • 7758 Posts
  • 2707 Reply Likes
recommend you contact free tech support and ask them directly
Photo of bverboort

bverboort

  • 9 Posts
  • 0 Reply Likes
I have previously and recently been in direct contact with them. request (#460212)
Photo of si_edgey

si_edgey

  • 2 Posts
  • 1 Reply Like
Hi folks, am I right in saying that we're 5 years down the line and this issue still persists? I have recorded 12 hours worth of footage (in 9.1.5) and have noticed while editing that the cursor jumps every time I click somewhere. It's very annoying to watch.

I tried the demo of Camtasia 2019 and it still does it, in fact the cusror smoothing effect makes it even worse as the cursor appears miles away from where it's supposed to be.

Did anyone find a fix or workaround so that the content is still usable?
Photo of Joe Morgan

Joe Morgan

  • 8751 Posts
  • 4665 Reply Likes
Theres an age old remedy of recording directly to avi.
However, you can only capture one audio stream.
Effects like cursor effects won't work.As its not a container format with that information.Everything you record is burned in. And not editable.
To record burned in cursor effects......


To record directly to avi

Photo of Rick Stone

Rick Stone

  • 6586 Posts
  • 3157 Reply Likes
Joe's method is good, but you did ask if there may be a workaround so that you may use what you already have. So here goes!

Another possibility would be to simply cut the recording just before and just after the cursor jump. This should isolate that segment where the "jump" is happening.

Then configure the cursor to be invisible by adjusting the opacity. 

Once that has been done, insert an image of the cursor at the click location.

Cheers... Rick :)
(Edited)
Photo of si_edgey

si_edgey

  • 2 Posts
  • 1 Reply Like
Thanks for the suggestions guys, much appreciated. Sadly I can't go back and re-record the full 12 hours as .avi and I have a very high CPM (clicks per minute!) so to do that edit every time I click over the full 12 hours would take longer than rerecording! 

It seems crazy that Techsmith hasn't been able to deal with this after all these years - it is surely an easy solution as they have the cursor data, it happens so consistently and appears to jump a consistent distance too.

I'm unsure what to do with my content now as it seems so unprofessional having the cursor jump all over the place. Any further suggestions would be great...!

Note to self: ALWAYS SET ZOOM IN WINDOWS 10 TO 100% BEFORE RECORDING!
Photo of Rick Stone

Rick Stone

  • 6586 Posts
  • 3157 Reply Likes
12 hours? In a single recording?
Photo of Rick Stone

Rick Stone

  • 6586 Posts
  • 3157 Reply Likes
Your situation seems to nicely illustrate a need for a change with respect to how Camtasia handles the cursor.

First off, a disclaimer. I'm fully aware that Adobe Captivate and TechSmith Camtasia are two different tools with different design paradigms. But having had considerable experience with both, I see no reason why Camtasia can't borrow nice and interesting aspects of other tools.

See, over in the Adobe Captivate world, a project consists of slides. In much the same way Microsoft PowerPoint operates. Captivate is kind of like PowerPoint on steroids, if you will.

In the Captivate world, you can create a blank project in much the same way that you can in PowerPoint. And likewise, we can create a new and empty project in Camtasia.

In Captivate, you have a choice to record screen activity. And when you choose to record, you can record in a video type format that is very similar to Camtasia's, or you can record in a simulation type format. In a simulation type format, you end up with many slides that have background images and a mouse path. And on the first slide where mouse movement occurs, you have full control over the mouse beginning point as well as ending point for the mouse path. And you are able to choose whether that movement is in a perfectly straight line or if it's curved. And as a bonus, you can also choose the mouse pointer if you like. I believe it looks at the different cursor files installed on your system.

For each subsequent slide, all you can control with the mouse placement is where the mouse stops. Because the starting point for each slide is determined by where the mouse stopped on the previous slide. This provides for good continuity.

And even if you haven't recorded anything, you are still able to add mouse movement later. You just choose to enable it for the slides you want and off you go.

It would seem that TechSmith has the capability of separating and isolating mouse movement. Otherwise, there would be no way to make it invisible. Or to use that new "smoothing" feature they recently developed.

So it sure would be nice to see TechSmith take some plays from the Adobe playbook on Captivate. Perhaps offer a new "track type" for a Mouse. Allow the Camtasia user to configure starting coordinates and ending coordinates by clicking and dragging the mouse pointer on the canvas. Offer nice little animations that represent clicking or tapping or whatever. 

Cheers... Rick :)
Photo of kayakman

kayakman, Champion

  • 7792 Posts
  • 2718 Reply Likes
I've never experienced the cursor jumping issue; using 23019.0.8. now, still not occurring, 

since you have the 12 hours of content, and cannot re-capture it [as AVI] , to move forward, you'll likely have to use what you have

Rick's suggestion is a good one, but I'll offer a slightly modified approach [either will require tedious additional editing]

make timeline selection[s] from before to after cursor jump; cut the selection [auto stitching off]; if appropriate, add a short duration transition at the split

perhaps that might also work?