Deployment Tool - Configuring HKCU keys does not work

  • 1
  • Problem
  • Updated 3 months ago
Hi

I want to fix those bugs within the Snagit 2018 transforms file:
https://support.techsmith.com/hc/en-us/articles/360005540571
https://support.techsmith.com/hc/en-us/articles/203731288

Using these keys:
[HKEY_CURRENT_USER\Software\TechSmith\Features\snagit]
"AllowOpenAllAudioAtStart"=dword:00000000

[HKEY_CURRENT_USER\Software\TechSmith\SnagIt\18]
"SimplifiedCrosshairs"=dword:00000001


I set everything how I want it to be configured and capture the registry settings on a clean machine like this.
https://support.techsmith.com/hc/en-us/articles/203730778

I'm using the current deployment tool 1.17.0.79
https://support.techsmith.com/hc/en-us/articles/115002617692

But it does not work like others mentioned:
https://feedback.techsmith.com/techsmith/topics/snagit-deployment-tool-capture-profile-presets

When I open up the transform in Orca there are no registry keys except some option keys you could disable through check boxes. There is a custom action but I'm not sure what this does.
When I install my custom package my settings are not configured. Not in the current user profile, not in the default profile, nowhere!

I expected this option to configure my transform using those HKCU keys and make them available through ActiveSetup or AutoRepair when a user starts Snagit for the first time. Of course I will be installing the package through SCCM under SYSTEM account. Therefore it makes no sense to just write the keys to the installing user profile.

So, what was the intention of this option? How should this work? Why does it not work?
Photo of ilovepowershell

ilovepowershell

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 3 months ago

  • 1

Be the first to post a reply!