Do i need to purchase a new version of snagit if i am running snagit 1.0.4 on MacOS Sierra version 10.12.2?

  • 1
  • Question
  • Updated 2 years ago
Photo of Mary Retallack

Mary Retallack

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 707 Posts
  • 175 Reply Likes
Hi,

If Snagit 1.0.4 is working on Sierra, then you can keep using it. If it's not working or if you'd like to be on the latest, version 4.0.7 is a paid upgrade, but the price is reduced for users upgrading from older versions. More info here: https://www.techsmith.com/snagit-upgrade.html

I hope this helps!