Downloading Assets to Camtasia 9.1.2 Library

  • 1
  • Question
  • Updated 5 months ago
  • Answered
Hi there, I've downloaded all the assets from Techsmith's Download page in it's original form as 

How do I upload the whole thing into Camtasia's Library or do I have to Unzip, upload on a folder level or upload each element individually?

Thank you.
Photo of Ceelin


  • 5 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of kayakman

kayakman, Champion

  • 7347 Posts
  • 2496 Reply Likes
drill into the zip folder; what is inside?  can you post a screenshot of part of what you see?
Photo of Joe Morgan

Joe Morgan

  • 8034 Posts
  • 4345 Reply Likes
He worked it out,
Oddly enough, the assets for Camtasia 9 downloaded directly from TechSmith

Come as a .zip not a .libzip
I downloaded it and was creating screen shots for importing a .libzip earlier this morning.
I even deleted some assets to show what would occur along the way. So I renamed the file .libzipAnd Camtasia 9.1.2 told me the library was created with a newer version of Camtasia and cannot be opened.
So the downloadable assets are all screwed up. 
Photo of Ceelin


  • 5 Posts
  • 2 Reply Likes
That's right @Joe Morgan. It comes as a .zip. For .lipzip, the double-click instructions work perfectly.

@kayakman, for .zip folder, I had to drill all the way down to the assets and upload that way by importing to library. Thanks for the help guys. 
Photo of chancellor.wyman


  • 1 Post
  • 0 Reply Likes
The instructions aren't correct.  There's no libzip file.  There is a libpkg file, which I tried to just import that alone and Camtasia doesn't recognize it.  I did try renaming the extension to libzip and while Camtasia does open, it did nothing with it.

Since I'm using Camtasia 9.1, I decided to try renaming the downloaded zip file instead.

Double clicked on it, Camtasia opened, and after about 5 minutes, the library was updated.  Guess you just need to make sure you're using the right version and have it fully updated.  Camtasia support should update those instructions though.